PDA

View Full Version : Compatibility issues?




R94N
Aug 31, 2010, 02:47 PM
Okay, now I don't own a PowerPC Mac, but a caller on the Tech Guy recently reminded me of this - are any of you guys starting to experience compatibility issues with your computers - like no updates/older software etc? Or you do tend to use the programs and such that were around when the PowerPC Macs were around and work?

Some insight would be much appreciated. Thanks. And I don't want to make this a full-on debate about PowerPC vs. Intel or anything like that, I would just like to know how you guys work.



max••
Aug 31, 2010, 03:40 PM
most of the compatibility issues i find are 10.4 vs 10.5 and g3 vs g4 most apps i find will run on a g4 with 10.5 but some apps like itunes 9 or the newer pre built versions vlc will not run on my ibook g3 with 10.4.11

randomerratum
Aug 31, 2010, 03:56 PM
I have a PowerPC G5 circa 2004/5

It's still a workhorse and with Leopard and some new RAM I recently added it runs better then the day I bought it... it even still holds it's own against newer machines I work with.. while it might be slower and a bit more cumbersome in places, I've integrated it into many Final Cut Pro workflows when I just need a machine to crunch on some video compressions or need to loan it out to a client.

For the most part, I do all of my work primarily on my new MacBookPro (1 year old) and on my client's editing systems. I'm holding on to Final Cut Studio 2 for the moment, but as my clients upgrade, it's apparent that I'll have to follow suit pretty soon. Since my G5 only supports FCS2, it's going to make things more complicated when I want to use it in workflows... yes, there are work-arounds, but you can only add so many hoops to jump through before an additional tool like this just becomes impractical.

To be honest, I never expected this thing to be relevant for so long... having grown up on PCs, I expect a computer with heavy use to last little longer then 2 years before I have to replace/overhaul it completely... it's just a shame that here's this fantastic machine that's fully capable of doing some heavy lifting, yet due to a handful of conflicting software versions it's sort of become the basic 'home computer' rather then the loyal stallion it once was.

VanneDC
Aug 31, 2010, 04:57 PM
I do a lot of video codec compression with my family of G5's, and mostly use handbrake.

for about 8 months there, i was using the older version of handbrake (ppc) as VLC didnt wanna play ball with it, turns out it was a VLC issue and the VLC webby just downloads the 64bit version. I finally found the 32 bit version that runs with the newest version of HB on vlc's FTP site.

Great steaming from now on. :)

PowerGamerX
Aug 31, 2010, 07:27 PM
I've only recently noticed it with my PowerBook. G5's are still supported by a variety of software.

However, if you just use software that was designed for your machine in the first place, it will run very, very, well still. (However, I can't stand Tiger compared to Leopard)

R94N
Sep 1, 2010, 01:17 AM
(However, I can't stand Tiger compared to Leopard)

Can I ask why? Are there major differences, or...?

MacHamster68
Sep 1, 2010, 04:02 AM
for me its the opposite i cant stand leopard , on all my G4/G5 i noticed a huge drop in speed when running leopard so i still prefer tiger which even gave my G5 powermac dual 2.3 a huge speedboost ..the previous owner had leopard installed on it :(
an as i said in another post ....if the app is 5 years old, it doesn't make the app unusable
on one of my iMac g3 i run even os9 and use claris works a app which is over 10 years old and it still is perfectly usable to write all my business letters and receipts :)

R94N
Sep 1, 2010, 07:22 AM
an as i said in another post ....if the app is 5 years old, it doesn't make the app unusable
on one of my iMac g3 i run even os9 and use claris works a app which is over 10 years old and it still is perfectly usable to write all my business letters and receipts :)

I understand exactly what you mean - older programs work just as fine. I just wanted to hear about whether people are having running any compatibility issues running older hardware and Mac OS.