PDA

View Full Version : Cannot disable Classic environment at startup




JULIAGOOLIA
Sep 1, 2010, 08:59 PM
:confused:
I cannot get the Classic environment to not automatically start when either I restart or turn on my PowerBook.

I've had this problem ever since someone needed to use my computer with a program that was for a prior operating system, once we found out that the only way for it to work on my Mac would be to wipe my current operating system and revert back to the Classic operating system, which of course at that point we stopped with the process.

Ever since then, the 9 is always bouncing in my dock, and when I go into system preferences I cannot uncheck the "Start Classic when you login" option, it is greyed out for some reason.

I've attached a screen shot, I have more of what happens when I login and I can post if it would be helpful.

:apple:Thanks.



MacForScience
Sep 9, 2010, 10:10 PM
To be of any assistance I need some details:
So you have a power PC what version of mac OS are you using?

Also what application did they run that started the issue?

Can you quit the classic environment after it starts or does it perpetually run?

Cheers

MacHamster68
Sep 10, 2010, 03:16 AM
i think thats the problem , you started to use classic an then stopped in the middle of the process , now poor classic is looking for your OS9 partition on every startup and cant find it :(so either you install OS9 in a partition on your harddrive or you reinstall the OSX



or i found this thing , cant make much sense of it , but never mind i need my classic for all my OS9 programs and games so i dont need to make sense out of it ,cant even imagine not having classic on a Mac , as for me classic belongs on a Mac like the little Apple
anyway thats what i found googling

1st way

" go into terminal and cd to your /Applications folder and su to root. then just enter the command:
chmod -x Classic.app
that's it. no more hassle. i tried starting classic after this and it doesn't do anything. no errors, no nothing. nice to finally be rid of that"

2nd way

"Trash the System Folder. No System Folder, no Classic!

(note: a folder named System Folder, not a folder named System!)"

3rd way

"Just navigate to the root of your drive and trash:
1) System Folder
2) Applications (Mac OS 9)
3) Any other folders you've used in OS 9 that aren't needed for X. The default X folders should be:
System
resources
Applications
Users
sw
Developer (you probably don't have this one)
Library

Just be careful to only trash folders that you're sure OS 9 or you created. Do not touch any folders or files that you're unsure of. "

one or the other should work, god i would get mad without OS9 on my Mac's

lewis82
Sep 16, 2010, 06:06 PM
Click on the lock icon. Type in your admin password. ;)

EDIT: didn't read correctly. Still, it might give you the option to deselect the greyed-out checkbox.