PDA

View Full Version : Handbrake doesnt take mkv-file: "no valid source found"




Microsaft
Sep 2, 2010, 06:10 AM
Hey all,

I just ripped my first BD (Avatar) using MakeMKV.
When I open Handbrake to get it ready for Apple TV, Handbrake just says "no valid source found".
VLC does play the file without any problems (with subtitles).

I tried to search the forums for others having the same issue. Somebody mentioned that you have to de-click the subtitles when ripping with makemkv. My problem is that I cannot do any settings?!
http://www.abload.de/thumb/bildschirmfoto2010-09-9csq.png (http://www.abload.de/image.php?img=bildschirmfoto2010-09-9csq.png)


(I am running the "Mac" build from https://build.handbrake.fr/ )

How can I do language / subtitle-settings in MakeMKV or what else am I doing wrong? Any suggestions?



drdauger
Sep 29, 2011, 01:43 PM
Use the turndown triangle to open the main title (usually over 20 GB) of the Blu-ray. It should expose Video, the Audio, then Subtitle tracks. There you can disable all the Subtitle tracks by removing those checkmarks.

obsidian1200
Sep 29, 2011, 02:50 PM
Use the turndown triangle to open the main title (usually over 20 GB) of the Blu-ray. It should expose Video, the Audio, then Subtitle tracks. There you can disable all the Subtitle tracks by removing those checkmarks.

Or, if you don't want to sit through another MakeMKV section, you should be able to remove the subtitles with MKVtools and leave the video and audio intact.

If I recall, Avatar doesn't have burned in subtitles, so you'll either need to make a subtitle file that you can use with handbrake, or search the internet for one (I'd suggest the latter, as it's much easier imo).

stiwi
Feb 12, 2012, 08:03 AM
MKVTools didn't want to read this file either. But I think that I found a solution why. In my case it was due to file permissions. I had to click "get info" and add myself under "sharing & permissions". Then Handbrake had no more issues in reading the source.