PDA

View Full Version : Dual 2.7ghz PowerMac G5 keeps giving me date problems and turns off randomly




212rikanmofo
Sep 2, 2010, 06:54 PM
My powermac has been giving me lots of strange problems lately. I had it for about 7-9 years now, and i usually never turn it off. It acts as a fileserver. But yesterday when I decided to finally put it to sleep and turn it back on the following day to use it, it randomly just completely shut down on me and upon pressing the power button, nothing happened, it won't even turn on.

So I unplugged everything, open the case up to clean the dust out somewhat, and then press the PMU reset button, and turned it back on and it works. But it will randomly shut itself off afterwards. Once I got into the desktop it gave me pop up window saying my system may behave erracticly because the system clock is set to Dec 1, 1969. So I had to go into my date/time preferences and have the computer set the time via internet. Is it because of this I am having these problems? Seems like I need to replace that circle battery thing inside my computer?

Not sure what else would keep making my machine shut off randomly like this. Please help.



raysfan81
Sep 2, 2010, 07:53 PM
My powermac has been giving me lots of strange problems lately. I had it for about 7-9 years now, and i usually never turn it off. It acts as a fileserver. But yesterday when I decided to finally put it to sleep and turn it back on the following day to use it, it randomly just completely shut down on me and upon pressing the power button, nothing happened, it won't even turn on.

So I unplugged everything, open the case up to clean the dust out somewhat, and then press the PMU reset button, and turned it back on and it works. But it will randomly shut itself off afterwards. Once I got into the desktop it gave me pop up window saying my system may behave erracticly because the system clock is set to Dec 1, 1969. So I had to go into my date/time preferences and have the computer set the time via internet. Is it because of this I am having these problems? Seems like I need to replace that circle battery thing inside my computer?

Not sure what else would keep making my machine shut off randomly like this. Please help.

I think a dead PRAM battery would cause the weird date problem as for the random shutdowns I really don't know if they are related.

VanneDC
Sep 2, 2010, 08:14 PM
nah mate, it wouldent be cause the computers date is out, thats a by product of whatever is causing your issue.

maybe the mobo batterys empty?

*shrugs*

Chuck Fadanoid
Sep 3, 2010, 06:33 AM
What do your error/system logs in Console say? Might be thermally related and mean leaky coolant?

MacHamster68
Sep 3, 2010, 10:23 AM
its definitely time to change the pram battery
as thats exactly the symptoms caused by a dead pram battery had the same symptoms plus one more it lost the screen resolution on my emac , changed the battery and fine again :)
sometimes these batteries just die and there is no date due for changing it its randomly some last only a couple years ,on my eMac from 2006 for example just 4 years others like on my iMac g3 lasts 10 years and still working ...touch wood

212rikanmofo
Sep 3, 2010, 10:37 AM
what type of battery and where can i buy it?

Hrududu
Sep 3, 2010, 11:02 AM
It should be a small 3.6v half AA battery on the motherboard. They can be found at Radioshack.

CubeHacker
Sep 3, 2010, 03:11 PM
A dead battery would cause the loss of time/date when the computer is unplugged, but it should not cause any kind of crashes or random shutdowns, or prevent the computer from starting. I have an iMac G3 that has a dead battery for the last 6 years, and it runs just fine. Your problem lies elsewhere.

Are you sure your coolant isn't leaking? Bad capacitors? Dying PSU? I would look into all of those.

MacHamster68
Sep 3, 2010, 04:01 PM
yes the iMac will start up without pram battery so do most Mac's , so do most eMac but not all , but mine was a different matter as i have two harddrives inside and they had been in a raid setup and this info is stored too in pram and can cause problems
read here , raid is bad in case of a dead pram and dead is like resetting all the time
http://support.apple.com/kb/HT1242
especially the link at the bottom of the support site

the pram is a mystery as not all Mac' react the same if you reset pram or have a dead pram battery

but you are right it could be the psu or even the logicboard , but the pram battery cost next to nothing compare to a logicboard or a psu , so just replacing the little battery and exclude the pram battery as cause of the problem and at least the mac remember the time and date and maybe the other symptoms are gone too with a bit of luck as a psu or logicboard does not come cheap to repair
__________________