PDA

View Full Version : iPod touch 1st gen restore error 20.




raysfan81
Sep 5, 2010, 02:24 PM
I was trying to downgrade my touch to firmware 2.2.1 and it keeps giving me error 20 and I have the screen looking like this attached image. Help me please! :(



kaiserkid
Apr 10, 2013, 01:02 AM
I was trying to downgrade my touch to firmware 2.2.1 and it keeps giving me error 20 and I have the screen looking like this attached image. Help me please! :(


I am having the same problem. Bought the iTouch on ebay, they didn't state what the problem is but from what I can tell someone attempted to jailbreak it and failed.

It first did error 9 at the apple store, apple told me I was "SOL" and I could buy an entire new phone for the small price of $270 with the "generous" 10% discount they were giving me.

Now after searching forums, I've got it to do error 20...not sure if this is better.

Apple knows how to fix this but refuses to help unless I give up and buy a new device.

Has anyone been able to fix this problem? I'm willing to use any program that could fix this.

The13thDoctor
Apr 13, 2013, 07:19 AM
I am having the same problem. Bought the iTouch on ebay, they didn't state what the problem is but from what I can tell someone attempted to jailbreak it and failed.

It first did error 9 at the apple store, apple told me I was "SOL" and I could buy an entire new phone for the small price of $270 with the "generous" 10% discount they were giving me.

Now after searching forums, I've got it to do error 20...not sure if this is better.

Apple knows how to fix this but refuses to help unless I give up and buy a new device.

Has anyone been able to fix this problem? I'm willing to use any program that could fix this.

I'm not sure if this applies to iPhone OS, but I think the signing period for the firmware has long passed and since you're on a jailbroken device, it doesn't let you restore anymore.

Bear
Apr 13, 2013, 10:26 AM
I was trying to downgrade my touch to firmware 2.2.1 and it keeps giving me error 20 and I have the screen looking like this attached image. Help me please! :(In general Apple will only let you install the latest firmware for the device in question. You should be able to restore it to the latest firmware it supports. I am curious as to why you want to downgrade it.

I am having the same problem. Bought the iTouch on ebay, they didn't state what the problem is but from what I can tell someone attempted to jailbreak it and failed.
....Have you tried following iOS: Unable to update or restore (http://support.apple.com/kb/HT1808) and make sure you're trying to install the latest firmware for the device.

kaiserkid
May 16, 2013, 01:28 AM
In general Apple will only let you install the latest firmware for the device in question. You should be able to restore it to the latest firmware it supports. I am curious as to why you want to downgrade it.

All the forums that I've found suggest to first downgrade it to the version I stated above. I've tried a multitude of versions of which none work.

Have you tried following iOS: Unable to update or restore (http://support.apple.com/kb/HT1808) and make sure you're trying to install the latest firmware for the device.


Have also tried this and to no avail. I'm on a never ending loop of error 9, error 20, and sometimes will get the "Could not be restored the device cannot be found".

The iTouch is in an never ending cycle of this. Apple techs haven't been any help. Does anyone else have any suggestions? I've tried several "repair programs" for iTouch and they haven't worked. I've uninstalled and reinstalled iTunes so many times I can't count.

Any suggestions would be appreciated.

pod5g
May 16, 2013, 07:53 AM
I was trying to downgrade my touch to firmware 2.2.1 and it keeps giving me error 20 and I have the screen looking like this attached image. Help me please! :(

Why do you want to downgrade it? The latest version available for the original iPod touch is 3.1.3, which has been jailbroken.

IpadSC400
May 16, 2013, 10:22 PM
My iPad was jailbroken and it was able to restore...:confused: It's version software 5.1.1