PDA

View Full Version : What's the deal with Quicktime & H.264 Playback?




Nobby82
Sep 10, 2010, 12:14 AM
I've developed a commercial MPEG4 container solution which uses ANNEX B H.264 compliant video. The encoded media plays back fine in every Mac OS and Windows based media player I've tried, except for Quicktime.

Quicktime X under Snow Leopard is rediculously buggy. It stops animating playback after a random amount of time (1-3mins). Seeking back through the media and resuming playback is fine but beyond the specific point, animation completely stops but playback time continues to increase.

Quicktime 7.6.7 under Windows plays back fine, as long as the file is under 1GB.

VLC Media Player is the only player under Mac OS I've tried that plays back the media flawlessly.

I've spent a lot of time looking around consumer forums and found no educated discussion on current MPEG4 compatibility with any Quicktime versions/platforms. I was wondering if there were any QTAPI devs out there that could share their H.264 experiences.

Thanks a bunch!!



GorillaPaws
Sep 10, 2010, 12:46 AM
One resource you might want to check out is Apple's "Quicktime-API" mailing list (http://lists.apple.com/mailman/listinfo/quicktime-api), if you haven't already. I have no idea how active that list is, but it's worth looking at.

Consultant
Sep 10, 2010, 01:03 AM
Someone doesn't realize Apple / QuickTime is well known for its use of H.264?

I bet you used the wrong encoding profile.

Nobby82
Sep 10, 2010, 01:42 AM
Someone doesn't realize Apple / QuickTime is well known for its use of H.264?

I bet you used the wrong encoding profile.

I'm using the profile matched to the media I'm archiving. Baseline profile, 3.1 level (based on macroblocks per second calculated by a function of frame resolution and frame rate). There's no B-Frames/Predictive vectors.

Given that VLC media player, WMP and Windows Media Center all handle the media fine and going by your assumption that I've done something wrong, why wouldn't Quicktime handle an encoding profile missmatch the same way these other media players do?

Nobby82
Sep 10, 2010, 01:43 AM
One resource you might want to check out is Apple's "Quicktime-API" mailing list (http://lists.apple.com/mailman/listinfo/quicktime-api), if you haven't already. I have no idea how active that list is, but it's worth looking at.

Thanks for this, i'll take a look at it this weekend.

Ritsuka
Sep 10, 2010, 01:43 AM
Or maybe there is something wrong with your mp4 file. QuickTime is not forgiving at all.
Can you post a little sample?

xStep
Sep 11, 2010, 03:26 AM
You didn't mention if you tried using QuickTime 7 Player on OS X. Perhaps there is a difference between that and the newer less tested QuickTime X.