PDA

View Full Version : PAL and NTSC for my TV out...


brap
Dec 19, 2004, 07:33 AM
Need a little help. I want to be playing some Sonic the Hedgehog on my 28" TV.

My Powerbook is an imported US model, so the VGA out defaults to 60hz. My TV is, however, very old, and very PAL.
Problem is, I can't see the video settings dialog in the window to change it! Fix me please?

Edit: I'm using composite out, since I lost my S-VHS cables somewhere (I know, I know). I'm using a DVI output 12" Revision C Powerbook, 10.3.7.

brap
Dec 19, 2004, 08:12 AM
OK, can of worms, perhaps. There are unanswered posts on Apple discussions on this problem, and the only thing in the kb is a list of modes for the adapter. Apparently, it can output PAL. Well, that's nice to know Steve, care to tell me how?

Nothing in MacOSXHints... nothing in the archive here... I need my video game fix already!

brap
Dec 19, 2004, 08:40 AM
OK, now we have a new problem.

By setting displays to mirror, I can change prefs for both on my PB screen. It seems the composite out is being detected as a VGA display and not a TV; therefore refresh rates below 60Hz aren't shown.

Someone please chime in with something, I feel like one hand clapping...

erik1975
Dec 19, 2004, 09:14 AM
I have the same computer as you, a 12" 1.33 Powerbook. I bought it in the UK, but was in America a few months back and got the mini-dvi to video adaptor. (I assume you are also using this adaptor). I had a lot of bad luck getting the signal to show up on the televisions I had hooked it up to. I thought it was an NTSC/PAL issue. I went into an Apple store and showed that the input did not work, but they would not replace it since I bought it from Amaon.com, and not Apple! I was highly disappointed.

At this point I had one week left in America, and wanted to be able to hook the Powerbook to a television so I could show family members videos/pics from my Powerbook.

I returned the cable to Amazon and bought a new one from MicroCenter. Funny enough the Apple store did not keep them in stock, but a computer store down the street did.

Long story short, the new one works perfectly. I have found threads in the Aple Support Forums where people have also found hit and miss reliability with these adaptors.

I suggest replacing it and hope the new one works.

brap
Dec 19, 2004, 09:18 AM
I have the same computer as you, a 12" 1.33 Powerbook.
<snip>
I suggest replacing it and hope the new one works.
Thanks for your reply. It outwardly looks like a software problem, but I guess if the hardware isn't announcing it's intentions then everything will be stuck.

Sigh. I'll take it into a reseller near me and have them take a look.

TEG
Dec 19, 2004, 09:22 AM
If you are using the DVI output, you must use a converter that will change the frequency. DVI is always at 60hz or 75hz. I'd suggest going on to apple.com and purchase a new S-Video to RCA adapter. Once that is done, it will detect it as a TV and allow you to set it to NTSC or PAL and then set the resolution for the TV.

It is quite worth it to play Sonic or any older games on a TV, enjoy.

TEG

brap
Dec 19, 2004, 09:36 AM
If you are using the DVI output, you must use a converter that will change the frequency. DVI is always at 60hz or 75hz. I'd suggest going on to apple.com and purchase a new S-Video to RCA adapter. Once that is done, it will detect it as a TV and allow you to set it to NTSC or PAL and then set the resolution for the TV.

It is quite worth it to play Sonic or any older games on a TV, enjoy.

TEG
Thing is though, I have this (http://docs.info.apple.com/article.html?artnum=88395), and should support it natively. Going to have to drop 20 on a replacement, I'll bet...

TEG
Dec 19, 2004, 08:18 PM
Well, there should be a setting in the Preference Pane to set the refresh rate. Also, try shutting down the system, then hooking everything up, then restart. It may be a small software bug. But I know, having used those adapters that the system will show several resolutions in the window, some will say (NTSC) and others will say (PAL). It may be that you are not looking in the right place, but I'm not entirely sure.

TEG

nymac
Jan 11, 2005, 03:48 AM
Well, there should be a setting in the Preference Pane to set the refresh rate...TEG


Indeed there is.
1.First connect the DVI cable, so the Powerbook switches to multiple display.
2. Launch system preferences>display
3. There should now be 3 tabs on the top (Display, Arrangement,Color). Select the 'Arrangement' tab.
4. Check the 'Mirror Displays' box. The Powerbook display will reset to mirror mode.
5. When the display settles, pull out the dvi cable, let it settle and plug it in again.

6. You should now see two dialogs, Color LCD and NTSC/PAL.
7. Select the resolution you want on the Color LCD dialog.
8. Select to bring to front the NTSC/PAL dialog and you will see the Refresh rate drop down list available for 50 Hertz(PAL) selection.

Looks quite bothersome but works for me. Was trying to record game session on a PAL camcorder and stumbled on your discussion while looking for solutions, found it while meddling the Preferences. Thought I'd share it even though it's been some time. Happy New Year.