PDA

View Full Version : Dual 2.5GHz G5 -> Problem Machine?


andym172
Dec 20, 2004, 11:46 AM
My 4 week old 2.5GHz G5 has now been in for repair for just over a week.

After having spoken to both the repair company (who Apple transferred the case to) and Apple themselves, it's become apparent that there have been a number of recurring faults with the dual 2.5's.

So, my reason for posting is to ask those of you who have purchased and/or use the dual 2.5 if you have encountered any faults with them? If so, what problems are/were they?

andym172
Dec 20, 2004, 08:02 PM
Am I to take that as a 'no' then?! :)

Cooknn
Dec 20, 2004, 08:04 PM
What went wrong with yours?

aussiemac86
Dec 20, 2004, 08:20 PM
I got one of the first dual 2.5's into AUS, so i have had it for almost 4 months now, i have had no issues whatsoever.

RJaMmin
Dec 20, 2004, 08:56 PM
Sorry you are having problems. I've had mine 3 1/2 months now, with no problems. It's been running 24/7.
This is probably not going to make you're situation any better, but for all the negative reports I think there are a lot of positive reports that just don't get mentioned. Hope you're troubles are resolved soon so that you can enjoy your new machine.

Scottyk9
Dec 20, 2004, 10:16 PM
Have only had it for about 8 weeks, but absolutely no problems, runs like a dream...

Duff-Man
Dec 20, 2004, 10:59 PM
Duff-Man says...I got one of the first ones in Canada (if not the first) and it has not had one problem at all - just like every Mac I have ever owned....oh yeah!

pdp
Dec 20, 2004, 11:59 PM
my dual 2.5 has been running non stop for about 3 days. it gets pms and stops and restarts out of the blue. it's no more stable than my pc. it's actually less stable. my pc has been on the past month and a half w/o bsod's and whatnot.

Blue Velvet
Dec 21, 2004, 05:21 AM
We've had 3 at work from one of the first batches to enter the UK.

They've been running 24/7 since mid-August with absolutely no problems...

cmvsm
Dec 21, 2004, 08:02 AM
my dual 2.5 has been running non stop for about 3 days. it gets pms and stops and restarts out of the blue. it's no more stable than my pc. it's actually less stable. my pc has been on the past month and a half w/o bsod's and whatnot.

My PC is loaded with adware that I can not get out of the registry no matter what program I use... :mad: My Dual 2.0 however runs perfectly and has been for a month now. If I were you, I'd analyze what you've added to the system. Repair permissions, do you maintenance with Onyx and see where you are at. Still having issues? Zero out the drive and do a clean install. If you are still having problems, take it to Apple.

These Powermac machines are incredible as others have attested... :D

iriejedi
Dec 21, 2004, 08:35 AM
Had mine since August - only issue one permission file corruption - but that was a 2 minute fix with disk first aid - but at the same time I found I could NOT boot from a CD since I have the 6800 Ultra card (no drivers on all the supplied boot CDs) - problem fixed with 'BootCD' application program and my VERY kind Apple Store that installed the OS on my external hard drive and updated it fully to 10.3.7 for me. Just had to produce the original 10.3.4 CD that is completely useless to me, as proof I own the system.

Good Luck and be patient - it will be worth the wait!


Have only had it for about 8 weeks, but absolutely no
problems, runs like a dream...

wdlove
Dec 21, 2004, 09:41 AM
I hope that you will find quick resolution to your problem. From my experience Apple is good about repairs. Just be sure to call them, be firm, but always pleasant with your inquiry.

link92
Dec 22, 2004, 06:31 PM
Logic Board went after 3/4 days...

SteveMentzer
Dec 22, 2004, 06:53 PM
I have had my dual G5 2.5 CTO for about a month now.

I get the occasional fan rev, but it has been rock solid stable and FAST since day 1.

Bear
Dec 22, 2004, 07:05 PM
You will always hear more form the people who have a problem with a product than you will hear from those with no issues.

And since some people repeat what they read without regard to how it really applies, some of these issues can get blown out of proportion.

andym172
Dec 22, 2004, 08:16 PM
It turns out the problems with my computer appear to stem from a faulty graphics card. The graphics card that held up production for sooo long - the 6800 Ultra.

The problems only showed up after them testing the machine at max cpu level for over a 5 day period, 24 hours a day :eek:

I should ask for replacement fans... ;)