PDA

View Full Version : G5 iMac and Apple Wireless Mouse issue...


yakisoba
Dec 21, 2004, 11:17 AM
Hey all,

I just bought a new G5 iMac for my wife for Christmas, and am having an odd problem with the wireless mouse. The mouse works fine on a clean boot or log in. However, if you switch the mouse off, wait for the "Connection Lost" message, and switch it back on, the iMac doesn't ever see it again. If you then use a Command-Shift-Q to log out, and use the arrow keys to select the user to log back in, it sees the mouse again after log in.... The same behavior is observed if you put the iMac to sleep and switch the mouse off to save battery life. When you wake the iMac with the keyboard, it will no longer find the mouse.

Any ideas?

TIA

joetronic
Dec 21, 2004, 11:40 AM
I can't help fix the problem but.....I was having the same issue with my iMac G5. what I did was go buy a set of good rechargable batterys and just leave the mouse on all the time. I know this dosn't help, but at least you knwo you are not alone...

yakisoba
Dec 22, 2004, 08:22 PM
FWIW,

It struck me as odd that I was generally successful getting the mouse to reassociate with the iMac when logged in as an Admin, but not as a user. I fiddled around (rather than giving my wife Admin status), and found that the Bluetooth setting to require authentication was turned on. I flipped that switch off, and things work now.

I'll have to look more into what the real issue is. There must be some kind of expectation by the Bluetooth daemon that a device authentication should be of an Admin or root sort of function, and a lowly user can't perform it....

Anyway, I hope this helps anyone else with the same problem.