PDA

View Full Version : Huge problem with MX900


Veldek
Dec 21, 2004, 01:58 PM
Hi everybody,

whoever has a Logitech MX900 BT mouse or knows about BT mice in general, please help me out.

I bought the MX900 to have a BT mouse with more than three buttons. I knew they didn't work in OS X except for Expose and that's what I wanted them for. And it works great.

But, and this is a huge but, from time to time, the mouse starts to get really, really sluggish, sometimes to a point where it doesn't move at all. The pointer jumps from one point to another and I cannot do anything at this moment. This happens quite often, so it's something that really bothers me, because it renders the mouse almost unusable.

I have the feeling that this especially happens when there's a high CPU load though this might be wrong/coincidence. I searched the web to see if I could find someone else with a similar problem but it seems to be only me.

So does anyone have an idea what could cause this and, more important, how I can get rid of this problem?

Thanks in advance.

Veldek
Dec 22, 2004, 01:51 AM
*bump*

Is this such a strange problem that noone knows an answer?

annk
Dec 22, 2004, 02:26 AM
Since this isnŽt a solution, I wasnŽt going to post, but since youŽre still waiting for help IŽll share my experience.

I have the same mouse and have never experienced what you describe - it works perfectly (I only left and right click and use the scroll wheel). But I HAVE experienced a similiar problem when using the trackpad; suddenly the pointer will take on a life of its own. It doesnŽt get sluggish, but floats and zips around regardless of my touch on the track pad. I havenŽt noticed any pattern that would explain why it happens when it happens.

I hope someone else posts with a solution or explanation of why it happens.

Veldek
Dec 22, 2004, 11:59 AM
Since this isnŽt a solution, I wasnŽt going to post, but since youŽre still waiting for help IŽll share my experience.

I have the same mouse and have never experienced what you describe - it works perfectly (I only left and right click and use the scroll wheel). But I HAVE experienced a similiar problem when using the trackpad; suddenly the pointer will take on a life of its own. It doesnŽt get sluggish, but floats and zips around regardless of my touch on the track pad. I havenŽt noticed any pattern that would explain why it happens when it happens.

I hope someone else posts with a solution or explanation of why it happens.

Thanks for your answer. I think, as noone can say anything about this, that the mouse is broken. Perhaps I should try to change it.

honeytoast
Dec 22, 2004, 12:20 PM
you don't have a cell phone near your mac when your using do you. i know when my phone is near my mac my bt mouse goes insane

Veldek
Dec 22, 2004, 02:39 PM
you don't have a cell phone near your mac when your using do you. i know when my phone is near my mac my bt mouse goes insane

Hmm, I sometimes have a cell phone here, so this could be the cause. Thanks, I'll do some testing.