PDA

View Full Version : So the new ATV is stream only - have Apple sorted the Mac sleeping issue?




Fantasy Guy
Sep 24, 2010, 02:31 PM
I don't like streaming to my ATV because, half way through a film, my Macbook Pro goes to sleep and the ATV suddenly stops.

So I have to go into System Prefs and switch off the sleep timer.

Then a couple of days later I get back from work to find my MBP has been on all day. So I have to reset the sleep timer again.

Then a few days later I watch a film on my ATV... well, you get the idea!

So have Apple sorted it so the Mac knows it's streaming to the ATV and temporarily disables the sleep function?



mullman
Sep 24, 2010, 02:51 PM
dup post...

mullman
Sep 24, 2010, 02:52 PM
I don't like streaming to my ATV because, half way through a film, my Macbook Pro goes to sleep and the ATV suddenly stops.

So I have to go into System Prefs and switch off the sleep timer.

Then a couple of days later I get back from work to find my MBP has been on all day. So I have to reset the sleep timer again.

This sounds like a User issue, not an Apple issue. :)

I set all my machines to never sleep, and I manual sleep them when they are not in use.

Fantasy Guy
Sep 24, 2010, 02:55 PM
dup post...

What's a 'dup' post?

mullman
Sep 24, 2010, 02:56 PM
What's a 'dup' post?

In error I replied twice - 'duplicate post'.

benoitgphoto
Sep 24, 2010, 03:01 PM
I don't like streaming to my ATV because, half way through a film, my Macbook Pro goes to sleep and the ATV suddenly stops.

So I have to go into System Prefs and switch off the sleep timer.

Then a couple of days later I get back from work to find my MBP has been on all day. So I have to reset the sleep timer again.

Then a few days later I watch a film on my ATV... well, you get the idea!

So have Apple sorted it so the Mac knows it's streaming to the ATV and temporarily disables the sleep function?


Why don't you check the "Wake for network access" option in the energy savings settings...

Fantasy Guy
Sep 24, 2010, 03:05 PM
Why don't you check the "Wake for network access" option in the energy savings settings...

Oooooh! Does that stop it sleeping? Excellent, thanks.

mullman: is typing "licate" really that hard?!

mchalebk
Sep 24, 2010, 03:08 PM
I have my MacPro set to never sleep automatically. I tried using the Wake For Network Access feature, but it resulted in my MacPro being wakened all the time. However, I just did some research and found that you're supposed to have a more modern base station than I have, so that might be my problem.

dmm219
Sep 24, 2010, 03:09 PM
If you use a Time Capsule or AEBS you can set waking by wireless access. It works pretty well. I personally found it would not work if you use AE in your setup.

So yes, the fixed it...buy you have to use apple products for your router.

Fantasy Guy
Sep 24, 2010, 03:09 PM
I have my MacPro set to never sleep automatically.

Out of interest, why not?

mchalebk
Sep 24, 2010, 03:14 PM
Out of interest, why not?

Over the years, I've done a bunch of different things where the computer was left running, but no user input was required. Unfortunately, computers aren't always smart enough to recognize that something is going on and they should stay awake. It's really frustrating to find that your computer went to sleep while it was crunching away on a task.

Now, it's quite possible that OS X is a lot smarter now. However, I got in the habit of working this way and it works for me. This way, I never have any concern that my computer might sleep when I don't want it to.

mchalebk
Sep 24, 2010, 03:18 PM
Out of interest, why not?

If you use a Time Capsule or AEBS you can set waking by wireless access. It works pretty well. I personally found it would not work if you use AE in your setup.

So yes, the fixed it...buy you have to use apple products for your router.

I've got an AEBS, but it's pretty old (2004, maybe?). I think I read you have to have one from 2007 or later to get this to work.

Fantasy Guy
Sep 24, 2010, 03:26 PM
Over the years, I've done a bunch of different things where the computer was left running, but no user input was required. Unfortunately, computers aren't always smart enough to recognize that something is going on and they should stay awake. It's really frustrating to find that your computer went to sleep while it was crunching away on a task.

Now, it's quite possible that OS X is a lot smarter now. However, I got in the habit of working this way and it works for me. This way, I never have any concern that my computer might sleep when I don't want it to.

I'm glad you've said all that - and I'm sure you're not alone.

This shows that Apple can do all they fancy to make their products more environmentally friendly, but it's the OS that really needs looking at.