PDA

View Full Version : iPad Wifi SOOOO SLOW




Cricketman
Sep 24, 2010, 08:40 PM
Hi everyone.

I have a 32GB Wi-Fi iPad and for a while now the wifi has been very, very slow. I have 2 laptops (sometimes 4) - currently a Macbook and a Vaio, 2 iPhones, 2 iPod Touches running off Wifi and a Macmini + Vonage directly hooked up to the internet modem. All my wireless devices get 20+MBPS. My Ipad, according to the speedtest app, is getting 6MBPS. Most of the time it is much, much slower.

Whats the problem?

I am running iOS software 3.2.2 for iPad. Not jailbroken currently.

I think it might be my upload speed, which from the last test was a stupid 0.01mbps...none of my other devices are like this!!



kaiak
Sep 24, 2010, 11:24 PM
I have the same problem with my iPad compared to my laptop. The only thing I can figure out is the wifi transmission to the iPad is slower for some reason, since it won't work at home with 4 people, but will work at school with 5,000 people. Hmm…

Fuzzy Logic
Sep 25, 2010, 12:40 AM
Don't know if this will work for you but it helped mine,
Found from another thread about this on here

Quote:
My iPad has issues with slow internet. It's very slow when iPad loads YouTube videos.
OpenDNS has made iPad web browsing twice as fast?. You can fix it by changing the DNS settings for the iPad's Internet connection.

Tap Setting > WiFi, and click on DNS, then type the following

208.67.222.222

Save it.
Then turn off wifi and turn it back on again.

Hth

Cartaphilus
Sep 25, 2010, 01:03 AM
I got abysmal results for my iPad when using SpeedtestX.HD, so I followed the suggestion to use an Open DNS server, but no improvement. So I downloaded the Speedtest Mobile app and got close to what my MBP reports on this same wifi network.

I've already sent a note to Heisenberg.

Capt T
Sep 25, 2010, 01:21 AM
If using the speedtest app change the server. The server closest to me is slow, but the next one on the list is as fast as my laptop. I noticed that the laptop is set for that server. So make sure all devices are picking the same server for accuracy in testing.

Zazoh
Sep 25, 2010, 07:05 AM
My ISP, has a horrible DNS server, I switched my laptops and iPhone to use a faster one, when I got iPad, first thing I did in settings. Same results all devices.

kAoTiX
Sep 27, 2010, 05:31 AM
I have a 3G iPad and the WiFi signal strength is the one thing that is becoming a real let down for me. The speed of the connection is equally as bad.
I have the router in my office and there's not even any other routers in range to cause interferance or anything of the sort.

My iPhone 4 picks up a signal totally fine, throughout the house. When I use the iPad, sometimes i get less than max bars when sat next to the router and sometimes I cant get a signal at all in other parts of the house. I have other wireless devices which have no issue getting at least a good signal anywhere in my house. MBP, Netbook, iPhone 4, iPhone 3GS, Nexus One, even friends who come over with their laptops get good signal.

The speed is just as bad, I have a 50meg connection (Virgin Media in the UK) so I get speeds of 6.6mb/s down on my PC. I don't expect to get these speeds on a device such as an iPad but sometimes I can bearly get 1mb/s. My iPhone can get much better speeds on the same network.
I've also noticed that when using WinSCP to transfer files to/from my iPad over the network I cannot get speeds over 400kb/s which makes copying videos horribly slow and time consuming.

/rant

Maybe my iPad is deffective?

chrono1081
Sep 27, 2010, 06:11 AM
My iPads fast....:o

ellie2000
Sep 28, 2010, 05:08 AM
My iPad's WLAN is slow as syrup. Will try the DNS change method. Fingers crossed. :cool:

nixiemaiden
Sep 28, 2010, 07:31 AM
Maybe you are holding it wrong. I am not saying this to be funny either. I was having a really crappy connection so I ran speedtest and got a ridiculous speed. I pay for 15 Mbps down and I was getting less than 1 Mbps down. Way less. I had my iPad laying down on my lap. I picked it up and ran speedtest again and was getting 6Mbps. So on my lap I get around 100-200 Kbps and standing up 6Mbps. I ran the test a few times after this and kept getting the same results.

Also, do you have a case on your iPad? Maybe that is interfering as well?

ellie2000
Sep 28, 2010, 09:05 AM
Im not holding it wrong. But i know what you mean.
And no case on it. But the DNS method seems to be working here. Hm. :)
So far so good, I guess.

Capt T
Sep 28, 2010, 09:17 AM
I have a 3G iPad and the WiFi signal strength is the one thing that is becoming a real let down for me. The speed of the connection is equally as bad.
I have the router in my office and there's not even any other routers in range to cause interferance or anything of the sort.

My iPhone 4 picks up a signal totally fine, throughout the house. When I use the iPad, sometimes i get less than max bars when sat next to the router and sometimes I cant get a signal at all in other parts of the house. I have other wireless devices which have no issue getting at least a good signal anywhere in my house. MBP, Netbook, iPhone 4, iPhone 3GS, Nexus One, even friends who come over with their laptops get good signal.

The speed is just as bad, I have a 50meg connection (Virgin Media in the UK) so I get speeds of 6.6mb/s down on my PC. I don't expect to get these speeds on a device such as an iPad but sometimes I can bearly get 1mb/s. My iPhone can get much better speeds on the same network.
I've also noticed that when using WinSCP to transfer files to/from my iPad over the network I cannot get speeds over 400kb/s which makes copying videos horribly slow and time consuming.

/rant

Maybe my iPad is deffective?

I get 18mb down and 3mb up using speed test on my iPad, same as on my computer. So you should get the same results as your computer with it sitting in the same location. If I use the other server it wanted to connect me to it is only 9mb down. So either you need to check which server speedtest is using and switch if it is different than the one you computer connects to, or if they are the same you may have an issue. As to transferring videos wifi to it....it always seems very slow to me, streaming no problems, but transferring is slow.

dunk50
Sep 28, 2010, 10:20 AM
Made the above DNS change and it seems to have worked. My question is this. I have a Macbook, an ip4 and the iPad. They are all on the same wireless router in my home but all are showing a different ip Address. They all do show the same DNS. My question is should I make them all the same. Sorry, newbie here!

nixiemaiden
Sep 28, 2010, 11:54 AM
Made the above DNS change and it seems to have worked. My question is this. I have a Macbook, an ip4 and the iPad. They are all on the same wireless router in my home but all are showing a different ip Address. They all do show the same DNS. My question is should I make them all the same. Sorry, newbie here!

No they should all have different local IP addresses. The IP address that the outside sees will be different. If you go to http://www.whatismyip.com they should all show the same IP address.