PDA

View Full Version : HD rips stuttering




liquidsuns
Sep 26, 2010, 12:30 PM
I'm having a problem with all my blu-ray rips stuttering during playback. They seem to have a really slow frame rate. It mostly happens during action scenes, but occurs at other times too. Some are worse then others. Streaming them makes the problem worse.

I figured it was maybe because I encoded them at too high a frame rate or something, but when checking the fps through Quicktime, they are all under 24fps.

I rip with makemkv then use handbrake to encode at with these settings:

resolution: 1280x720
fps: same as source
advanced: ref=3:mixed-refs=1:bframes=3:me=hex:subq=7:b-adapt=2:8x8dct=1:weightb=0:trellis=0:weightp=0

All the bit rates are between 2000-4500kbps

Purchased HD iTunes movies play fine. All the HD movies are synced to the AppleTV. Everything plays fine on iTunes. Any clues as to why this is happening?



roidy
Sep 26, 2010, 01:43 PM
If streaming makes them worse then it sound like you're getting bit-rate spikes that are too high. This is the advanced string from the AppleTV preset notice the vbv-maxrate and vbv-bufsize options, these limit any bit-rate spikes, not saying this is you problem but it's worth a try.
cabac=0:ref=2:me=umh:b-pyramid=none:b-adapt=2:weightb=0:trellis=0:weightp=0:vbv-maxrate=9500:vbv-bufsize=9500
I suggest using the AppleTV preset and adjust the resolution to 1280x720. Just out of curiosity are you using Handbrake 0.9.4? If so I don't think it includes the vbv setting in the ATV preset. I would download the latest nightly version from here:-

https://build.handbrake.fr/

NightStorm
Sep 26, 2010, 01:48 PM
Depending on what version of Handbrake you are using, you may have CABAC enabled which is causing issues with both synced and streamed content if you aren't careful.

liquidsuns
Sep 26, 2010, 02:00 PM
I'm using 0.9.4. I'm going to try the nightly build and use the default Appletv settings and see what happens.

Checking the version of handbrake I've been using, there is an option checked under advanced settings called CABAC Entropy Coding, which isn't enabled in the nightly build. But all the SD dvds play fine both synced and streamed. It's just the blu-ray rips.

liquidsuns
Sep 26, 2010, 02:09 PM
So I did a partial encode of and HD movie using the AppleTV preset with the nightly build and it seems to have solved the problem. It played fine even while streaming.

Thanks a lot guys. I've got some reencoding to do...

roidy
Sep 26, 2010, 02:16 PM
No problem, glad it's working now.