PDA

View Full Version : Flash looks great on everything except for mac




devknob
Sep 28, 2010, 04:17 PM
Tested through several friends and apparently the only issue is in Mac/Firefox which I cannot test in. Its a specific os and but there must be some underlying problem im missing. These variations(nearly every variation Adobe Flash offers in publish settings) all look wrong.
http://blog.haamoniismooth.com/?swf=Transition1
http://blog.haamoniismooth.com/?swf=Transition2
http://blog.haamoniismooth.com/?swf=Transition3
http://blog.haamoniismooth.com/?swf=Transition4
http://blog.haamoniismooth.com/?swf=Transition5
http://blog.haamoniismooth.com/?swf=Transition6
http://blog.haamoniismooth.com/?swf=Transition7
http://blog.haamoniismooth.com/?swf=Transition8
http://blog.haamoniismooth.com/?swf=Transition9
http://blog.haamoniismooth.com/?swf=Transition10
http://blog.haamoniismooth.com/?swf=Transition11
http://blog.haamoniismooth.com/?swf=Transition12

They all look like the attached screen shot.
Anyone with more knowledge than me with flash know what would cause this?



devknob
Sep 28, 2010, 04:20 PM
http://forums.macrumors.com/showthread.php?t=1016918&highlight=
This was my last post on this issue, which basically told me this has got to be some other issue or specific to 1 mac os or 1 firefox or something like that.

joy.

we need standards like crazy

NikMac
Sep 28, 2010, 05:54 PM
I'm on Mac OSX 10.6.4 running Firefox 3.6.8, all the animations look great here.

ezekielrage_99
Sep 28, 2010, 07:19 PM
I'm guessing the text is an images? I am guessing a PNG?

This is more a Flash issue, what you need to do to make them smoother is:
1) Go to image in the Library
2) Select the image
3) Change the compression to JPEG
4) Select allow smoothing

The issuing being Flash generally wont smooth a PNG with alpha.

devknob
Sep 28, 2010, 08:54 PM
Thats gotta be it!
Having it checked by someone that was seeing the fuzziness. Thank you so much =)

update: Verified Works. Thank you very much. Seems like this setting was only needed for a small subsection of os/browser but every bit counts.
I'm guessing the text is an images? I am guessing a PNG?

This is more a Flash issue, what you need to do to make them smoother is:
1) Go to image in the Library
2) Select the image
3) Change the compression to JPEG
4) Select allow smoothing

The issuing being Flash generally wont smooth a PNG with alpha.

ezekielrage_99
Sep 28, 2010, 09:13 PM
update: Verified Works. Thank you very much. Seems like this setting was only needed for a small subsection of os/browser but every bit counts.

No problemo, it seems to be a bug/added feature of Flash. I tend to do a lot of micro campaign ads for the site I work with, the ad agency tend to send through High-Quality PNG which look awesome until you scale and add motion to in Flash.

Once I saw the ad I knew that it must have been the issue because I've experienced it so many times. Still if you have the font I would suggest converting the image text to actual text and increasing the FPS to around 18, the animation will be smoother, the text will be crisper and overall will take up less space.