PDA

View Full Version : New USB/Firewire Drive, external, questions


agentphish
Dec 26, 2004, 08:42 PM
"can not copy the item "icon" because the name is too long or contains characters that the disk can not display"

I get this error when i try to copy specific folders to my new external drive. Which is formatted for FAT32, which, in accordence with what i have read on these forums, Is what i need to do if i want to have this drive work on both my PC and my Mac. I have a folder on my mac with all the apps I have ever obtained via DL and buying online or from friends for my mac, which i want to backup onto this drive, so in the event of emergency I have them easily accessable. This error only occurs on certain folders/programs and doesnt seem to follow any certain pattern. For instance it happened when trying to copy my "Extensis" folder, then also happend when i tried to copy the "Pod2Text 2.5 X" folder. Has anyone any ideas?

The external drive is a maxtor 300gb external. I have tried connecting it via both firewire and usb.

The other problem I am having is when I try to trash the folders I created on the drive (since not all of their contents copied over beacuse of the above error) they go to trash but when I go to empty the trash it takes FOREVER!


So I'm looking for solutions. I've done some searching and not found anything on this issue.

TIA.

varmit
Dec 26, 2004, 10:21 PM
"can not copy the item "icon" because the name is too long or contains characters that the disk can not display"

I get this error when i try to copy specific folders to my new external drive. Which is formatted for FAT32, which, in accordence with what i have read on these forums, Is what i need to do if i want to have this drive work on both my PC and my Mac. I have a folder on my mac with all the apps I have ever obtained via DL and buying online or from friends for my mac, which i want to backup onto this drive, so in the event of emergency I have them easily accessable. This error only occurs on certain folders/programs and doesnt seem to follow any certain pattern. For instance it happened when trying to copy my "Extensis" folder, then also happend when i tried to copy the "Pod2Text 2.5 X" folder. Has anyone any ideas?

The external drive is a maxtor 300gb external. I have tried connecting it via both firewire and usb.

The other problem I am having is when I try to trash the folders I created on the drive (since not all of their contents copied over beacuse of the above error) they go to trash but when I go to empty the trash it takes FOREVER!


So I'm looking for solutions. I've done some searching and not found anything on this issue.

TIA.

I had the same error when setting up my Linux server. It had to do something with permissions on the harddrive. Check the folders that you are copying that they all have the same user stated as their owner. Also check the drive you are copying too, and make sure that its the same user that has permission to write to it.

For me, I had to change who was the person that mounted the drive on Linux server, and that username had to match the one that I was trying to mount the drive as in OS X, so that I could copy files back and forth.

EDIT: Right click or CTRL + click and choose Get Info for the drives and folders you are copying.