PDA

View Full Version : Green replacing most blacks on Apple TV 2




Macguy1138
Oct 4, 2010, 02:53 AM
So here's what happened, today, we just received the brand new 2nd generation Apple TV. It looks incredible, and I couldn't wait to use it. We plugged it in, with a HDMI to DVI cable, as our TV isn't a very, well, amazing tv (it'smade by Hotpoint, whoever they are...). Anyway, it was all plugged in, the white light was on on the Apple TV, but nothing was happening. The tv screen was just blank. So I unplugged the Apple TV, then plugged it back in, and it was working! We could see the language set up screen!
However - All the blacks were replaced by greens :(
We ended up setting it up as usual, connecting it to home sharing etc, but we looked through the setting and there just wasn't anything we could do to fix it. We unplugged and plugged it back in again though, and it was just blank again. I'm 99% sure it's a TV issue. Anyway, in the case of it being that 1% chance that it is an Apple TV issue, can anybody help?
Anyone know of this issue? We also kinda need an answer fairly soon, otherwise we'll probably just return it, and that would suck, as it looks so nice!

Anywayyy... Thanks for the help in advance!
Josh.



Frosticus
Oct 4, 2010, 03:34 AM
Have you tried a different HDMI cable to eliminate that?

Macguy1138
Oct 4, 2010, 06:50 AM
Well, we bought that cable just for the Apple TV, and it cost $40, and it's perfectly new, so spending another $40 on a cable that seems fine really won't be worth it.
But thanks for replying :)

Evgenyy
Oct 4, 2010, 07:08 AM
Does seem to me like a cable issue. How long is it? I had a 15m HDMI cable and it was replacing blacks with blues. It was solved by replacing the cable (but it works fine for some reason with the HDMI splitter with post-processing unit).

Also, $40 for a cable? Wow... You can get a perfectly suitable cable for $10 without any quality loss as it's a digital signal and not analog.

edk99
Oct 4, 2010, 08:05 AM
I wouldn't get another $40 cable. I would return the $40 cable you got and get this one http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10231&cs_id=1023104&p_id=2404&seq=1&format=2

It sounds like the cable for sure if the colors are off like you described.

OmegaRed1723
Oct 4, 2010, 08:07 AM
I use these cables (http://www.amazon.com/HDMI-Cable-2M-6-Feet/dp/tech-data/B0002L5R78/ref=de_a_smtd) on my :apple:TV1 and :apple:TV2, as well as all other HDMI devices in my home. Zero problems.

Arran
Oct 4, 2010, 08:08 AM
Do you have a computer monitor with a dvi input that you can test with? That would verify whether or not it's a cable issue.

(btw, I thought Hotpoint only made washing machines! Maybe you need a hose and not a cable :) Seriously though, what country are you in?)

jeznav
Oct 4, 2010, 09:18 AM
This seems to be a handshake issue.

http://discussions.apple.com/thread.jspa?threadID=2600405&tstart=0

lg1992
Oct 4, 2010, 09:44 AM
After looking around the Internet, it appears this is a common problem with the AppleTV and not the cable.

Macguy1138
Oct 4, 2010, 03:42 PM
Does seem to me like a cable issue. How long is it? I had a 15m HDMI cable and it was replacing blacks with blues. It was solved by replacing the cable (but it works fine for some reason with the HDMI splitter with post-processing unit).

Also, $40 for a cable? Wow... You can get a perfectly suitable cable for $10 without any quality loss as it's a digital signal and not analog.

It's a 2 meter cable, and also it's $40AUD, I'm in Australia.

Do you have a computer monitor with a dvi input that you can test with? That would verify whether or not it's a cable issue.

(btw, I thought Hotpoint only made washing machines! Maybe you need a hose and not a cable Seriously though, what country are you in?)

I'm not sure, but that's a good idea, I'll be sure to check later. And yeah, that shows just how unknown and unsupported our tv is =P And I live in Australia.

Thanks everyone else for suggesting the cables as well.


__________________
When the world zigs, zag.

Macguy1138
Oct 5, 2010, 01:19 AM
OK, so we tried plugging the Apple TV to a computer monitor, and it worked! Which means, it's a tv problem. However, we're probably getting a new tv, so we'll keep the Apple TV, and everything will be jolly fine :D
So thanks everyone again for the help :cool:

Mr. Incredible
Oct 5, 2010, 01:42 AM
Why not just take it back, and exchange it for a new one? Doesn't Apple do that?

Mr. Incredible
Oct 5, 2010, 01:47 AM
OK, so we tried plugging the Apple TV to a computer monitor, and it worked! Which means, it's a tv problem. However, we're probably getting a new tv, so we'll keep the Apple TV, and everything will be jolly fine :D
So thanks everyone again for the help :cool:

I should've read this before commenting. Good job.

Macguy1138
Oct 5, 2010, 02:41 AM
I should've read this before commenting. Good job.

Yeah, haha. Thanks :D

DavoMrMac
Oct 5, 2010, 05:55 AM
Mine shows nice blacks;
http://www.youtube.com/watch?v=_-Z7kRyjTgk