PDA

View Full Version : ATV2 Screen Colours Are Incorrect (and Unchanging)




backspace
Oct 5, 2010, 10:24 PM
I am trying to use the new Apple TV 2 with my Panasonic TX-32LXD700A television but the colours are all wrong; blues are green, yellows are pink, etc. The odd colouring also affects the on-screen menus. Note that this is different to the "HDMI handshake every 20 to 30 minutes" problem, in my case the colours are always incorrect and unchanging. The device plugs in via HDMI. I have tried swapping the to the second HDMI port. I've tried a second cable. I've tried changing the order in which the devices are switched on from cold boots. Nothing works. The picture and sound is otherwise fine. Switching to another input forces the normal colouring to return to all inputs, but as soon as the Apple TV 2 has finished booting the colours switch to the incorrect space. The firmware of the TV is given as version 3090-10000. There are no options in either the user menus or the service menus to change the colour-space. I plugged the Apple TV into a computer monitor using a HDMI-DVI cable and the colours appeared fine. Please help!



DJinTX
Oct 6, 2010, 08:43 AM
Up until your final sentence, I thought the ATV was hosed, but now I have no clue. You could call Apple tech support and see what they think. I wonder if some older TVs have some sort of hardware incompatibility. I have a 42 inch Panasonic plasma, its about 2 years old, and my new ATV works fine on it.

backspace
Oct 6, 2010, 06:23 PM
Thanks DJinTX. My TV is from late 2007, so it's just a little older.

I called Apple and whilst the guy on the phone was very understanding he was unable to help. I was hoping there was some secret combination of the remote buttons that would see the colours spring into life, but no.

I called Panasonic and asked for access to the latest version of the firmware for the television. They are sending it to me on an SD card via courier at no charge (one would think that it must be cheaper to host it on-line). The new firmware addresses a "sound distortion" issue (which I can recall happening occasionally sometime ago) but here's hoping it fixes my ATV2 colours too.

backspace
Oct 8, 2010, 06:55 PM
I took my ATV2 to a friend's place and plugged it into his TV using my HDMI cable and all was well. So I know that it's an issue with the TV.

I'm still waiting on new firmware from Panasonic.

macros73
Oct 8, 2010, 07:12 PM
Does your TV have a DVI port?

backspace
Oct 9, 2010, 05:24 AM
No? Why? Did I say that it did?

I didn't know that there were TVs that had DVI ports.

macros73
Oct 9, 2010, 06:30 AM
My older Westinghouse 42" HD monitor (sold as a "TV" with no tuner) has 1 HDMI port and 2 DVI ports. I was hoping maybe you just happened to overlook one, as you then could connect via HDMI->DVI and see if your problem stopped.

backspace
Oct 10, 2010, 12:47 AM
A 42" HD monitor? Wow!!! My TV is only 32".

chrono1081
Oct 10, 2010, 01:50 AM
My mitsubishi tv did this. The picture looked awful but it looks fine on my ... whatever brand tv i have it hooked to now lol.

backspace
Oct 10, 2010, 06:17 AM
Ouch, your LOL burns me! I only have one TV! :p

I'm still waiting on that firmware...

chrono1081
Oct 10, 2010, 04:45 PM
One thing you can try which did wonders for my messed up tv is if you have a picture setting option, change it to natural or normal. Mine was on "brilliant" and took a toll on the colors. Changing it to natural made the picture almost perfect.

backspace
Oct 10, 2010, 05:47 PM
Yeah, in desperation I tried that too.

The colours are messed up similar to what happens if you muddle the leads in a component connection. Every colour is wrong.

chriso89
Oct 10, 2010, 05:47 PM
http://lastopp.no/filer2/99331844366456bebeabdf01b9624997.JPG

every hour this happens. switching hdmi channel and back agein and its normal. must be a softwarebug?

backspace
Oct 10, 2010, 06:09 PM
Thanks chriso89 I'm familiar with this phenomenon and said so in my opening post. My problem, whilst similar, is separate to this as I can't in any way switch the colours back. The correct colours never appear.

backspace
Oct 12, 2010, 08:07 PM
Well the new firmware arrived. TV now shows version 3100-10000. ATV2 still doesn't work.

My only hope now is that Apple update the ATV2 to include similar video options as on the ATV1. At least an option to choose between 50 and 60Hz for those of us outside of the US.

backspace
Oct 22, 2010, 10:32 PM
I purchased a new Sony KDL-40EX600 and the Apple TV 2 works fine. The whole exercise ended up being quite expensive. :(

jdbr
Oct 24, 2010, 05:48 PM
This seems to be a problem with a lot of Philips and some other make TVs. I contacted Apple and they helped me through updating firmware on my tv etc. However no change. They then asked me to unplug everything and start up again. Again no change. the picture goes green and then like a pink tinted negative every 10-30 mins.
They are aware of the problem with Philips etc tvs and then told me it was the fault of Philips etc. Philips tell me that it is an Apple problem.
This is a big issue, but no one seems to be talking about it or solving it.
This product does not work. Please Apple do something about it.

dadudeness
Oct 25, 2010, 03:55 AM
Actually this seems to be a quite common issue. My Sony KDL32EX402 also is affected. Tried different HDMI Cables, changed the HDMI Port but every 2-30mins the display turns pink again.

Theres a big topic in discussions.apple.com as well: http://discussions.apple.com/thread.jspa?threadID=2600405&start=0&tstart=0

Waiting for a new ATV2-firmware... :mad:

decsramble
Oct 30, 2010, 10:23 AM
I have the same problem on a Philips 42" TV. searching around it appears that there is a serious bug in the HDMI, it's particularly noticeable on Philips TVs but also impacts Sony and other brands to a lesser extent.

I dont think Apple can blame Philips, my MacBook Pro worked fine through a cable to the TV so if the TV has a HDMI handshake problem then the Macbook Pro must also have a similar HDMI handshake problem so it just happens to work ok with the "faulty" TV? Would Apple rather fix the MacBooks or the Apple TVs?

dadudeness
Oct 30, 2010, 10:32 AM
I cant believe anyone but Apple can be blamed for that. Even guys who's first gen Apple TV worked absolutely fine are reportedly affected by this issue