PDA

View Full Version : Connecting Macbook Pro to HDTV via Mini DisplayPort to HDMI causes video to stutter




okstad
Oct 12, 2010, 12:34 PM
Hi,

Hope anyone can help me out with this one! Been browsing the net for hours without any result so far..

Ive connected my Macbook Pro 2.4 GHz Intel Core 2 Duo 4GB ram (Mid2010) to my new Sony Bravia KDL-40EX700 via a Mini DisplayPort to HDMI adapter. The connection apparently works fine giving full 1080p image and sound via the HDMI cable.

However. When trying to play back any video in full screen, the playback goes slightly choppy (stutters). The audio is playing back fine. The video is not far from perfect, but the slight stuttering is very annoying! Regardless of what video I play (DVD from MAC, full 1080p files, divx) this issue occurs.

When connecting my Xbox360 or DVD/Bluray player via HDMI the picture is smooth.

So far Ive tried the following without any results:

run all updates for OSX
different HDMI cabels
tried various resolutions (1080p / 1080i / 720p etc)
changing the modes on the TV (auto, zoom, panorama etc)
switching to the TV as main monitor i OSX display preferences
running TV as only monitor
different settings regarding the Hz
disabling various settings on the TV (Sony Motionflow etc)


If anyone has the same problem or can point me in the right direction that would be highly appreciated!

Thanks!



jajohns8
Oct 12, 2010, 01:23 PM
I am having a similar problem.

I am playing back material streamed from Hulu and get a 'ripple' that slowly moves down the screen. It's not always there, but it happens every so often.

I am using a MAcbook pro (core i7), mid 2010, going through a minidisplay port to HDMI to a Panasonic 720P HDTV.

I havnt tested non web based material (that's what my ATV is for and works fine).

I'm wondering in my case, if it's a streaming issue related to web based content?

okstad
Oct 12, 2010, 04:17 PM
PROBLEM SOLVED!

Turned out to be a function called CineMotion within the Sony Bravia (3:2 pulldown process) that was causing the stuttering in the video. For some reason this function is enabled by default.

After switching this option to Off (instead of Auto 1 or Auto 2) all video transfered to the Bravia is now running super smooth! :D

Anyone experiencing similar problems should read this article:

http://interscription.com/2008/04/07/reverse-32-pulldown-cinemotion-and-how-choppy-video-sucks/

in short: When feeding HDMI signal from Apple Mac to Sony Bravia HDTV -> CineMotion should be turned OFF

just1nd20
Oct 12, 2010, 09:35 PM
I found the same issue of poor video playback in Plex from my 2.53Ghz MacBook Pro using the same cable. This happened is I had the Display Setting as Mirrored or Extended. What I found was the graphics card could not handle outputting 1080p while also having the built-in display on. My solution was to use the Apple Remote to wake the MacBook with the lid closed to use Plex. I just bought the remote today, in fact, and it's working fine. This is why I replied. No more stuttering while watching videos. From what I've also read, you could use an external keyboard or plug in any USB device to wake the Mac and all should be well. Hope this helps someone.

gentrysama
Jan 4, 2011, 08:45 AM
Hey folks, was wondering if anyone can help me out. I recently bought an Sony KDL EX 500 32" and tried hooking it up to my new Macbook Air 13". The first time I tried, it worked but was in dual display mode. I turned this off, and never got the TV to recognize the signal. I tried turning the Air off, then on, the TV off then on, etc, but nothing worked. Any suggestions? I'm not very familiar w/fiddling with the settings on a Bravia (my first) and same with the Air. Thanks

aaronthomas
Jan 4, 2011, 11:17 AM
Hey all! Wow good post to find... Just hooked up my Mac Pro (2006) with my Sony Bravia. Funny little jittery lines run down the screen...mostly during heavy action seens. I just noticed when I unplug the monitor from the back of the mac the lines go away. Thanks... however its a bit of a pain to continue to do that every time I want to watch a flick. I use front row... is there away to put the monitor to sleep without unplugging it? Also... Cant find "CinaMotion" anywhere on my Sony.... what file is it under? THANKS SOOOOO MUCH!!!!

remmealaska
Sep 6, 2011, 03:10 AM
I am having the same problem. I have disabled the CineMotion on my Sony Bravia and have also turned off the display on my Macbook Pro by closing the lid and waking it up with a bluetooth mouse, but the problem persists.

I am using a 17" Macbook Pro, Processor: 2.66 GHz Intel Core i7, Memory: 8GB 1067 MHz DDR3, Graphics card: NVIDIA GeForce GT 330M. I am connecting to a Sony Bravia 40EX500 via Minidisplay to HDMI adapter.

I've used this setup for gaming and it's worked fine. Audio is fine, just the video is choppy sometimes. Any help would be GREATLY appreciated and I can provide more information if necessary.

aaronthomas
Sep 7, 2011, 10:42 AM
I am having the same problem. I have disabled the CineMotion on my Sony Bravia and have also turned off the display on my Macbook Pro by closing the lid and waking it up with a bluetooth mouse, but the problem persists.

I am using a 17" Macbook Pro, Processor: 2.66 GHz Intel Core i7, Memory: 8GB 1067 MHz DDR3, Graphics card: NVIDIA GeForce GT 330M. I am connecting to a Sony Bravia 40EX500 via Minidisplay to HDMI adapter.

I've used this setup for gaming and it's worked fine. Audio is fine, just the video is choppy sometimes. Any help would be GREATLY appreciated and I can provide more information if necessary.

I ended up finding out that my video card wasn't up to speed on my Mac Pro and that was causing the choppy picture. Were huge movie and music goers here so we ended up biting the bullet and getting a mac mini and us it solely for entertainment... It was cheaper and made more sense than up grading an '06 Pro and less of a head ache than using my Lady Friends lap top. Plus with using the Rowmote app which runs off WiFi we put the mini in the other room.
We also started using the Caffeine app to keep the Mini from sleeping while listening to music.

cptexas
Jan 26, 2012, 08:39 PM
All,
I too have a Sony Bravia and a Macbook Pro with a mini display port.

I bought the Apple attachment to connect my mini display port to a HD15 cable with ferrite core. I plugged the HD15 cable into the rear of my TV where it says RGB. Everything fits well, but I am still seeing only two external inputs for the TV: my DVD player and my cable box. The TV doesn't seem to know that I have a computer attached to it. The user manual for the TV says I should change the output signal from the PC to a certain resolution. Tried that. I really don't know what I am doing. I want to display a Powerpoint presentation and a set of photos from Iphoto on the TV this Sunday (January 29, 2012). Will I be able to do that when I get this working? I thought I could use the TV like an external computer monitor. I need some step by step instructions including what order to turn the TV and the computer on, and when to connect the cable to the mini display port. I have read that I should use PF7 on my Macbook, but I don't think that may be from a different version of Macbook than mine. Mine doesn't seem to have the "mirror display" icon on any of the function keys... Can anyone help?

aaronthomas
Jan 26, 2012, 11:29 PM
All,
I too have a Sony Bravia and a Macbook Pro with a mini display port.

I bought the Apple attachment to connect my mini display port to a HD15 cable with ferrite core. I plugged the HD15 cable into the rear of my TV where it says RGB. Everything fits well, but I am still seeing only two external inputs for the TV: my DVD player and my cable box. The TV doesn't seem to know that I have a computer attached to it. The user manual for the TV says I should change the output signal from the PC to a certain resolution. Tried that. I really don't know what I am doing. I want to display a Powerpoint presentation and a set of photos from Iphoto on the TV this Sunday (January 29, 2012). Will I be able to do that when I get this working? I thought I could use the TV like an external computer monitor. I need some step by step instructions including what order to turn the TV and the computer on, and when to connect the cable to the mini display port. I have read that I should use PF7 on my Macbook, but I don't think that may be from a different version of Macbook than mine. Mine doesn't seem to have the "mirror display" icon on any of the function keys... Can anyone help?


I'm sure someone with more know how will chime in but... If you use a Mini Display to HDMI adapter that should work... thats how my GF does her Power Point presentations. With the Sony its as easy as choosing the HDMI port you plugged into using the "Home" button on your remote. No sound though. In choosing your display go into your System Preferences and chose your TV... however we never seem to need to choose. Hope this helps and I havent screwed you up.... this is how it has worked for us.
Good luck!

cptexas
Jan 27, 2012, 08:56 PM
Thanks for the support. I tried HDMI hookup but my macbook pro didn't recognize the TV. With the VGA hookup, it did recognize the TV (it went blue screen temporarily on the Macbook Pro). On the Macbook Pro, I went to system preferences/display/detect displays and it downloaded a Sony TV display for me. I went to system preferences/display/arrangement and picked Mirror Display. Later when I had everything working, I went back and played with the resolution of the screen.

My problem was with the Sony. I figured out (finally) how to set the TV to the VGA input (called PC Input on the Sony Bravia). Someone had set up the Sony Bravia for me when I bought it, and they renamed the inputs. So I had one for my DVD player and one for my cable box (component one and component two on the actual TV). Nothing else, because he chose "Skip" for the other inputs including the HDMI inputs, the Video inputs and the PC Input. So they no longer showed up when I scrolled through my external inputs using the remote. All I had to do was use the menu on the Sony Bravia to rename my External inputs. I changed "Skip" to "On", for the PC Input. It is working! This is a very basic hookup but it serves my purpose and whew! I needed it for Sunday. Thank you Apple. The guy at the Apple store was the one who convinced me the problem was with the Sony (by reassuring me that the blue screen was the computer doing what it should do). And I remembered the TV technician renaming things for me a few years earlier and decided to try that angle.

aaronthomas
Jan 27, 2012, 09:19 PM
glad it worked in the end!

Kilamite
Feb 2, 2012, 02:51 PM
Well I'm having the exact same problem. I've turned off CineMotion (or Film Mode as it is called on my Sony Bravia) as well as MotionFlow, but things are still very slightly stuttery in comparison to my Mac display or external monitor. Even if I turn off my MacBook Pro display.

I'm using VLC Player, connecting my Mac via HDMI from the Thunderbolt port.

jetfanroy
Dec 6, 2012, 08:13 AM
I am having a similar problem...I have connected my MBP - OS X 10.6.8 4GB 2.3 GHz via the Thunderbolt port to my Vizio m3d55okde. I am using a Monoprice MDP to HDMI cable to connect to the tv.
I am using VLC 2.0.4 to play a 1080P .mkv file.
& there is a slight video studder - audio is fine.
I've tried XBMC & had the same problem.

I've tried the same file on a dell laptop with a built-in hdmi port and VLC & it played perfectly.

Any help would be greatly appreciated