PDA

View Full Version : PowerBook 12" RIP?!?




Groovey
Oct 14, 2010, 04:34 PM
Hi. I wish there's somebody here, who could help. I was given a 12" PoweBook. I don't even have any specs. The problem is that it plays the startup chime, but often doesn't do anything more than that. Sometimes it goes into Open Firmware and says "Invalid Memory Access". I already zapped NVRAM and PMU - no help. In the memory slot there was a 256Mb module, which I removed. The problem, as you can see in the picture, remains.

http://lh4.ggpht.com/_62-pX0dwP_0/TLd001XVCEI/AAAAAAAAAE8/9PP0sATLfFA/s640/photo.JPG

It did boot once from 10.4 install dvd, and I got a new OS installed. It just was the one only time. Should I conclude that the problem is the RAM on the motherboard? I'd really love to have this machine working. If you know something more, please help. Thank you very much.



Intell
Oct 14, 2010, 04:39 PM
What happens if you type in "mac-boot"?

Groovey
Oct 14, 2010, 04:44 PM
BLINK, BLANK, BLÍNK.
-->

ALLOC-MEM request too big!
ok
0 >

Also tried:

reset-nvram
set-defaults
reset-all

By the way, thanks for a quick answer.

XaPHER
Oct 14, 2010, 04:58 PM
Your powerbook model should be a g4 at 1.33 ghz.

666sheep
Oct 14, 2010, 05:08 PM
You can try to disable this onboard RAM and test machine with this 256 which you removed. Read instructions here: http://osxbook.com/book/bonus/ancient/whatismacosx//arch_boot.html

Groovey
Oct 14, 2010, 06:41 PM
Thanks a bunch for helps and all! I got it figured. Removing the Airport Extreme card got the machine up and running. And re-installing it carefully after cleaning gave me a nice couch-Mac for absolutely free. No more Invalid Memory Access errors. It's great. Though I did remember 12" PowerBooks had better displays...