PDA

View Full Version : iMac G4 - cannot get it to boot UbuntuPowerPC Disc




pHreaksYcle
Oct 15, 2010, 12:21 AM
Has anyone successfully done this? I've tried nosplash, quiet, and what seems to be every other combination of boot arguments, and I still can't get it to boot. I really want to use this thing with Ubuntu Linux.

Thanks in advance!



disconap
Oct 16, 2010, 02:44 PM
Sorry if most of this is "duh" stuff, just being thorough:

1) make SURE you have the PPC distro. It's community supported and therefor not on the main page.
10.10 is here: http://cdimage.ubuntu.com/ports/releases/10.10/release/
10.04 (LTS) is here: http://cdimage.ubuntu.com/ports/releases/10.04/release/
Older versions: basically the same link, just replace the version number.

2) make SURE you burn the disc image properly. If you're just burning the image to the disc you're doing it wrong, it has to essentially be cloned.
Kbase article: http://support.apple.com/kb/ht2087

3) Make sure your boot cd-rom/dvd-rom/etc is working properly. Try burning the image at a slower speed if the drive you're reading from is older than the one you're burning with, and test/make sure the drive itself works. CD-rom drives, like any other piece of hardware, do die eventually, I've had several crap out on me over the years, and G4s are old...

4) if all else fails, try the alternate images.

Also, this may be another "duh" thing, but just holding down "c" after the boot chime will boot from CD instead of hdd. Good luck!

pHreaksYcle
Oct 16, 2010, 02:49 PM
1) I definitely have the PPC version. Made very sure of that.

2) I'm pretty experienced with making bootable discs from images, that isn't the problem =]

3) The drive can't be bad, I'm getting to the welcome screen of the live disc after holding "c", but good thought - they are old.

4) I thought they only offered the alternate text only version for the G4 - I'll have to try and find the alternate.

Thanks =]

disconap
Oct 20, 2010, 06:22 PM
Alternate Install image is on the same page (check the links above). You may want to try redownloading ore reburning the disc image, you may have just had some corruption in the download (maybe pick a different mirror if that's an option too).

At what point is it failing? Are you able to complete the install itself?