PDA

View Full Version : Pismo Battery won't charge - battery or power board?




wjlafrance
Oct 21, 2010, 12:55 AM
I did some Googling and couldn't find the definitive answer to this question. I just got a Pismo and it came with a battery of unknown past usage and it won't charge.

Battery Information:

Battery Installed: Yes
First low level warning: No
Full Charge Capacity (mAh): 4500
Remaining Capacity (mAh): 0
Amperage (mA): 0
Voltage (mV): 12586
Cycle Count: 0

AC Charger Information:

AC Charger (Watts): 50
Connected: Yes
Charging: No

I'm not sure if it's the battery that's a lemon or my power board. Is there a way to tell without purchasing one or the other? After being plugged in for a while my battery will flash one light when I press the button, so I take it my power board is working?

Thanks for any advice. :)



CaoCao
Oct 21, 2010, 01:59 AM
I did some Googling and couldn't find the definitive answer to this question. I just got a Pismo and it came with a battery of unknown past usage and it won't charge.



I'm not sure if it's the battery that's a lemon or my power board. Is there a way to tell without purchasing one or the other? After being plugged in for a while my battery will flash one light when I press the button, so I take it my power board is working?

Thanks for any advice. :)

batteries deteriorate over time and that Pismo is a decade old, you need a new battery

Epsilon88
Oct 22, 2010, 11:55 PM
Happened to me too. It was the battery (no wonder, since it was 8 years old!)