PDA

View Full Version : Powerbook G4 DC in / Charger / Battery problems




Man-Droid
Oct 30, 2010, 04:20 AM
I have a 17" PB with a couple of growing issues. Right now I am unable to use it for one of several reasons. About a year ago I purchased a charger off of Ebay to replace the original one that started sparking. Shortly after I received the new charger I started having issues with the charger connecting. I would have to twist it and turn it to find the right spot. Now, it doesn't glow green or amber at all. That sweet spot is completely gone. Also, the battery is completely dead. It needs to be replaced.

Not sure at this point if I'm sitting on a dead charger or if I need to replace the DC-In board. I have never had a major accident with the machine but I do recall snagging the chord once or twice. It is possible something was damaged inside when that happened. I've never had an issue like this so I'm not too sure about the symptoms.

I'm thinking a new charger would be the cheapest and safest start. I don't feel very confident purchasing one from Ebay again.

Any suggestions? Thanks!



chrismacguy
Oct 30, 2010, 06:09 AM
I have a 17" PB with a couple of growing issues. Right now I am unable to use it for one of several reasons. About a year ago I purchased a charger off of Ebay to replace the original one that started sparking. Shortly after I received the new charger I started having issues with the charger connecting. I would have to twist it and turn it to find the right spot. Now, it doesn't glow green or amber at all. That sweet spot is completely gone. Also, the battery is completely dead. It needs to be replaced.

Not sure at this point if I'm sitting on a dead charger or if I need to replace the DC-In board. I have never had a major accident with the machine but I do recall snagging the chord once or twice. It is possible something was damaged inside when that happened. I've never had an issue like this so I'm not too sure about the symptoms.

Sounds to me like its the DC-In Board, I had a similar issue with my 15" G4 PB (1.67Ghz non-HR), and a new DC-In fixed it - perhaps the sparking adapter zapped it, but it sounds like a dead DC-in board OR Dead charger - Maybe try to borrow a charger off someone to see if its that or the board? :)

Man-Droid
Oct 30, 2010, 11:07 AM
Thanks, borrowing an adapter is actually a really good idea. I'll have to hunt one down.
Question: I have looked at some of the tutorials for replacing the board and it doesn't look to difficult. I have cracked open and repaired some Macs in the past. Do you know if there is any soldering involved in the repair or is it just pulling the old part and putting in the new one?

Agincourt
Nov 2, 2010, 02:43 PM
Thanks, borrowing an adapter is actually a really good idea. I'll have to hunt one down.
Question: I have looked at some of the tutorials for replacing the board and it doesn't look to difficult. I have cracked open and repaired some Macs in the past. Do you know if there is any soldering involved in the repair or is it just pulling the old part and putting in the new one?

Go to ifixit.com and they should have guides to taking apart virtually any Apple laptop.

Old models:
http://www.ifixit.com/Device/PowerBook_G4_Aluminum_17%22_1-1.67_GHz

Latest models:
http://www.ifixit.com/Device/PowerBook_G4_Aluminum_17%22_1.67_GHz_%28High-Res%29

Hope this helps.

XaPHER
Nov 2, 2010, 03:14 PM
My clamshell arleady did that. Finally, there was only bad contacts on the DC in board