PDA

View Full Version : System 7 on Powermac g4




512k
Nov 7, 2010, 12:22 PM
First of all, i'm new to this forum, so i'm not sure if this is the right place to post.

greetings , one and everyone. i need to know if it is possible to run system 7 on a powermac g4 running 10.4.11. i have a virtual startup disk (.img), but as you know, classic only supports os 9.1+. is there a way to maybe create a disk partition to run system 7 on? thanks,

512k ftw.



gr8tfly
Nov 7, 2010, 12:27 PM
Depending on which PMG4, 8.6 is the probably earliest it will boot to.

Edit: misread as PB

Edit: the earliest G3s could only run 8.0. You'd have to go back to the 601-604 series to run Sys 7.

512k
Nov 7, 2010, 12:32 PM
Depending on which PBG4, 9.1 is the probably earliest it will boot to. Some require 9.2.

1. i am not using a powerbook g4, i am using a power MAC g4

2.system 7 should run on ppc i just need to figure out how

Nermal
Nov 7, 2010, 12:33 PM
The earliest systems shipped with 8.6, so that's the earliest version that you'll get running natively (and as gr8tfly mentions, if your system is newer then you may only be able to run 9).

There are emulators available (such as vMac) but I don't know how compatible they are.

2.system 7 should run on ppc i just need to figure out how

All NewWorld machines (this includes all G4s) lack the toolbox ROM required by System 7. It is not possible to run System 7 natively.

512k
Nov 7, 2010, 12:37 PM
The earliest systems shipped with 8.6, so that's the earliest version that you'll get running natively (and as gr8tfly mentions, if your system is newer then you may only be able to run 9).

There are emulators available (such as vMac) but I don't know how compatible they are.



All NewWorld machines (this includes all G4s) lack the toolbox ROM required by System 7. It is not possible to run System 7 natively.

i do have a copy of Mini vMac, is there any way i can run from that? an if so, where do i find the roms?

GimmeSlack12
Nov 7, 2010, 12:37 PM
The earliest systems shipped with 8.6, so that's the earliest version that you'll get running natively (and as gr8tfly mentions, if your system is newer then you may only be able to run 9).

There are emulators available (such as vMac) but I don't know how compatible they are.



All NewWorld machines (this includes all G4s) lack the toolbox ROM required by System 7. It is not possible to run System 7 natively.

Actually I think the earliest PPC's shipped with 7.6 on them. The earliest were the 6100, 7100, and 8100's. System 8 was not released until the 2G PPC's came out and finally System 9 with the G3's.

Thus, trying to get System 7 on a G4 is probably not possible.

gr8tfly
Nov 7, 2010, 12:39 PM
1. i am not using a powerbook g4, i am using a power MAC g4

2.system 7 should run on ppc i just need to figure out how

See my edits above.

bartelby
Nov 7, 2010, 12:39 PM
Actually I think the earliest PPC's shipped with 7.6 on them. The earliest were the 6100, 7100, and 8100's. System 8 was not released until the 2G PPC's came out and finally System 9 with the G3's.

Yeah, I'm fairly sure my 7500/100 had 7.6 on it. In fact it did, as I got OS8 for christmas the following year.

XaPHER
Nov 7, 2010, 01:33 PM
7500s can boot 7.5.2

The earliest came with 7.1.2

To use system 7 on classic, it requires at least a 7500 (up to a 9600) with an upgraded cpu(601 not supported on osx) and xpost factohttp://eshop.macsales.com/OSXCenter/XPostFacto/Framework.cfm?page=XPostFacto.html#machine

Nermal
Nov 7, 2010, 01:44 PM
Actually I think the earliest PPC's shipped with 7.6 on them. The earliest were the 6100, 7100, and 8100's.

I was referring to the earliest G4s as that's what the OP said he was trying to use.