PDA

View Full Version : App crashes after update with Sparkle framework




barenature
Nov 12, 2010, 06:31 AM
Hello,

I use the Sparkle framework to deliver updates to the user of my application, but when I test it myself and click the familiar "Install and Relaunch" button, the app is installed, but crashes on relaunch.

The crash report says the following:

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: 'launch path not accessible'


I have done some googling and I think this is due to the fact that an application downloaded from the internet does not have the permission to execute, hence the familiar dialog that pops up when you first launch an application that has been downloaded from the web.

I am a bit confused, though, because how does one go about and alter these permissions to allow the Sparkle to work properly? In other words, why does the application not have the "correct" permissions even though a previous version has been installed and launchd before?

Any pointers or help is appreciated.

Bart



barenature
Nov 12, 2010, 09:27 AM
It seemed to be a problem with the Sparkle framework itself. I downloaded and compiled the most recent version of the framework from GitHub and all works fine now. Odd.

Any pointers or comments are still welcome as they might help in solving this bug.

Bart

chown33
Nov 12, 2010, 12:01 PM
It seemed to be a problem with the Sparkle framework itself. I downloaded and compiled the most recent version of the framework from GitHub and all works fine now. Odd.

Any pointers or comments are still welcome as they might help in solving this bug.
The bug was solved in the latest Sparkle version.

If you want to see the cause of that bug, do a diff between the Sparkle version that works and the version that fails. Also read the checkin notes or release notes to see if they say anything relevant.

Otherwise it's all just guessing, which has a low effectiveness as a debugging strategy.

barenature
Nov 14, 2010, 04:33 AM
It's only a bit confusing for the users that the "old" version is still downloadable on the Sprakle website (not GitHub), but I guess Andy (the creator of Sparkle) swamped with work at the moment.

Anyway, I'm glad it's solved now and it's amazing that this framework is free to use by developers.

Thanks for your input!

Bart