PDA

View Full Version : Apple TV 2 Colour Problem




fabian9
Nov 18, 2010, 10:36 AM
Guys,

I recently bought a new Apple TV. The colours go really funny every now and then, everything seems to be turning pink/purpleish (see attached photo).

I have tried different HDMI cables and ports, but the problem still occurs.

Has anybody else experienced this before?!



saving107
Nov 18, 2010, 10:57 AM
1. Have you restored your Apple TV to see if that solves the issue?

2. Does this happen with any other devices plugged into the TV using HDMI (like a PS3 or Blu ray player)?

fabian9
Nov 18, 2010, 11:01 AM
I have tried to restore it to no avail.

It seems to be a pretty wide-spread issue if this thread I just found on the Apple discussion forum is anything to go by:

http://discussions.apple.com/thread.jspa?threadID=2600405&start=0&tstart=0

chrono1081
Nov 18, 2010, 11:09 AM
Ive read that some people solved this by getting updated firmware for their TVs. Not sure if your TV allows this or not but it would be worth checking.

fabian9
Nov 18, 2010, 11:20 AM
yeh just talked to apple care and they said that upgrading the tv firmware should solve it. so i did that and am now monitoring the situation… hopefully i won't see strange colours again!

cheers!

fabian9
Nov 18, 2010, 11:36 AM
nope, that didn't do it. it just happened again...

saving107
Nov 18, 2010, 11:46 AM
what tv model do you have?

ShiftClick
Nov 18, 2010, 11:53 AM
just from looking at that picture seems to be a RGB/709 color space issue. If your tv has settings for each hdmi input see if there is a setting for color space to toggle between RGB and 709.

fabian9
Nov 18, 2010, 12:09 PM
It's a Sony Bravia 32" KDL-BX300… I don't think I can change the colorspace, there doesn't seem to be any such option in the settings. :mad:

KeithJenner
Nov 18, 2010, 01:28 PM
It's a Sony Bravia 32" KDL-BX300… I don't think I can change the colorspace, there doesn't seem to be any such option in the settings. :mad:

Basically, you're stuck. There is currently no known solution for the problem with many Sony and Phillips models including yours. Check out the long thread in the Apple support forum.

Sorry to be the bearer of bad tidings.

fabian9
Nov 19, 2010, 05:18 AM
Basically, you're stuck. There is currently no known solution for the problem with many Sony and Phillips models including yours. Check out the long thread in the Apple support forum.

Sorry to be the bearer of bad tidings.

it would appear you're right. Good thing I bought the TV less than 2 weeks ago so I'll return it tonight... it's clearly a Sony issue so will put it down as faulty. Got a Samsung replacement coming tomorrow morning. :)

Audiotic
Nov 19, 2010, 05:52 AM
Same here. Bought my Apple TV 2 in USA as they arent available in Holland yet. Every once in a while, and only temporarily, it shows this problem. As I have no issues on my TV with the other devices linkedin via HDMI, for me its an issue of THE Apple TV2. It is very annoying, hope Apple solves it soon.

Guys,

I recently bought a new Apple TV. The colours go really funny every now and then, everything seems to be turning pink/purpleish (see attached photo).

I have tried different HDMI cables and ports, but the problem still occurs.

Has anybody else experienced this before?!

gbfabiani
Nov 19, 2010, 09:21 AM
I have the same problem, it last 20 to 50 seconds and than it caome back normal. It happens 2 times per half an hour I guess.....
I see that the one of us who initiated the chat is Fabian9, my name is Fabiani..... but I assume that has no influence, and hope someone find a fix:)

fabian9
Nov 19, 2010, 09:54 AM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C134 Safari/6533.18.5)

I have the same problem, it last 20 to 50 seconds and than it caome back normal. It happens 2 times per half an hour I guess.....
I see that the one of us who initiated the chat is Fabian9, my name is Fabiani..... but I assume that has no influence, and hope someone find a fix:)

Lol I hope it's not name related!

rudivd
Nov 21, 2010, 10:53 PM
Hi there,

I just hooked up my ATV G2 ios4 to my SONY KDL-32EX402, and it
also suddenly goes magenta-ish. Sometimes it returns to normal all
of a sudden, or else it turns to normal if switch HDMI input sources
on the TV..

Hope Apple comes with a fix in 4.2

Rudi

fabian9
Nov 22, 2010, 02:49 AM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C134 Safari/6533.18.5)

Having spoken to apple customer service, they seem to blame Sony... Sony is blaming apple. So I'd be surprised if they came up with a solution together.

The issue seems to be isolated to Sony and panasonic (?) tvs judging by replies on the apple discussion forum.

chriso89
Nov 22, 2010, 06:08 PM
my apple tv didnt get this way before, but i updated it to 4.1 now and this happend to me too:( ****. have to change hdmi channels to get it back to normal!

jdbr
Nov 22, 2010, 06:21 PM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

No updating the firmware of the tv does not fix it and Apple know that. I don't know why they keep churning that old one out. I have spoken to Philips and they say it is an Apple problem. It seems to happen with certain PhiliPs and Sony models.
Apple have issued a faulty product. Replacing it, which will be their next suggestion does not solve the problem either.
There is a lot of discussion about this on the apple support forum. It is not the odd isolated incident! Bad apple for not fixing it or properly testing their product.