PDA

View Full Version : Booting Problems


spot618
Jan 15, 2005, 12:06 AM
I have a Powermac G3 MT (upgraded to G4 500) with OS 10.2.8 on one hard drive and OS 9.2.2 on another. When I want to change the boot disk back and forth, I have no trouble changing from the OS X boot to an OS 9 boot, but when I try to go back, it's as though the "Startup Disk" control panel in 9 doesn't work. It will let me select the OS X as my startup disk, but when I go to restart, it boots back into the OS 9. The only way I can get it to go back to booting from the OS X disk is to disable the OS 9 system folder by removing the finder. This usually crashes the computer, but when I go to restart again, it will by virtue of no other choice, boot into the OS X volume. I tried re-installing the OS 9 to get a fresh copy of the "Startup Disk" control panel, but it made no difference at all. I also tried increasing the memory allotment to the control panel, again with no results. Has anyone else heard of this problem and can offer a possible solution? By the way, holding down the "Option" button during startup has no effect on this "older" Mac.

neilrobinson
Jan 15, 2005, 12:12 AM
have you tried reseting the PRAM?

spot618
Jan 15, 2005, 12:18 AM
I didn't think of trying that. Should I do it while booted into OS X or OS9?

neilrobinson
Jan 15, 2005, 12:23 AM
usual PRAM thingy - have a search for edesign's thread on it, its a sticky

spot618
Jan 16, 2005, 10:16 PM
I tried zapping the PRAM, but it didn't help the problem. I'm going to try one more thing, though. My OS 9 volume is on a SCSI hard drive, while the OS X volume is on and ATA HD. I'm going to try re-installing the OS X but on another SCSI hard drive. Perhaps the problem could be that I'm trying to go back and forth from SCSI to ATA? I'll let you know if it works or not.

Duff-Man
Jan 16, 2005, 11:52 PM
Duff-Man says...instead of using the Startup disk control panel, try searching Apple's site for an old utility called "System Disk" - it was used to select early OS X and OS X Server startup disks, this was before the "aqua" days so it never really made it into "production." Let me know if you can't find a copy - I know I have v3.3 on a CD on my shelf somewhere.....oh yeah!

varmit
Jan 17, 2005, 10:33 AM
If these are on separate partitions, separate disks, you can hold down option or the apple key during boot (forget which one), at which point you can choose which OS to go into.

Mechcozmo
Jan 17, 2005, 11:24 AM
If these are on separate partitions, separate disks, you can hold down option or the apple key during boot (forget which one), at which point you can choose which OS to go into.

It is the option key, but this Mac might be a little bit old for that...
Try pressing and holding the "X" key on startup to see if it will restart into OS X. But then again, your Mac may be too old for that.

Try and and let us know?

(Pressing the X tells the Mac to start into OS X for a one-time-only kinda shot, but you can reuse it. Don't worry.)

Duff-Man
Jan 17, 2005, 11:32 AM
Duff-Man says....on those old beige G3's just holding the X key did not work....if I recall correctly, you had to hold option+x or was it command+x to boot into X if your default was OS 9.....oh yeah!

spot618
Jan 17, 2005, 06:54 PM
Thank you all for your suggestions. I tried them all. Neither holding down the X key, the option key, nor the Option+X key worked. I think my G3 MT is just too old for that. What did work was downloading the "System Disk" application and using that to select my OS X partition. It booted back into OS X, and I have since gone back and forth successfully. Does anyone know the reason why my OS 9 Startup Disk control panel wouldn't work, even though it presented me with the option and actually let me select OS X as a boot volume?