PDA

View Full Version : @mac.com Address Unavailable on iPhone




JayDH
Nov 23, 2010, 12:40 PM
I recently decided to start using my MobileMe account. Since I have had it since the .Mac days, I have a @mac.com address.

Since I updated my iPhone 4 to 4.2, I noticed that the only outgoing email address available is the @me.com address. I can still use @mac.com using Mail.app or the MobileMe website.

Anyone else notice this or have a solution? Thanks!



philipk
Nov 23, 2010, 01:12 PM
I bought my 3GS back in January. It would only work by using @me.com from day one.

I bought my iPad the first day it was released. It worked using @mac.com. However after the 4.2 update, the iPad @mac.com stopped working. I had to delete the account and switch to @me.com.

One side note, my secondary @mac.com address continued to work. This account is not used for syncing. I still deleted and went to the @me.com.

So, yes it is normal to have to use @me.com for your main iPhone settings.

Darathor
Dec 13, 2010, 04:29 AM
Well, it shouldn't be normal.

I have a similar problem since the last upgrade and it's very unpleasant as I want to use only @mac.com addresses.

When the .mac services closed we were certified to be able to use our @mac.com addresses seamlessly and for as long as Apple lives.

Phil A.
Dec 13, 2010, 04:37 AM
Strangely enough, I have an alias that was created before the move to mobileme, and that shows (with the @mac.com address) in the list of available sender names.
However, the @me.com address for that alias doesn't show (but does in Mail and the MobileMe website).

I think this is a bug rather than anything deliberate

scott.n
Dec 17, 2010, 03:47 PM
1. Delete your MobileMe account on your iPhone.
2. Sync the @mac.com account from your computer using iTunes.

More detail here: http://support.apple.com/kb/TS3570

It worked for me.

Darathor
Dec 27, 2010, 05:28 AM
Hello scott.n,

thank you for the kb link, it sounds quite sastisfying. I'll look into it after work!

:)