PDA

View Full Version : iTunes 10.1 freezes when I connect iPod Classic




iShell
Dec 4, 2010, 12:35 AM
Hi All,

When I connect my iPod Classic iTunes freezes. Meaning I get the 'spinning ball of death', the iPod does show up in itunes but I don't get much further than 'verifying iPod' before it freezes. I have continuously had to force restart iTunes.

The things I have tried are:
• connecting the iPod to a different USB port & using a different USB chord.
• Restarting my iMac & Repairing Disk permissions.

The iPod Classic is appox 2 years old & is running 2.0.4 mac.
The iMac is running mac OS 10.6.5 & has a 2.33 GHz Intel Core 2 Duo & 2 GB 667 MHz

My apologies if this matter has been addressed before, but I couldn't find any info by searching the forums.

Thanks for your help!



Rusalka
Dec 4, 2010, 10:17 PM
tl;dr:

Same issue with last years 160 classic. Assuming it's an issue with iTunes 10.1. Brand new nano connects with no issues.


Long version:

I think I've been experiencing this issue as well! My classic is pretty much now sitting on my desk useless for about two weeks now. I've got last years classic refresh.

Sometimes it didn't show up at all, or iTunes will freeze.

Eventually I was able to restore the ipod, but I'm never able to sync my music back because Itunes will freeze or something. or take 7+ hours (It's only 40GB of music, so that sounds like an excessive amount of time)

On black friday I took my classic in to get looked at, and they immediately assumed it wasn't working because it's got so many scratches (I'm a super klutz)

I was hoping they had some sort of diagnostic tool so they could just tell me what the problem was so I'd be able to fix it, guess they don't. They just restored it for me, though it still doesn't work.

So I'm assuming it's something going on with iTunes since we're both having malfunctions? I'm on 10.1 as well.

This is excellent news! Because I don't want to buy a new classic!

On a side note: My sister just bought a new nano on black friday, and it connects to my iTunes just fine, so I'm assuming it's just a classic problem

Tried: Repairing Macbook permissions, disk verify and repair using installation disk, reformatting ipod using disk utility, repairing ipod using disk utility, multiple restores through iTunes.

iShell
Dec 5, 2010, 12:26 AM
Thanks for your reply.

I guess I'll just have to hope the problem will be fixed in a future update. I'll contact Apple anyway, although surely they would be aware of the problem by now, what with all crash reports I have sent them!