PDA

View Full Version : iMac G4 new HD not supported?!




iDutchman
Dec 23, 2010, 03:56 PM
So I finished installing a freshly new 500GB WD Caviar BLue (IDE) 3.5" HD.
This was done in an 15" 700mhz 1GB RAM Imac G4.
It was a real pain in the ass to do and when I boot the bastard and run the install CD (Panther, don't have Tiger right now), it says that the HD is not supported.

I format with disk utility. MAC OS Journaled.

Thing I get: S.M.A.R.T. Status: Not Supported.

So it won't install. Very very frustrating.

Even though you cannot understand the language, it's quit obvious:).

What the hell is going on? Thanks in advance.



Intell
Dec 23, 2010, 04:00 PM
Its possible that it your iMac G4 doesn't have large drive support. Try this: http://nanchatte.wordpress.com/2008/04/27/128gb-large-hdd-lba48-support-on-the-g4-cube-with-leopard/

Yes, I know it is for a Cube, but it should still work just fine.

iDutchman
Dec 23, 2010, 04:32 PM
OK we're installing. Thanks for the help intell.

The problem was that a previous installed version of OSX was necessary.
Because this Panther cd's apparently are 'upgrade cd's'

So, I installed 10.1.2 (original iMac cd's) and then inserted the panther.
Still limited to 128Gb but I don't care. It's just a fun little project.
I'll be getting Tiger tomorrow. So it will run real smooth with that.

occams razor
Dec 23, 2010, 08:01 PM
That's sucky that it doesn't support large drives. Glad to hear you got it working!

iDutchman
Dec 24, 2010, 05:36 AM
UPDATE: I installed Tiger and surprisingly Tiges does support the full 500GB (!). So iMac G4's with 10.4+ have more than 128GB support.