PDA

View Full Version : Apple TV 1 not showing under Devices on iTunes




ultrasonica
Jan 7, 2011, 10:44 AM
We have a new ATV but the first version (salesman convinced my parents it was a good deal...)

We have connected both the ATV1 and iTunes but ATV will not appear under Devices as it is supposed to according to all settings instructions.
We go to "Settings" in ATV and try to connect, number code appears on TV screen but the devices is nowhere to be seen on iTunes

We are running iTunes on a Sony Vaio PC with Windows XP Professional

I've been reading around support forums and there seems to be an issue with iTunes 10 and ATV1.
There used to be an Apple TV tab on Preferences that doesn't exist anymore so a lot of the solutions proposed and apple support instructions are now unusable.

Also:

* ATV works and is connected to the Internet, we can watch trailers and YouTube videos
* iTunes also works fine, we can access the Apple store
* we have disconnected the firewall so that's not the issue (as mentioned somewhere)
* we have uninstalled McAfee (there was a thread where this solved the issue)
* we can't disconnect from iTunes library and reconnect in ATV Settings (another solution I've seen around) cause it was never connected in the first place

Can anyone help?

Thanks in advance!



Shuttleworth
Jan 7, 2011, 11:26 AM
I had a very similar problem to this last year. I've got an iMac, and I've no idea about iTunes on a PC, but this may still be of some use to you. From a post I put on a different forum:-

I tried factory restoring AppleTV, deleting iTunes preferences, mucked about rebooting my time capsule and modem, connected the AppleTV directly to the imac, no joy.

I was just about to give up when I decided to try and connect to the imac as a shared library (the AppleTV was not synced to any library due to the factory restore earlier) This worked and I could now stream from the imac to the AppleTV, the AppleTV has appeared again in the iTunes devices list, but still not in preferences.

I then went back to the AppleTV and set it up to sync to the iTunes library. This worked, the AppleTV reappeared in the iTunes devices list and I have all my syncing options back again.

TallManNY
Jan 8, 2011, 12:10 AM
I don't have a solution except to say that I've found my Apple TV 1 has been inconsistent in showing up in iTunes. Lately it has been really good, in fact solid for about the last six month. But I've had it for years and it has been hard to reach from time to time. Hopefully it will become rocksolid like mine eventually.

That said, I would have bought Number 2 myself. See my post about the fact that I'd rather rent TV shows instead of buying them.

ultrasonica
Jan 9, 2011, 04:56 AM
Thanks to both of you for responding.

We have tried that too but it's still not showing...

Regarding renting tv shows, it's not an issue since this service is unavailable in Spain anyway, but I would too nave bought atv2 myself

If anyone has any further suggestions I'd be more than thankful!

nippyjun
Jan 9, 2011, 09:34 AM
Try temporarily disabling the firewall and antivirus on your pc and reboot it and see if the appletv shows up. If it does you need to change some firewall or antivirus settings to not block it.

R34
Apr 24, 2011, 11:06 AM
I know this is an old thread, but I thought I would chime in so that other people who run into this problem might have a fix.

Ran into this problem and spent hours trying to figure it out. The thing that ended up working for me had nothing to do with port forwarding or firewalls. I'm not sure exactly why this worked, but my router is a linksys E3000, dual-band wireless-n router and by turning the 5.0 ghz band off, and turning the 2.4 GHz band to "G-only", I was able to once again reconnect with the Apple TV. Give it a shot.

BigAudio
Apr 26, 2011, 01:16 AM
I know this is an old thread, but I thought I would chime in so that other people who run into this problem might have a fix.

Ran into this problem and spent hours trying to figure it out. The thing that ended up working for me had nothing to do with port forwarding or firewalls. I'm not sure exactly why this worked, but my router is a linksys E3000, dual-band wireless-n router and by turning the 5.0 ghz band off, and turning the 2.4 GHz band to "G-only", I was able to once again reconnect with the Apple TV. Give it a shot.



I have dealt with this a lot, Between family and friends that all have apple tv's (mostly due to me... ) My trouble shooting routine goes like this.

If the apple tv says you have no movie.. check Itunes, and see if the apple tv shows up under devices. If not, reboot itunes.. If it still doesn't show, close Itunes, pull the power from the apple tv. Let it reboot.. once it is up all the way, then restart Itunes. If still not showing, There are only 2 things it can be.
1, make sure its actually on the same network. I had a friend going crazy on this one, only to find he was actually hooked to his neighbors open network.

2 reboot the router. I suspect it wasnt the change of setting in the router that helped the above post, but the reboot of the router when you made those changes..

Between family, friends, and customers, I manage about 25 apple tv's of both generations.. I have never had those steps fail for me.

Good Luck!