PDA

View Full Version : PowerBook G4 mystery -- help?!?




katewrath
Jan 16, 2011, 04:05 PM
Hi,

I've been working through the advice of various previous posters, but now I'm stuck, and hoping someone can point me towards the next step.

My 12" PowerBook G4 is stuck on the grey Apple screen, with a spinning wheel.

I ran the disc utility, ran permissions repair, ran disc repair: everything came out roses. Everything was fine, and even though I ran disc repair to be sure, it said "No repairs needed" when it was all over.

I learned from this that my CD/DVD drive still works, my fan still works, and my screen still work, but the laptop still got stuck on the grey screen.

I reset the PRAM. No change. I safe booted. No change.

I flipped over the laptop, took out the Crucial RAM I put in about three years ago, put back the Samsung RAM I removed at the same time. No change.

I reset the PMU. No change.

Now I do another safe boot, but this time, I hit Cmd-V so I can see what's going on -- and lo and behold, I get this:

"Couldn't find root user. Sleeping and retry."

This message repeats ever 5-10 seconds for 10 minutes, and then I give up and force it off again. FWIW, the date stamp on each of these messages was Dec 31, at 4:45 p.m. This was this morning, so clearly that's not right.

As you can tell, I like to fix my own problems, but I am out of ideas now. I have moved over to a MacBook Air last November, and my data is pretty backed up, but the PowerBook is an extremely handy machine and I'd like to get it up and running.

Any thoughts? Suggestions? Ritual sacrificial offerings to the Great and Powerful Jobs?

Thanks!

Kate



Intell
Jan 16, 2011, 04:12 PM
Your Mac OS X install may be corrupted. Try this:

1) Start up in Single-User by holding Command-S

2) Type "/sbin/fsck -y", hit return, then type "/sbin/mount -wu /"

3) Once you have the prompt again type "cd /var/db/"

4) The prompt will change slightly. Then type "ls" and verify that somewhere in the table of items there is the file: ".AppleSetupDone"

5) Making sure that this file is there, then you can delete it by typing "rm ./.AppleSetupDone" or move it to the root of your hard drive for safekeeping by typing "mv ./.AppleSetupDone /"

6) Once it is no longer in place, type "reboot" and the computer will restart...and the first-run video will play and prompt you to register. You don't have to fill any of this in, you can just press Command+Q, confirm the dialog, and you'll be presented with a page where you set up a new admin account. Put in whatever you want, log in, and you can change the password on your main account.

katewrath
Jan 16, 2011, 04:36 PM
Intell,

Thanks for the advice! I did exactly as you suggested -- and doublechecked that AppleSetupDone had been moved by looking at the table of items again, and yes, it was gone. After that, I rebooted and the PowerBook restarted.

So the good news is that I can follow instructions.

The bad news is that, after 10 minutes, I am still stuck on the grey screen of death. I'm not getting to the first run video or any of those goodies.

Poop!

But thanks again for the suggestion -- for 15 minutes there, I actually felt like I was doing something to solve the problem :-)

Strimkind
Jan 16, 2011, 04:55 PM
If that didn't work, a full reinstall of OS X should fix it.

If you can get it, grab DiskWarrior, boot from the CD, and it can restore the disk to the point where you can grab all your files (make sure to have a flash drive or external hard drive handy).

Intell
Jan 16, 2011, 05:09 PM
I'm afraid that a reinstall may be the only way to save it. If you're willing to go the ultra-geek route, I'm willing to tell you how.

katewrath
Jan 17, 2011, 12:29 AM
Aaaand a full re-install carried the day. Computer is back up and running, albeit with a 10G re-install on the already-overloaded hard drive, so now I've got to go through "Previous System," pull out the good stuff and trash the rest.

Intell & Strimkind, thank you for the words of advice. I'm almost a little sorry that I didn't see the "ultra-geek" option before I'd started the two hour reinstall process -- but now I have something to look forward to the next time the PowerBook craps out on me :-)

MacRumors forums to the rescue!! You guys are the best!