PDA

View Full Version : PowerMac G4 FW800 only boots while open.




applegeek13
Jan 17, 2011, 03:46 PM
I have a dual 1.25 FireWire 800 Power Mac that has been acting up lately. It was dormant for a couple weeks between Christmas and now, and when I went to boot it up, only the power button light came on. It is sending power through the ADC port, as I can get the Cinema display to turn on, but it too only displays the power light. I tried opening it up this morning, and hit the power button. It boots right up as normal, but if I try to close the case, it shuts off immediately. It works fine right up until the bottom case hits the top, or, if I close it really slowly, it works right up until I latch it. I've checked all the power connections I can find, they seem snug. So, my question is this: What the hell?

In summary:

-Power lights on both ADC monitor ans tower work
-boots fine, unless case is shut
-power connectors seem snug



macdudeguy
Jan 17, 2011, 04:13 PM
Loose heatsink?

applegeek13
Jan 17, 2011, 07:31 PM
^^^ Not that I know of. I'm going to pull it off and put some arctic silver in sometime, I'll check then.

666sheep
Jan 17, 2011, 08:04 PM
It could be damaged cable (power or IDE cable). When you're closing case it could short out or lose connection. Examine all cables and plugs for physical damages.

AlexMaximus
Jan 19, 2011, 07:21 AM
I had the same thing once on my G4 and figured it out.

Try this: When you slowly close the G4 MDD door, use a maglight or some other light and shine in the case till it closes. You need to monitor the cable tree that is connected on the mainboard that runs underneath the front HD tray. This cable tree usually is snapped on with two black cable ties on the bottom in front of the 120mm case fan. When the door shuts completely, the cable tree is bent to the max which is actually a very bad design flaw from apple. Sometimes the cable tree at the radius is bent against the ATA cable to the side, preventing it to have enough room to bent. If that is the case you need to untie the black cable ties and/or release some pressure once its door is shut.

Past "open-and-close-door-events" may have lead to cable breakage or a loose connection which you experience.

good luck

applegeek13
Jan 22, 2011, 03:17 PM
Thank you Alex, I will try that. I'm also going to replace the PRAM battery soon. I have some time to work on it, now that semester finals are over.