PDA

View Full Version : The Big Dilemma [3GS New Bootrom -> 4.2.1]




chiefpavvy
Jan 24, 2011, 08:14 PM
So here's my big dilemma. I have a new bootrom 3GS, currently running 4.1 unlocked with Ultrasn0w (5.13.04 baseband). I need to make the jump to 4.2.1 as I now have some apps which I cannot install to the phone or use as they require the latest firmware. I'd also [REALLY] like the AirPlay and AirPrint functionality which is not possible with 4.1.

The big dilemma is that I kind of need the unlock as well, and as I understand it the only way to accomplish that is by hacking in the 6.15.xx iPad baseband and losing GPS - a trade-off I'm not willing to make.

So I either sit where I'm at OR make the leap to stock 4.2.1 and [tethered] jailbreak with Redsn0w, losing my precious unlock. Precious is maybe too strong. I've been using a T-Mobile affiliate and been reasonably happy, but I *could* get by with using my H20 SIM card as I don't really use cellular voice or data very much. I'd rather have that unlock, but I guess it isn't mission critical.

My last question is what are the odds with the forthcoming 4.2.5 or (more likely) 4.3 iOS release. Will we see an unlock for the newer 5.x basebands, a patch for the GPS issues with the 6.xx.xx iPad baseband? Or am I dreaming?

Any one else in this situation? Most folks on here seem blessed with an OLD bootrom 3GS. Unfortunately mine was an Apple replacement back in September. Only good thing to come out of it was saved SHSH which was golden indeed!



PsstGreek
Jan 26, 2011, 12:56 PM
You have an unlockable baseband so there is no need in upgrading it to 6.15.

You'll just need a custom 4.2.1 ipsw to keep your baseband in order to unlock with ultrasn0w.

chiefpavvy
Jan 26, 2011, 01:40 PM
You have an unlockable baseband so there is no need in upgrading it to 6.15.

You'll just need a custom 4.2.1 ipsw to keep your baseband in order to unlock with ultrasn0w.

But such an IPSW doesn't exist and PWNage won't do it. I guess it's a moot point now since 4.3 is so close, I'm not going to bother with 4.2.1 anyway.