PDA

View Full Version : XP PC won't get on to Mac OS X Server Network




atgaviation
Jan 28, 2011, 07:29 AM
Hi all,

I've recently been setting up a new Mac Mini 10.6 Server in an office I'm working in as a standalone server. So far I've managed to set up all the functions I've needed (VPN, File Sharing etc). All the computers in the office are Macs except for one desktop PC - which refuses to recognize the Mac server.

I've activated SMB and Workgroups, however the PC simply will not find the Mac server, even if i go to Run > Server IP Address.

Does anyone have any suggestions as to where I might be going wrong?

Any help would be really appreciated as my knowledge of PC's is fairly minimal!



fluffels
Jan 31, 2011, 05:16 PM
Take a look at SMB (Samba) file sharing - without that enabled through Server Admin, your PCs will be unable to connect to shares.

Within Server Admin's SMB area you can also configure an OD server as a PDC (Primary Domain Controller) - making it pretend it's a Windows Server and allowing you to bind Windows installs to a domain. Note: Windows 7 will not work with this.

onecajun
Jan 31, 2011, 07:39 PM
try this....double click on my computer
click in the address bar and hit \\miniserve
substituting the name of your server for miniserve and hit enter.

also check ur server config
make sure the following are on
afp
dns
smb

i normally turn off open directory
also double check the name of ur server

atgaviation
Feb 5, 2011, 08:53 AM
Cheers for your replies!

onecajun - which name should I use here? The mac mini server shows as 'Mac Mini Server' to the Macs but there is also a NETBIOS name which is something like 'macmini28138'.

fluffles - one of the problems I suspect might be that the PC appears to be tied to a domain used by the previous (windows exchange) server - if I try to change this then it seems to seriously mess up the user accounts on that PC - not allowing me to log in etc.

objc
Feb 6, 2011, 01:28 AM
If it's on a windows domain then it's probably using NTLMv2 authentication.. that may be a problem. You may need to change the lmcompatibilitylevel setting in the registry and reboot, unless the Mac server can support v2... I'm not sure if it can or not.
You want the lmcompatibilitylevel setting in windows to be 3.
http://technet.microsoft.com/en-us/library/cc960646.aspx

ernestojerez
May 18, 2011, 05:28 PM
Hello! I have a macmini server running with several windows PCs.

So try this:
- Server Admin, SMB General tab check the role is PDC (Primary Domain Controller). Type a Computer name for the server that windows clients will use comunicate. And type a Domain like windom.local or wherever.

- Server Admin, SMB Access tab, check NTLMv2 & Kerberos is checked.

Then, in the windows PC make sure DNS is working properly, you should be able to see the server from that PC.

Go to RUN: CMD
At the terminal window type: nslookup
and try to see if you can access your server by typing the server name and hit enter. You should see something like:
server: (the dns server name)
address: (your dns server address)

name: (the server/client name you´r trying to access)
address: (server/client address)

If you couldn´t see that, maybe your windows client is not resolving DNS.

Try to go to the network properties to put the DNS server manually.

Sorry my english... Best luck!

Hi all,

I've recently been setting up a new Mac Mini 10.6 Server in an office I'm working in as a standalone server. So far I've managed to set up all the functions I've needed (VPN, File Sharing etc). All the computers in the office are Macs except for one desktop PC - which refuses to recognize the Mac server.

I've activated SMB and Workgroups, however the PC simply will not find the Mac server, even if i go to Run > Server IP Address.

Does anyone have any suggestions as to where I might be going wrong?

Any help would be really appreciated as my knowledge of PC's is fairly minimal!