PDA

View Full Version : iTunes sends all video to Apple TV by default now...




iMJustAGuy
Feb 3, 2011, 12:52 AM
So I've streamed from iTunes to Apple TV a couple of times and now when in my music library on iTunes, when it gets to a music video, it starts streaming it to the Apple TV instead of on my mac, when it's over it goes back to playing music on my computer. I've looked in preferences and, there are none. The bottom of iTunes has my computer chosen to output sound (and if it were the Apple TV it wouldn't be playing my music through iTunes). I click a video and it goes to Apple TV by default, if I click the little arrow on the play/next hover box in the iTunes window and then select computer, it will play it as it should but when it goes through music and get's to another video... bam.... back on Apple TV.

I know I've probably confused the heck out of you with the wording of that post but PLEASE HELP ME! (I guess I should've posted this in the iTunes section)

-Dale



Omne666
Feb 3, 2011, 03:08 AM
Most Strange.

Have you tried breaking the link?? Turning HomeShare Off in iTunes, quitting iTunes, restarting it and turning Homeshare back on? Maybe even breaking the link from the atv side also?

Sorry. Its the best I can suggest. Havent experienced it myself, but Id be taking these steps.

Sedulous
Feb 3, 2011, 03:32 AM
You could always dump your iTunes pref file. It will reset iTunes preferences back to defaults.

iMJustAGuy
Feb 3, 2011, 12:31 PM
Most Strange.

Have you tried breaking the link?? Turning HomeShare Off in iTunes, quitting iTunes, restarting it and turning Homeshare back on?

GET THIS! Home sharing is OFF! I click a video and it sends it to Apple TV!!!! Now, it displays it as being output through Apple TV in iTunes with that big black window but it wasn't actually playing because the time in iTunes was at 0:00 and not moving. I turned ATV off, click a video again, and it actually powers on my ATV as if it is about to play it... again HOME SHARING IS OFF at this point (was just running some trial and error sessions to try to fix this).... this is strange.

newagemac
Feb 3, 2011, 02:26 PM
It wouldn't matter if Home Sharing is on or off because you're using Airplay. Have you clicked the Airplay button in iTunes to choose to stop sending the video to the Apple TV? And try switching from multiple to single.

If that doesn't work, reboot your computer and then hold Down+Menu on the remote until the Apple TV light starts flashing quickly (about 5 seconds) to make the ATV reboot.

powerman
Feb 3, 2011, 04:20 PM
my itunes did this for a while. I just changed the display to the computer then reset my atv. has not done it since.

iMJustAGuy
Feb 3, 2011, 05:38 PM
It wouldn't matter if Home Sharing is on or off because you're using Airplay. Have you clicked the Airplay button in iTunes to choose to stop sending the video to the Apple TV? And try switching from multiple to single.


Ah, didn't know that about AirPlay. Yes, it's on single. And the Airplay button is set to computer. I'll try the reset of the ATV, but I don't see how this is an issue coming from that end.

AidanFrench1
Feb 3, 2011, 05:41 PM
If you click the airplay icon at the bottom right hand corner of itunes and change it to computer it should make itunes the default again. If not click the multiple speakers bit and then un-tick apple tv. :)

jaw04005
Feb 3, 2011, 06:53 PM
I had the same problem. It's clearly an annoying bug in iTunes 10.1.

I ended up -

1. Turning off Home Sharing on the Apple TV.
2. Turning off Home Sharing on the Mac.
3. Unplugging the Apple TV.
4. Restarting the Mac.
5. Opening iTunes on the Mac and selecting "Computer."
6. Enabling Home Sharing again on the Mac.
7. Plugging up the Apple TV.
8. Enabling Home Sharing again on the Apple TV.

This was recommended on the Apple Support forums