PDA

View Full Version : PLEASE HELP!! serious network speed issues (choppy, slow) not inability to connect




candybars
Feb 3, 2011, 10:59 AM
I have a 13" macbook air (the new late 2010 model, upgraded CPU, memory) that has the following problem: I can connect to wifi networks (including at home WPA and also tried WPA2 settings) but even though I may get proper speed at first, I soon lose that (permanently even while disconnecting and reconnecting) and it becomes much slower and choppy (if I open activity monitor I can see the speed going up and down like crazy...). My internet speed at home is 12mpbs set by my provider. When I perform speed tests (vis speedtest.net or downloading files from other speed test sites) on my windows PC that is also on this network I get the full download speed. However with this MAC while I initially did get the full speed, it is now down to an average of 3-5mbps and the activity monitor, again, shows choppy behavior so it will be at 8 then at zero almost and then up and down again but never near the full speed. I tried to connect to other networks and I have the same problem - once this happens it stays. I tried removing the airport connection in network preferences and adding it again it does not help.

I TALKED TO APPLE AND HAD MY COMPUTER TESTED BY THEM - they didn't find any hardware issues (they said it was fine - but it isn't) but they still replaced the airport hardware in the computer - both the chip and the antenna (which meant replacing the entire screen). I brought the computer home, ran a speed test and everything was fine. I thought GREAT but then something happened and the problem returned. What I did (which I think was unrelated) was connect via SMB to a PC at home and I tried to stream a movie file. I noticed it kept 'pausing' so I opened up activity monitor again and to my HORROR I saw the choppy wave with network speed very inconsistent going up and down like crazy... I tried connecting to my slingox using the sling web access after disconnecting from my home PC but got partial speed and lots of drops too. I tried the speed test again multiple times, nothing seems to work.

SO I don't know what to do at this point. I have 10.6.6 running. I heard something about a firmware update but I am new to mac so not sure how to even do that or what else I can do to solve this problem or what is causing it. BTW - logging in now from the guest account still does not fix the issues and they remain the same.

I am desperately looking for help!!

Thanks a lot!



double329
Feb 3, 2011, 02:26 PM
I discovered the very identical issue with my MBA. As the matter of fact, I think all Macbook Pro/Air have this problem. If you google "Mac slow wifi" you will see many people have problem. Don't get me wrong, I love my Mac, but it is definitely having issue with wifi. Most people won't notice the problem if you just do web access. :confused:

http://forums.macrumors.com/showthread.php?t=1089315

Personally, I think it is an issue with wifi driver on Mac OS. VM driver via Fusion in Windows work GREAT!!!

candybars
Feb 3, 2011, 02:45 PM
I have parallels with which I run windows. How exactly do I make that wifi connection? Can you give me the 'for dummies' version of this explanation?

Btw if anyone else has any non windows solutions I would love to hear

Thanks

2IS
Feb 3, 2011, 09:46 PM
I haven't been happy with the wifi performance of my MBA either. In fact it's by far worse then any other laptop i've owned, all of which used Intel based chipsets.

It's fine for downloading files, but streaming from my slingbox or from my media server is choppy.