PDA

View Full Version : MacRumors: Site Updates and Server Move


MacRumors
Feb 6, 2005, 12:52 PM
MacRumors will be undergoing server maintainence operations today (Sunday, Feb 6 2005) which will result in the forums being down for much of the day.

AirUncleP
Feb 6, 2005, 10:17 PM
LL Cool J once said,
"I can't live without my radio"

AirUncleP once said,
"I can't live without my MacRumors."

Sun Baked
Feb 6, 2005, 10:18 PM
Yay, it's done.. :p

Hopefully we won't see too many teething problems.

jimjiminyjim
Feb 6, 2005, 10:38 PM
... and is it me or are the forum pages loading much more quickly?

nsb3000
Feb 6, 2005, 10:41 PM
... and is it me or are the forum pages loading much more quickly?

You might even say it is *snappier* ! ;-)

Redpoetsociety
Feb 6, 2005, 10:43 PM
so far so good.
:)

KC9AIC
Feb 6, 2005, 10:43 PM
Whateve the changes, I like that it works! Thank you MacRumors team!

iceTrX
Feb 6, 2005, 10:47 PM
Hopefully this is the end of "The server is busy" messages! :D

Fiveos22
Feb 6, 2005, 10:48 PM
What are the specs of the new vs. old hardware?

Daveway
Feb 6, 2005, 10:48 PM
I spoke with Arn today. He said that the server was upgraded to a new Xeon system. So this may explain why MR is much snappier. I asked about why he didn't choose an xserve, but it was like a dead wall.

virus1
Feb 6, 2005, 10:50 PM
ah.. good to be back.. now where is the story about all the superbowl commercials?

Lacero
Feb 6, 2005, 10:58 PM
Let's see how this new server holds up during WWDC. Any bets?

VicMacs
Feb 6, 2005, 11:03 PM
i felt it!

Platform
Feb 6, 2005, 11:09 PM
Any new servers
If so which once :confused:

Peterkro
Feb 6, 2005, 11:12 PM
I think I just had a near death experience,but every things O.K. now,better even :D

aoasus
Feb 6, 2005, 11:31 PM
I think that's hilarious, running Mac Rumors on a Xeon box....

That might explain the errors and slowness all on it's own :rolleyes:

LimeiBook86
Feb 6, 2005, 11:32 PM
Yay this is faster than ever, I actually noticed a speed-boost!

Keep up the good work! :D

hob
Feb 6, 2005, 11:34 PM
I think that's hilarious, running Mac Rumors on a Xeon box....

That might explain the errors and slowness all on it's own :rolleyes:

Damn! You beat me to it! C'mon guys, why not get some XSERVES goin' on?

Hob

Daveway
Feb 6, 2005, 11:35 PM
Maybe if Arn would bring back donations we could afford an Xserve! :rolleyes:

MacNut
Feb 6, 2005, 11:45 PM
Im not sure if this is related or not but Im not getting email notifications anymore.

saabmp3
Feb 7, 2005, 12:25 AM
I think that's hilarious, running Mac Rumors on a Xeon box....

That might explain the errors and slowness all on it's own :rolleyes:

But it sped up when the Xeon boxes were put in. Don't bash it cause you don't understand it.

BEN

brandon6684
Feb 7, 2005, 12:34 AM
Could be worse. Could be running Windows on those Xeon servers.

Punani
Feb 7, 2005, 12:38 AM
Is the main page's forum activity bar still "detached" from the system?

swissmann
Feb 7, 2005, 12:40 AM
Is this in response to the big overload after MWSF? Keep up the good work guys!

all-devourer
Feb 7, 2005, 12:52 AM
I spoke with Arn today. He said that the server was upgraded to a new Xeon system. So this may explain why MR is much snappier. I asked about why he didn't choose an xserve, but it was like a dead wall.
Maybe the xeon box is a sponsor donation?

edesignuk
Feb 7, 2005, 12:55 AM
Maybe the xeon box is a sponsor donation?
Or a Dell box with a FREE Linux OS + FREE Add-ons (Apache, MySQL, PHP) is significantly cheaper ;)

Anyway, glad to see everything seems to have gone well, all is normal. Good job!

Doctor Q
Feb 7, 2005, 12:59 AM
Is the main page's forum activity bar still "detached" from the system?No.

nagromme
Feb 7, 2005, 01:09 AM
Who cares what flavor of UNIX it is, if it works :)

I even turned off StopAdvBanners for a while, in a show of support...

Punani
Feb 7, 2005, 01:21 AM
No.I'm sorry, I worded my question poorly. I'm noticing that the site's main page forum activity listings and the forum's main page seem to be out of sync. Since this was a problem just prior to the move, I was wondering about its status.

Doctor Q
Feb 7, 2005, 01:30 AM
I'm sorry, I worded my question poorly. I'm noticing that the site's main page forum activity listings and the forum's main page seem to be out of sync. Since this was a problem just prior to the move, I was wondering about its status.I think I was answering what you were asking. The comment counts and other details about the forums, as shown on the front page, were being updated only sporadically for the last couple of days, and the problem has now been fixed.

virividox
Feb 7, 2005, 01:40 AM
YAY its back!!!

Punani
Feb 7, 2005, 01:49 AM
I think I was answering what you were asking. The comment counts and other details about the forums, as shown on the front page, were being updated only sporadically for the last couple of days, and the problem has now been fixed.Oh, okay. I noticed my browser was using a cached copy just now...

Mitthrawnuruodo
Feb 7, 2005, 03:17 AM
Man, this weekend (specially yesterday) was boring... but if I never see another "Server is busy" it was totally worth it... keep up the excellent work...!!! :)

Knox
Feb 7, 2005, 03:46 AM
I spoke with Arn today. He said that the server was upgraded to a new Xeon system. So this may explain why MR is much snappier. I asked about why he didn't choose an xserve, but it was like a dead wall.

Xserves aren't an option at the company arn uses. The machine itself might be similar price to an equivalent Dell for example, but when you add on the cost of hosting and bandwidth it's cheaper to go with a linux machine from one of the mass server hosting places.

SiliconAddict
Feb 7, 2005, 07:59 AM
Do you guys want any donations? A new server can't be cheap.

ASP272
Feb 7, 2005, 08:12 AM
Thanks for the fixes guys, I noticed a lot of bugs but just dealt with them (like the main page not updating even after cache was cleared - and the whole server is too busy error). But an Xserve wouldn't give you this trouble. They are completely impenetrable rock solid Unix-based masterpieces! Ok, just kidding! :D But I did find it funny you were using a Xeon system for a Mac forum. (not surprised though)

Bibulous
Feb 7, 2005, 08:55 AM
I have been using this site for over a year and would have no problem sending a few bucks to a paypal account to help out every now and then, wouldnt even care if Arn just took that money and went out drinking with it.

Chip NoVaMac
Feb 7, 2005, 11:10 AM
Im not sure if this is related or not but Im not getting email notifications anymore.

Same here. but glad this is the only issue that I have seen so far.

Congrats on the new server.

arn
Feb 7, 2005, 11:48 AM
I'll look into the email notifications tonight.

arn

Doctor Q
Feb 7, 2005, 01:05 PM
My e-mail notifications are working fine. So either there is no longer an e-mail notification problem or it affects only certain people.

MacNut
Feb 7, 2005, 02:45 PM
My e-mail notifications are working fine. So either there is no longer an e-mail notification problem or it affects only certain people.Im still not getting e-mail notification.

Nickygoat
Feb 7, 2005, 03:47 PM
Xserves aren't an option at the company arn uses. The machine itself might be similar price to an equivalent Dell for example, but when you add on the cost of hosting and bandwidth it's cheaper to go with a linux machine from one of the mass server hosting places.
This might be a dumb question but how many servers are you using and what are they running? I know s** all about this so it's purely academic. Also, any idea when the contributions will start again? Thanks in advance :)

edesignuk
Feb 7, 2005, 03:48 PM
Things still seem to be pretty patchy over the last few hours...

Doctor Q
Feb 7, 2005, 03:52 PM
... any idea when the contributions will start again?No, because it's undecided. But it's reassuring to hear people asking about it.

zelmo
Feb 7, 2005, 03:54 PM
I ran into a couple of "server is busy" messages around 2:30PM EST, but everything has been pretty snappy since then.

I'll 3rd that question about re-instating donations to help support MR. New servers don't just fall off the back of the truck...they have to be quietly and gently lifted out while the truck is at a stop light ;)

Sun Baked
Feb 7, 2005, 03:54 PM
Things still seem to be pretty patchy over the last few hours...I wonder how much google hammers the site... :confused:

We are searchable there -- but some sites crash (or crawl to a halt) when the googlebots arrive.

Mudbug
Feb 7, 2005, 04:36 PM
Things still seem to be pretty patchy over the last few hours...

well, it's running on a Intel box, so patchy is probably the right word :)

MacNut
Feb 7, 2005, 05:05 PM
Im still not getting e-mail notification.That seems to be working now too.

arn
Feb 7, 2005, 07:04 PM
Yeah... there are still some lingering issues...

a) Fixed thumbnails... so image upload thumbnails work

b) emails problem... should be fixed over the next day or so. I had to make some DNS changes. Apparently, the new server domain hasn't completely propagated and the emails were denied for being spam-y.

c) database errors.... er... well, doing better. there's an underlying software issue going on here... so I'm still working on it. In the meanwhile, things work a bit better.

dsharits
Feb 7, 2005, 09:30 PM
Before the move, I was getting the "Server too Busy" messages constantly. I haven't had one since Sunday. Everything has been working great, including the e-mail notices. Good job, Arn.

Daniel

kretzy
Feb 9, 2005, 02:22 AM
Yeah great job!! :) I can definately notice the difference.