PDA

View Full Version : G4 can't reset password/invalid memory access




StarrRSX
Feb 4, 2011, 04:55 PM
So I've had this laptop forever and I thought it was broken and never used it for 2+ years. I recently moved and I discovered it does work, but I cant update anything without the admin password (which I forgot). I have EVERYTHING that goes with it, so i figured no problem I can follow the directions to reset it with the install disc.

Problem: I follow all instructions (put in disc, reset computer, hold down "c") and I get a screen that says blah blah type "mac-boot" to boot or type "shut-down" to shut down (instructions don't say anything about this screen) I figure I'll type mac-boot. Then I get a screen with just the mac face inside a folder and it will occasionally flash a "?" inside the folder than go back to the mac face. I don't know what to do now, I wait and nothing happens, I tried pressing buttons, but nothing happens. Any help would be greatly appreciated, otherwise I'll have to go down to the applestore :(

My problem sounds somewhat similar to this thread, except I CAN start my computer like normal, but i cant change my password, so I can't update anything.http://forums.macrumors.com/showthread.php?t=597541

crappy pics, if it helps :
http://i132.photobucket.com/albums/q2/Starrshatterred/IMG_6186.jpg
http://i132.photobucket.com/albums/q2/Starrshatterred/IMG_4176.jpg

Sorry if I'm just a complete moron



max••
Feb 5, 2011, 01:47 PM
try holding down option (alt) instead on c and see if it will let you chose the cd as the boot device

StarrRSX
Feb 5, 2011, 01:56 PM
try holding down option (alt) instead on c and see if it will let you chose the cd as the boot device

I did that it just went to the "mac-boot" screen when I clicked the CD...I also tried running the apple hardware test CD...that cd worked fine and it said it didnt find any problems.

max••
Feb 5, 2011, 02:02 PM
ok. at the screen wheere it says macboot type: reset-nvram then type set-defaults then type reset-all and see if holding c will boot from cd

StarrRSX
Feb 5, 2011, 02:08 PM
it just goes back to the the "mac-boot" screen