PDA

View Full Version : Apple TV (Gen1) wont stream




Cr0nJ0b
Feb 13, 2011, 10:53 PM
Hey guys,

I'm having a ton of issues with my "new" gen 1 ATV. What I want to do, is stream my library to the ATV and use my iphone remote to play songs etc. I'm not sure what to expect, but I'm not getting anything good.

I have it connected "wired" to a wireless bridge. I can connect to the network and I can see itunes content and I can login to iTunes.

I can connect to my iTunes (latest version) in either Win7 or OSX 10.6. I connect (get the numbers...run upstairs...input them...apple say ok...shows up in itunes etc) Then the library shows up sort or greyed out.

I go back to the ATV menu and look for songs in MYsongs and nothing. The note under ATV menu for sharing said to look in "shared" folder, but there are no "shared" folders listed under music or photos.

I'm thinking that it takes a while to sync and nothing shows up until it's competed syncing...that might be the case...or not...I have no idea.

any help would be appreciated.



Omne666
Feb 14, 2011, 12:33 AM
There are two methods for the atv1 to connect...synced and streamed.

Choose the first option and you get no 'shared movies' etc in the menues, every things under 'My Movies' etc....IF in itunes you've chosen what to sync.

Choosing the second option gives you the streaming version of things where you get the 'shared' menus showing.

Make sure you choose the second option.

That you iTunes library is showing up grey means it's synced or streamed but cannot find the library.

Select on the atv the grayed library and let it disconnect and do it again, but make sure you choose the second option. That's streaming.

I went through a period where my atv1s constantly dropped the link and I had to reboot them to get the link re-established. Seemed to fix itself.

Give it a try and see how you go.

Cr0nJ0b
Feb 14, 2011, 03:56 PM
I initially tried the setup with Stream, not sync...but in both cases it's not working as I would expect. The only answer I can come up with is the the stupid ATV takes some time to sync metadata data in "stream" mode and it doens't mention that on screen. My sense is that you setup the stream mode, and it might take like 1Minute per 100 songs or something for the xml sheet inside the ATV to get updated with the song information form itunes. During that process the the ATV can become un responsive or stop reporting up to iTUnes...it will drop etc...until it's all up to date. After that it works pretty much as advertised...at least that's what i'm hoping for.

rayward
Feb 14, 2011, 04:29 PM
I initially tried the setup with Stream, not sync...but in both cases it's not working as I would expect. The only answer I can come up with is the the stupid ATV takes some time to sync metadata data in "stream" mode and it doens't mention that on screen. My sense is that you setup the stream mode, and it might take like 1Minute per 100 songs or something for the xml sheet inside the ATV to get updated with the song information form itunes. During that process the the ATV can become un responsive or stop reporting up to iTUnes...it will drop etc...until it's all up to date. After that it works pretty much as advertised...at least that's what i'm hoping for.

Couple of things:

1) Your Mac/PC that runs iTunes and hosts your media library has to be awake with iTunes open and running in order for the ATV to pull content from it. This is critical if your are just streaming and mostly important if you are syncing (because the ATV will have some content on board that's always available). If any part of this is not happening, your ATV is useless.

2) If you are not syncing, go to the ATV page in iTunes, and make sure that the option that says something like "Show only synced items" is UNchecked. If you are streaming and have no synced content, if this is checked it will mean you will see nothing in the ATV menus.

FWIW, I choose to sync music and photos to my ATVs, so that it's always available regardless of the state of my Mac/iTunes, and then stream movies and tv shows. My Mac "wakes on network" when it gets pinged by an ATV, so the awake/running thing isn't a problem (this only works on newer Macs, and I have no idea whether a PC can do this).

p17blo
Feb 15, 2011, 08:22 AM
Just to confirm (as I have a ATV1 working in 'stream' mode) - You have to 'sync' the box which seems to sync the meta data for the library. Once you have done this you should be able to stream from your itunes library as long as you have un-checked the box that says 'Only show downloaded Content' (Or whatever that does actually say - I am sure you know the box I am on about).

One thing to note though, if your wireless bridge 'slips' and your ATV looses site of your itunes library you won't see anything.

Paul

EvilC5
Feb 15, 2011, 08:46 AM
since you are using a bridge, does it by chance assign its own ip address from its DHCP pool? it might be that you are not on the same network segment as the pc with itunes running. as long as you have a connection to the internet, you will be back to see itunes content even if the pc is turned off.