PDA

View Full Version : My 1st Lion bug ... with NAS drive




mmomega
Feb 24, 2011, 06:23 PM
1st Lion bug for me so far

I can no longer log into my Western Digital MyBook World NAS.

Guest account shows up in finder but I have a password set to read/write to the drive. When I go to "Connect as" and Log in as Admin I get "The version of the server you are trying to connect to is not supported. Contact admin..."

Works just fine on SL on any other Mac.



celticpride678
Feb 24, 2011, 06:29 PM
It might not be an issue with Lion. That specific hard drive may just not support it.

mmomega
Feb 24, 2011, 07:03 PM
Sorry not understanding what the hard may not support.

If you mean the connect as, then it does and it always has.

As stated before the exact same steps for logging into the user specific accounts work on all other Macs under Snow Leopard, Lion is a no go ATM.

jamesarm97
Feb 24, 2011, 09:10 PM
I have the exact same issue here with a FreeNAS server using AFP. I get the same message. I sure hope it is a simple bug in Lion and not something that has to be changed with all the NAS software. All I see in the logs of FreeNAS is error in afp_open.

mmomega
Feb 24, 2011, 09:19 PM
I reported it as soon as I found it, hoping for a fix in the next build or two.

retroneo
Feb 24, 2011, 09:42 PM
You should be able to connect fine using cifs:// or smb://

You may even find it is faster!

Transeau
Feb 24, 2011, 11:51 PM
+1 for me.

Lion can not connect to my FreeNAS *OR* my 10.6.6 Xserve

happygareth
Feb 25, 2011, 03:13 AM
Connecting by smb works fine. I didn't have a great deal of time to look into the problems yesterday but I do wonder if the problems are with authentication. Guest accounts work fine. I do wonder if taking the password off the account may work. AFP is still showing as v2.0 but something has changed somewhere.

This was from a Synology NAS.

sstyle
Feb 25, 2011, 06:45 PM
The same issue with synology ((

Jermn8r
Feb 25, 2011, 08:13 PM
Same here guys, I can't connect to my NAS. I use a pogoplug and samba solution... Normally I can connect to my samba drives by going to Go > Connect To Server but it won't work now.

I get the same error message... Hopefully this will be fixed in a future beta. Macs running SL connect to the same share flawlessly. Two Apple TV 2's also connect to the same share. Filed a report.

cyberia625
Feb 26, 2011, 01:25 PM
The issue definitely appears to be a change in the version of the AFP client that Lion is using. For now, I fixed it by changing the afpd server running on my NAS. If you don't know what SSH is, don't try this, because I have no interest in turning this into a support thread.

I have a Netgear ReadyNAS Duo, so my steps are specific to that device...


1. SSH to NAS
2. find afpd.conf (mine was at /etc/netatalk/afpd.conf)
3. my original line looked like this:
- -uamlist uams_clrtxt.so,uams_dhx.so -unixcodepage UTF8 -maccodepage MAC_ROMAN -setuplog "default log_info /var/log/netatalk.log"
I replaced it with this:
- -uamlist uams_guest.so -unixcodepage UTF8 -maccodepage MAC_ROMAN -guestname "admin" -setuplog "default log_info /var/log/netatalk.log"

Things to note about the above changes:
I changed the available UAM list, so instead of only accepted clear-text passwords (uams_clrtxt.so) or encrypted passwords (uams_clrtxt.so), it accepted only guest connections (uams_guest.so).

In order to get the right permissions for my shares, I had the guest account automatically use the "admin" account (-guestname "admin").

THIS MEANS ANYONE ON THE NETWORK CAN ACCESS THE SHARES, AND THEY WILL BE LOGGED IN AS ADMIN. YOU HAVE BEEN WARNED.

I still can't get timemachine to work over the network, but this is a start. Unfortunately my NAS uses the Debian Sarge release, which is really dated. If anyone else's NAS uses a more modern release, try upgrading your netatalk to a newer version (apt-get upgrade netatalk, or download it from the netatalk site and compile from source). Also, try a different encryption type (uams_dhx2.so). It requires libgcrypt, which I couldn't get installed on my NAS. I could see the list of available UAMS at /usr/lib/netatalk/

My guess is that it will require an upgrade on the NAS, as it appears Apple has updated their AFP client to be more secure. *Maybe* they'll allow a less secure "compatibility" mode, but I'm not holding my breath.

Best of luck!
Paul

cyberia625
Feb 26, 2011, 02:21 PM
After doing some additional investigation, it looks like some smarter people have come to the same conclusion as me: the new version of AFP requires DHX2 authentication. The reason they are smarter? They came up with a solution (at least for ReadyNAS Duo devices):

http://www.readynas.com/forum/viewtopic.php?f=28&t=51033 (see end of thread)

cheechvt
Jul 24, 2011, 06:51 PM
You should be able to connect fine using cifs:// or smb://

You may even find it is faster!

And it IS faster too... thanks!!

Cheechvt

balamw
Jul 24, 2011, 07:02 PM
Lion support through netatalk 2.2. coming soon to other NAS vendors too. http://forums.macrumors.com/showpost.php?p=13016995&postcount=46

B

elppa
Oct 2, 2011, 03:10 PM
I've tried this fix (http://community.wdc.com/t5/My-Book-World-Edition/WORKING-FIX-Time-Machine-Lion/td-p/230864) posted to the WD Support forums (for the My Book World Edition).

I can confirm it works. Western Digital have committed themselves to a firmware update which will fix this issue (they did actually release one on 12th Sep, but had to pull it due to some issues), so these instructions should only be followed if you are not patient enough to wait.

The instructions take you to a forum post, which link you to a wiki post, which link you to drupal free.fr site, so for simplicities sake I have condensed below:

Part One - Turn on SSH (in the admin panel)
[1] Go to to http://mybookworld.local
[2] login: username will be admin, password will be whatever you have setup. If you can't remember it should be in your Mac OS X keychain (Utilities > Keychain Access, search for "mybookworld"). If you have not changed if from the default the password will be admin as well.
[3] Switch to advanced mode.
[4] From the System tab, pick Advanced.
[5] Enable SSH Access, and click submit.
[6] Click on the network tab and then the LAN button
[7] Make a note of the IP address

Small, maybe obvious, but nevertheless important point: For the install to work, your NAS needs to be connected to a router with internet access.

Part Two - Install netatalk2.2
[8] Open Terminal.app (Utilities > Terminal)
[9] Enter the following command (substitute in 127.0.0.1 for the actual IP address you noted down in step 7), then hit return:
ssh root@127.0.0.1
[10] When prompted, enter the ssh password (will be welc0me).
[11] You are now going to download the installer. Enter the following command, then hit return:
wget http://mybookworld.wikidot.com/local--files/netatalk2-2-on-whitelight/install_netatalk.sh -O install_netatalk.sh
[12] Once completed, you will need to run the installer. Type:
sh install_netatalk.sh
[13] You will be asked a number of question during install, answer yes to all. When asked about the "DHX2 login process", I opted to install the modified version, so I can confirm it works.
[14] Once the box has restarted, you should be able to connect to your afp shares and continue to use Time Machine.

Mgkwho
Dec 21, 2013, 08:22 PM
I can confirm that this fix still works; I'm running 10.9 and am pleased that after three years of being unable to use Time Machine on a $300 hard drive (though previously successful) I can now back up my system again!

Thanks, elppa!

-=|Mgkwho

hawkipa
Feb 28, 2014, 02:45 AM
Hi, my WD white light time capsule stopped connecting earlier this week so in desperation I followed the process kindly posted below. However, it didn't work so I wonder if anyone could help me undo the installing netatalk bit as I'm worried I've made some change that could impact elsewhere and worse still my time capsule still isn't working. Thanks in advance.

Paul
(macrumors newbie)

I've tried this fix (http://community.wdc.com/t5/My-Book-World-Edition/WORKING-FIX-Time-Machine-Lion/td-p/230864) posted to the WD Support forums (for the My Book World Edition).

I can confirm it works. Western Digital have committed themselves to a firmware update which will fix this issue (they did actually release one on 12th Sep, but had to pull it due to some issues), so these instructions should only be followed if you are not patient enough to wait.

The instructions take you to a forum post, which link you to a wiki post, which link you to drupal free.fr site, so for simplicities sake I have condensed below:

Part One - Turn on SSH (in the admin panel)
[1] Go to to http://mybookworld.local
[2] login: username will be admin, password will be whatever you have setup. If you can't remember it should be in your Mac OS X keychain (Utilities > Keychain Access, search for "mybookworld"). If you have not changed if from the default the password will be admin as well.
[3] Switch to advanced mode.
[4] From the System tab, pick Advanced.
[5] Enable SSH Access, and click submit.
[6] Click on the network tab and then the LAN button
[7] Make a note of the IP address

Small, maybe obvious, but nevertheless important point: For the install to work, your NAS needs to be connected to a router with internet access.

Part Two - Install netatalk2.2
[8] Open Terminal.app (Utilities > Terminal)
[9] Enter the following command (substitute in 127.0.0.1 for the actual IP address you noted down in step 7), then hit return:
ssh root@127.0.0.1
[10] When prompted, enter the ssh password (will be welc0me).
[11] You are now going to download the installer. Enter the following command, then hit return:
wget http://mybookworld.wikidot.com/local--files/netatalk2-2-on-whitelight/install_netatalk.sh -O install_netatalk.sh
[12] Once completed, you will need to run the installer. Type:
sh install_netatalk.sh
[13] You will be asked a number of question during install, answer yes to all. When asked about the "DHX2 login process", I opted to install the modified version, so I can confirm it works.
[14] Once the box has restarted, you should be able to connect to your afp shares and continue to use Time Machine.