PDA

View Full Version : Shortcut to Launchpad




Gangztax
Feb 27, 2011, 06:47 AM
I was meddling around with Lion and I noticed the fact that Launchpad is nowhere to be found inside the hard drive. It seems to be only present on the dock, it doesn't have a shortcut anywhere else.

The reason I'm wondering this is because I would want to set my mouse button 4 or 5 to automatically start launchpad, but since it's not considered an application, and isn't located anywhere inside the computer, is there any way to find or make a shortcut to it so I can assign a button to it?



jnozsc
Feb 27, 2011, 07:14 AM
You can use 4 figures in trackpad to launch the LaunchPad, wish the mouse shortcut too

Gangztax
Feb 27, 2011, 07:49 AM
True, except I don't have a trackpad or a magic mouse, nor am I interested in paying 69$ for either.

Warbrain
Mar 8, 2011, 06:00 AM
You can set up a hot corner for Launchpad.

Shorties
Mar 8, 2011, 08:26 PM
Go to System Preferences > Expose and spaces > Slide the slider to spaces and set your keyboard shortcut there, you have three options, I set mine as Command and arrow keys. With that, you press Command Up and it brings you to LaunchPad

saschke
Mar 9, 2011, 04:46 AM
Go to System Preferences > Expose and spaces > Slide the slider to spaces and set your keyboard shortcut there, you have three options, I set mine as Command and arrow keys. With that, you press Command Up and it brings you to LaunchPad

Are you mistaking Launchpad for Mission Control? If I press ctrl+arrowUp (my preference for switching spaces is ctrl+arrows), it takes me to Mission Control, not Launchpad.

Shorties
Mar 9, 2011, 11:13 PM
Are you mistaking Launchpad for Mission Control? If I press ctrl+arrowUp (my preference for switching spaces is ctrl+arrows), it takes me to Mission Control, not Launchpad.


Oh whoops never mind, yeah I was. I also noticed today that my old expose button for show all windows (F12) has changed to mission control even though there are no options anymore in the expose system preferences to set those keys as that, my guess is that is where you will set hotkeys to open Launchpad or mission control or whatever you want it to be, but this build of lion hasn't added that feature yet.

Sirobin
Mar 9, 2011, 11:30 PM
As far as I can tell, Launchpad is part of the Dock, not a separate application, so youíre probably out of luck for now. Iím sure Apple will add additional ways to launch it eventually though.

andyorkney
Jul 4, 2011, 06:03 AM
go to system prefs, keyboard. Then click Launchpad and Dock. Then un-tick and re-tick the Launchpad option and it will give you opportunity to assign a keyboard shortcut. I've gone for Command Option L

hope this helps someone

CyBeRino
Jul 4, 2011, 06:18 AM
I have a Launchpad Launcher app in my /Applications much like Mission Control, Dashboard, etc.

Typswif2fingers
Jul 4, 2011, 06:30 AM
You can set up a hot corner for Launchpad.

It may be me, but Hot Corners have always been the easiest way to launch the Spaces, Expose and Dashboard on Snow Leopard and Mission Control, Launchpad and Dashboard in Lion.

Quite a fan of Hot Corners.

LociKW
Jul 4, 2011, 02:44 PM
I may be slow :confused: but I had a few minutes of frustration trying to set this until I randomly double clicked where the shortcut is actually defined on the right side (which is blank as default). Once I clicked in that area it was easy to setup.

I also used CTRL-COMMAND-L

Thanks for the help.

RobT
Jul 4, 2011, 03:47 PM
I may be slow :confused: but I had a few minutes of frustration trying to set this until I randomly double clicked where the shortcut is actually defined on the right side (which is blank as default). Once I clicked in that area it was easy to setup.

I also used CTRL-COMMAND-L

Thanks!

I had been missing with this for quite a while and your advice finally got it workng for me.

Thanks for the help.

buckers
Jul 20, 2011, 03:00 PM
Bizarre. This worked initially; had F8 assigned to Launch Pad. But after restart, it stopped working, and now, no combination of keys will work :S

mox358
Jul 20, 2011, 09:04 PM
Bizarre. This worked initially; had F8 assigned to Launch Pad. But after restart, it stopped working, and now, no combination of keys will work :S

I'm having the same problem. My folders in Launchpad wouldn't let me rename them, Apple Support forums said to restart and it would fix the problem. I did that, and found out my keyboard shortcut for LP no longer works, even though it's still set in the Keyboards system preference pane.

Unchecking, reassigning, and trying again has yielded no success thus far.

opfeffer
Jul 21, 2011, 01:31 AM
I'm having the same problem. My folders in Launchpad wouldn't let me rename them, Apple Support forums said to restart and it would fix the problem. I did that, and found out my keyboard shortcut for LP no longer works, even though it's still set in the Keyboards system preference pane.

Unchecking, reassigning, and trying again has yielded no success thus far.

same here. the keyboard shortcut was working fine for the first thirty minutes or so until it suddenly stopped working. any ideas?

DagazaGZ
Jul 21, 2011, 02:42 AM
I have it set to a hot corner. Way more convenient for me.

mox358
Jul 21, 2011, 08:06 AM
same here. the keyboard shortcut was working fine for the first thirty minutes or so until it suddenly stopped working. any ideas?

I've tried a ton of things... nothing has worked yet. I've been watching the apple support forums as well as here, but I haven't found a solution yet. Which really sucks because I actually like launchpad a lot more than I thought I would. Oh, the irony! haha

roadbloc
Jul 21, 2011, 08:08 AM
Not sure what you are all on about. Launchpad is in the Applications folder and not just a part of the dock.

whambam
Jul 21, 2011, 10:19 AM
If you are using your trackpad, I found this by mistake. Put 5 fingers on your trackpad opened apart and close them together in the center. That launches launchpad. Enjoy!

buckers
Jul 21, 2011, 11:05 AM
I've tried a ton of things... nothing has worked yet. I've been watching the apple support forums as well as here, but I haven't found a solution yet. Which really sucks because I actually like launchpad a lot more than I thought I would. Oh, the irony! haha

I know it's been said already, but using a hot corner does the trick for me. But I'd much rather have button on the keyboard like I did when I first set it up. I didn't think I'd like Launch Pad or Fullscreen, but after using only an iPhone on holiday it feels just like having a homescreen on my Mac; nice. :)

goastros
Jul 21, 2011, 12:50 PM
I know it's been said already, but using a hot corner does the trick for me. But I'd much rather have button on the keyboard like I did when I first set it up. I didn't think I'd like Launch Pad or Fullscreen, but after using only an iPhone on holiday it feels just like having a homescreen on my Mac; nice. :)

Agreed... it takes like like 10 minutes to hit use a hot corner on my 30" monitor.

To set your launchpad short key, open up system prefs and go to keyboard/keyboard shortcuts and set it to what ever you want.

Additionally, I use bettertouchtool that I can set up on my magic mouse to enable any number of gestures to activate the keyboard shortcut.

davedude
Jul 21, 2011, 12:51 PM
Launchpad is in the Applications folder.

Just drag it back into the dock. I set a shortcut key to Command+Esc to activate it as well.

buckers
Jul 21, 2011, 03:10 PM
To set your launchpad short key, open up system prefs and go to keyboard/keyboard shortcuts and set it to what ever you want.

Only worked for a short while and hasn't worked since (no matter how many times I restart or what I set the key I set it to). Must be a bug.

mox358
Jul 21, 2011, 03:54 PM
I know it's been said already, but using a hot corner does the trick for me. But I'd much rather have button on the keyboard like I did when I first set it up. I didn't think I'd like Launch Pad or Fullscreen, but after using only an iPhone on holiday it feels just like having a homescreen on my Mac; nice. :)

Yeah... I've almost been tempted into trying it, but I've never been a huge fan of hot corners for stuff like this. I use my hot corners for putting the display to sleep and starting screen saver.

The keyboard shortcut was perfect for how I work, so it figures it'd be a bug. Oh well... it gives me something to look forward to in 10.7.1 I guess

extensor
Jul 22, 2011, 06:26 AM
... I would want to set my mouse button 4 or 5 to automatically start launchpad...

I got it to work with Button 4 on my mouse. I set my Launchpad shortcut to control spacebar. Then I wrote this applescript.

tell application "System Events"
key code 49 using control down
end tell

Then I went into the prefs of USB Overdrive ( a mouse prefs add-on I already had) and added the apple script to Mouse Button 4.

Arkanok
Jul 22, 2011, 06:40 AM
Bizarre. This worked initially; had F8 assigned to Launch Pad. But after restart, it stopped working, and now, no combination of keys will work :S

I have the EXACT same problem! Thankfully it's not just me.
Any fix yet?

bboysloth
Jul 22, 2011, 12:11 PM
Go to System Prefs/Keyboard/Lauchpad & Dock

-from there click "restore to defaults" (the box for "show Lauchpad" will uncheck

--when you check the box again, it will ask you to enter in a Keyboard Shortcut of your choosing (i did CMD+L)

--you're done!!!!


-Apple Genius-

startamovement
Jul 22, 2011, 12:29 PM
I tried resetting PRAM yesterday and it didn't work. What I did today was reset the keyboard shortcut to default, then restted my PRAM and now it works.

http://support.apple.com/kb/ht1379

RobT
Jul 22, 2011, 02:08 PM
I've had this experience as well and like the post above, I did this"

"Go to System Prefs/Keyboard/Launchpad & Dock

-from there click "restore to defaults"

Then I restarted making sure to uncheck the restore option in the restart dialogue box. If you leave it checked it reloads whatever is hosing your setting. Then go back to System Prefs/Keyboard/Launchpad & Dock and set the key combination again.

femmebot
Jul 22, 2011, 02:38 PM
You can also just pinch with your four fingers to invoke Launchpad according to David Pogue (http://www.nytimes.com/2011/07/21/technology/personaltech/the-usual-apple-upgrade-big-steps-forward-a-stumble-backward-state-of-the-art.html)

Sully1980
Jul 22, 2011, 05:54 PM
if you take your three fingers and your thumb and move then on a diagonal angle on your trackpad toward each other... launchpad will open. to get rid of it do the same movement only away from each other

z0808k
Jul 23, 2011, 03:09 AM
You can find the gesture for launchpad in here..
http://support.apple.com/kb/HT4721

buckers
Jul 23, 2011, 05:19 AM
-from there click "restore to defaults" (the box for "show Lauchpad" will uncheck

--when you check the box again, it will ask you to enter in a Keyboard Shortcut of your choosing (i did CMD+L)


This worked for me, thank you! :D

How can I be sure it won't revert like it randomly did before, though?

mox358
Jul 24, 2011, 01:54 PM
I've had this experience as well and like the post above, I did this"

"Go to System Prefs/Keyboard/Launchpad & Dock

-from there click "restore to defaults"

Then I restarted making sure to uncheck the restore option in the restart dialogue box. If you leave it checked it reloads whatever is hosing your setting. Then go back to System Prefs/Keyboard/Launchpad & Dock and set the key combination again.

Just tried this and it worked like a charm! Thanks!

auto4d
Jul 24, 2011, 03:31 PM
I have launchpad set to F4, since it'll be there soon anyway...

Branskins
Jul 24, 2011, 04:50 PM
I used functionflip to assign launchpad to my dashboard keyboard key since I don't really use dashboard. You could look into that

buckers
Jul 25, 2011, 09:45 AM
Keeps reverting back. I assume this'll get patched at some point. I'm kind of getting used to Hot Corners, now.

I used functionflip to assign launchpad to my dashboard keyboard key since I don't really use dashboard. You could look into that
Sounds worth a look-in

Grug
Jul 28, 2011, 10:00 PM
go to system prefs, keyboard. Then click Launchpad and Dock. Then un-tick and re-tick the Launchpad option and it will give you opportunity to assign a keyboard shortcut. I've gone for Command Option L

hope this helps someone

Beauty - thanks mate. This did the trick for me.
I went with F5 alongside dashboard and mission control.

Icy1007
Jul 28, 2011, 10:55 PM
Launchpad is a separate app in the Applications folder.

Mr. Incredible
Jul 31, 2011, 10:24 PM
I've had this experience as well and like the post above, I did this"

"Go to System Prefs/Keyboard/Launchpad & Dock

-from there click "restore to defaults"

Then I restarted making sure to uncheck the restore option in the restart dialogue box. If you leave it checked it reloads whatever is hosing your setting. Then go back to System Prefs/Keyboard/Launchpad & Dock and set the key combination again.

This worked for me.

Thank you! :)

samueljt
Aug 4, 2011, 05:46 PM
Just go here http://www.youtube.com/watch?v=42PCn-XB0N8&feature=player_embedded

HappyJoe
Aug 7, 2011, 11:34 AM
Behind this lurks the issue of how hotkeys are stored and changed deeper down. Are these also done via 'defaults' or 'plist'? Any suggestions about how to learn what 'defaults' are available and what range of values they can have?

I, too, need to use the keyboard for speed and continuity.

Nuck81
Aug 7, 2011, 12:35 PM
So are you not allowed to add in the apps and programs to launchpad that you actually want in there?

I've tried everything I know how to add Swackett, Coconut Battery, Google Chrome, Firefox, a few games, and pretty much every other app I use regularly and it won't accept them.

I STILL have to go to Finder, apps folder, or have them in my dock. So what's the point?

HappyJoe
Aug 7, 2011, 02:30 PM
So are you not allowed to add in the apps and programs to launchpad that you actually want in there?

Have you noticed that there might be more than one L'pad screen? I didn't until I inadvertently hit a right arrow key and suddenly my other apps appeared! I have my apps in two folders 'Applications' and '~/Apps' (for all d'loaded apps) and they appear with a screen for each folder and, mostly, that is how they are divided. Most folders are invisible except Utilities, which is inside Applic.s, and 'Developer', which is not. Duplicates sometimes appear when I have inadvertently created aliases when I thought I was dragging apps to their preferred folder. Auto-aliases are another unwanted Lion 'improvement' (cured by 'Cmd-drag').

I still want my hotkey!

Nuck81
Aug 7, 2011, 03:20 PM
Have you noticed that there might be more than one L'pad screen? I didn't until I inadvertently hit a right arrow key and suddenly my other apps appeared!

Well I'm a huge goober, there they were.

Thanks bro!!

HappyJoe
Aug 7, 2011, 06:40 PM
I still want my hotkey!
...and I found it in the form of a hotkeys/shortcuts manager, Spark. See http://www.shadowlab.org/Software/spark

I now press Option-L and up pops the Launchpad screen(s).

For a (very) short laugh, press the Option key while L'pad is up...

r3trol0gic
Aug 14, 2011, 08:09 AM
Download the application Spark, it will let you assign whatever shortcut you want to open launchpad.

http://www.macupdate.com/app/mac/14352/spark

liamgeorge706
Aug 15, 2011, 12:22 AM
Hey, just a random question. I was looking around at the keyboard shortcuts and I somehow managed to screw up the F4 button for launchpad. When I press to button, Launchpad doesn't show up. It only shows up when I press fn+F4. I don't know what I did, I've tried to restore the defaults etc, etc but I can't seem to get it back to normal. Help?

basher
Aug 15, 2011, 12:30 AM
Hey, just a random question. I was looking around at the keyboard shortcuts and I somehow managed to screw up the F4 button for launchpad. When I press to button, Launchpad doesn't show up. It only shows up when I press fn+F4. I don't know what I did, I've tried to restore the defaults etc, etc but I can't seem to get it back to normal. Help?

System Preferences, Keyboard. In the keyboard section, clear the checkmark in the 'Use all F1, f2, etc...."

liamgeorge706
Aug 15, 2011, 12:34 AM
System Preferences, Keyboard. In the keyboard section, clear the checkmark in the 'Use all F1, f2, etc...."

Yeah, I've tried that, but it won't let me enter in just F4 on its own. =/

JustDC
Aug 22, 2011, 09:39 AM
Bizarre. This worked initially; had F8 assigned to Launch Pad. But after restart, it stopped working, and now, no combination of keys will work :S

Man, I thought I was the only one having this stupid problem...

tur
Sep 4, 2011, 11:47 AM
:) helped me thanks.. strange you should have to search out such an obvious thing

go to system prefs, keyboard. Then click Launchpad and Dock. Then un-tick and re-tick the Launchpad option and it will give you opportunity to assign a keyboard shortcut. I've gone for Command Option L

hope this helps someone

Trikks
Sep 6, 2011, 02:19 PM
To open it with a mouse key check this
http://trikks.wordpress.com/2011/09/06/launching-the-new-lion-launchpad-with-a-mouse-key/

sroberson
Mar 9, 2012, 02:31 AM
go to system prefs, keyboard. Then click Launchpad and Dock. Then un-tick and re-tick the Launchpad option and it will give you opportunity to assign a keyboard shortcut. I've gone for Command Option L

hope this helps someone

Thanks for this tip. Something slightly odd that took me a while to figure out was that you may not be able to set the shortcut keys using an external keyboard on a MacBook. I had to use the MacBook keyboard rather than a wireless keyboard before I could get it to work properly.

Cheers!