PDA

View Full Version : Headphones jack and Audio not working after OS X Lion Beta upgrade




MetRob24
Feb 27, 2011, 04:13 PM
Hello to everyone,

I've search around and I haven't found an answer to the following.

After I upgrade my MacBook Pro to OS X Lion Beta from Snow Leopard the Headphones jack and Audio are not working properly.

Here's what's happening, see below.

1 - When I plug in my External Speakers Bose Companion 2 or headphones to the Headphones jack the Audio starts to sound pretty bad. and in order for me to fix this I have to turn of the Mac and re-start it. After the Mac restarts again (with speakers plug in), the sounds goes back to normal. But if I unplug the speakers/headphones from the jack the sounds goes bad again. Once I re-start the Mac again with the Speakers un-plug the sound goes back to normal. But if I plug the speakers/headphones again the sounds goes bad again.

I just want to double check if any one is experiencing the same issue after OS X Lion Beta upgrade. This wasn't happening before I did the upgrade.

Can anyone let me know what might be the issue here, I am considering doing a whole system restore back to Snow Leopard to figure out if is a Software related issue or Hardware issue (headphone jack gone bad). I am out of my 1 year warranty and I don't want to even think about is a HW issue.

Thanks in advance to everyone and appreciate your help and comments on this issue.

Note: My Brother in-law has a MacBook Pro 13" (2010) running on Snow Leopard and I plug in the Speakers/Headphone and the issue I mention above does not happen to his Mac.

Thanks,
Roberto



ca7l0s9
Feb 27, 2011, 11:16 PM
I have the same problem with my 2010 13" MacBook Pro. The audio will also sound pretty bad after leaving the headphones in without playing anything for a while. Hope there's a workaround.

Regards,
Carlos

ayeying
Feb 27, 2011, 11:24 PM
I really really hope you guys have a back up copy of your original install.

This is literally a very early release of Lion, meaning many many bugs. I wouldn't install it over my original.

ikmisje
Feb 28, 2011, 04:08 AM
same problem here

macbook air 11

ovrlrd
Feb 28, 2011, 04:50 AM
Easy fix, just go into Audio MIDI Setup and change the output format to 2-ch 32-bit float and then it will stick and you won't have any issues from then on. I suspect that there is something wrong with the default (16-bit) mode that bugs out.

I always laugh when someone suggests reverting to a backup copy of your OS. I think almost everyone running a beta version of an OS for developers knows what they are getting into and will either live with the bugs or find workarounds. The whole point is to test software to make sure it works and fix the bugs that are broken in your software. If you aren't a developer or are not doing testing for a developer then you really have no reason to be running it (plus it's a really dumb way to spend your money).

ca7l0s9
Feb 28, 2011, 06:11 AM
Thanks ovrlrd! That fixed it for me.

MetRob24
Feb 28, 2011, 07:20 PM
ovrlrd,

Thanks for your help. Yes it fixed it for me to as well. I followed your instructions and now the sound is back to normal. I got worried for a minute.

Thanks again for your help.

Thanks,
Roberto

arm breaker
Mar 1, 2011, 08:13 AM
I had to register to say thanks.

Cruleworld
Mar 1, 2011, 09:35 AM
Thanks so much, this was the only thing driving me nuts

nick592prouty
Mar 2, 2011, 11:37 PM
How do you do that? "Easy fix, just go into Audio MIDI Setup and change the output format to 2-ch 32-bit float and then it will stick and you won't have any issues from then on. I suspect that there is something wrong with the default (16-bit) mode that bugs out.
"

marcopeters
Mar 3, 2011, 04:16 PM
Go to Applications -> Utilities -> Audio MIDI Setup (a Spotlight search for Audio MIDI Setup is ok too)

There change your output to 32 Bits and you're done!

jaswalker24
Mar 4, 2011, 05:48 AM
ovrlrd you are a genius!!!1

tizy
Mar 6, 2011, 02:18 PM
I confirm ... this worked for me as well.

tanhm
Jun 9, 2011, 09:19 AM
after upgrading to Lion beta, my headphone does not work , speaker is fine, I did what ovrlrd suggested, however , it still can not

any other suggestions

thank for your help


@work after restarting . Tks

josecuervo44
Jul 30, 2011, 03:30 PM
hi, i've a MB 2008 black, and don't have 32bit option. do you have the solution?

madaski
Aug 25, 2011, 04:33 PM
I have a MacBook Pro and the highest option is 24 which it is already on. No dice.

teobesta
Oct 2, 2011, 07:33 AM
my imac also doesn't have the 32-bit option. max is 24. this is frustrating.

[edit a few hours(!) later. ugh!]
this worked for me, got my "headphones" back & control over the computer's main volume control
without the greying (which picked my curiosity & got me in trouble to begin with)
http://forums.macrumors.com/showthread.php?p=13445650#post13445650