PDA

View Full Version : Can't connect to SMB shares




metec
Feb 28, 2011, 08:26 PM
Has anyone been able to access smb shares on Lion? I tried to access 3 windows (WHS, 7) computers and can't. The computers are detected in finder but the login is not accepted. The login prompt just wiggles and won't accept the correct login. I added the login info to the keychain and now it just says Connection failed. All computers connect fine in SL. I have Lion installed on an external hdd and so far liking it (except for this issue obviously but everything else seems to work).



mattiowa
Feb 28, 2011, 08:38 PM
I have installed Lion on a Mac Pro and am able to access SMB shares that I previously accessed using SL. In fact, things seem to be faster for SMB folders with a large number of files.

Jongewehr
Feb 28, 2011, 08:41 PM
iv had this also, i found that if i go to "connect to server" an enter the servers IP address, it will ask for a login, an connect

metec
Feb 28, 2011, 08:52 PM
iv had this also, i found that if i go to "connect to server" an enter the servers IP address, it will ask for a login, an connect

That's weird. I tried that too but same thing. It just seems like it won't accept the login. I even created a new account on WHS but it still won't connect.

shawn.concerto
Mar 10, 2011, 08:32 PM
I have the same issue but nobody knows how to fix it.
Anybody help?

calderone
Mar 10, 2011, 08:49 PM
Logs are your friend.

Console.app

katzha
Jul 20, 2011, 10:52 AM
I am having this problem today. Is there a solution?

STEPHAGNE
Jul 21, 2011, 08:50 AM
I have a similar problem. I get the following message in Console :
11-07-21 09:39:05,000 kernel: smb_ntstatus_error_to_errno: Couldn't map ntstatus (0xc0000225) to errno returning EIO

JRansomed
Jul 23, 2011, 10:21 PM
I just love posts like logs are your friend and a reference to the console.app That was a pretty worthless post. An offer to help analyze someones logs would have been better. The logs are definitely reporting errors, but there's not much to find regarding the errors.

I'm going to pretty much paste what I put in another post that was discussing this. I hope it helps some of people out. It's not pretty, but it has gotten me into all my servers and a number of SMB shares.

=========
Definitely issues with Apples new SMB implementation. I have managed to get SMB working and will try to explain what I think is happening.

As best as I can tell, when we try to map a SMB or CIFS share from the GUI, it appears to send the username and password of the logged in user. It appears to completely ignore any username you add to the url.

The ugly work around (Mount from the CLI)

Fortunately for us, there is the CLI method. You will need to open terminal for this.

First we need to make a place to mount the share to. When you first open terminal, it should place you in your home directory.

Lets make a folder called "data" by entering the following:

mkdir data

In my case, this will have created a folder in my home directory named "data". Now that we have a folder to mount the share to, lets get down to business. Below is the command used to mount a share. I'll explain it:

/sbin/mount_smbfs //myusername@myserver/share data

myusername is the username you need to connect with.
myserver is the server name or IP of the server you wish to connect to.
share is the share name you wish to connect to.
data is the folder you wish to mount this share to, in this case we created "data" as the mount point.

Give this a little time after hitting enter, it will prompt you in the terminal to enter your share's password. As you type, you will not see anything on the screen, but it is taking the password. Once you've completed entering your password it will mount to the folder you specified. You can access your files from in this folder, or if you have set Finder to show mounted shares on the desktop, you will see it on the desktop as well.

The only other odd thing here, is it does seem to have issues with then trying to mount another share from the same server with the same username. It has allowed me to mount other shares with another username on the same server. Really odd.
=========

Hopefully this will help until Apple starts releasing updates to Lion. (I'm hoping they won't leave this broken.)

Edit:
Just occured to me. If you are using Time Machine, you might want to exempt any mount points you create. I'm not sure if it won't try and back them up.

STEPHAGNE
Jul 25, 2011, 11:08 PM
Thank you so much!

nolar
Aug 9, 2011, 12:58 AM
When I use mount_smbfs (or smbutil), I get an error saying:

$ smbutil view //nolar@NOLAEEE
smbutil: server connection failed: Socket is not connected

What can it be? Firewalls are down on both machines. Windows machine can access Lion machine with ease. But not the other way.

mobtek
Aug 9, 2011, 01:07 AM
I had a weird one with smb shares, before using a shortname like smb://myserver worked under SL but now I have to use smb://myserver.company.com and no nothing has changed in our DNS :)

sdugoten
Aug 9, 2011, 11:17 AM
same problem, but the other direction.

I can't use Windows 7 to connect to Lion share (samba). I will have to disable and then enable the file sharing in system preferences every time after reboot.

DaMan05
Aug 28, 2011, 05:40 PM
Thank you so much JRansomed for your help.

I have 3 computers I want to access. 2x Windows XP and 1x Windows 7.

One Windows XP one shows up in Finder as type Sharepoint (??? Sharepoint is not installed on that PC) and I can browse its shares just fine.

The other Windows XP machine shows up in Finder, but says Connection Failed when I click on it. However, your terminal command works for me and I can mount it's shares (albeit one at a time). Thank you so much.

The last Windows 7 machine shows up in Finder but doesn't connect as above. And the terminal mount command doesn't work either. Same error as a poster above: "server connection failed: Socket is not connected"

I've posted my problem many places and even called AppleCare to no avail. After an hour of trying to figure it out, the Apple guy said the only thing left was to re-install the OS. No thanks. He didn't even mention the command line mount method that is posted here. Real Geniuses.

If someone could please help with the Windows 7 PC. I really don't understand why Apple broke this in Lion. Worked fine in SL.

muitst
Aug 5, 2012, 12:21 PM
I did a fresh install of Lion Server, bound it to active directory, created shares, and added AD users.

I can access the shares from Xp, but I can't access the shares from a 2008 server.

On the 2008 server, If i run the command: \\lion server, to access the shares,

I will get a message:The specified logon session does not exist. It may have already been terminated.

If I try to access the server by ip address: \\192.168.1.100, I can access the shares.

I am running DNS on the 2008 Server and it is configured correctly.

If I add another A record to DNS and assign another name for the server and enter the same ip address, I then can access the lion server by that second name.

Lion Server 192.168.1.100 Can not access by share name

Lion Server-1 192.168.1.100 Can access by its share name

I believe it is some type of Kerberos issue with the newer version of SMB Apple is using on the Lion Server.

Has anyone else experienced this issue?

qfactor
Mar 5, 2014, 02:18 PM
I had the same issue, but I found a very simple solution.

My (Windows) laptop's internal battery (the one that runs the clock) is now out of whack, so it always shows the wrong time. Once I reset my clock to the accurate time (by clicking on the clock in the taskbar and setting it via Internet Time) it readily accepted my password.

I hope this works for you lot tooŚ it was quite annoying an annoying issue that had a pretty simple workaround.

agenda
Mar 23, 2014, 10:21 AM
Thanks for your post qfactor! I too had the exact same issue with SMB shares and only realised what my problem was after reading your post. As you correctly indicated, after setting the correct time on the clock of my Windows PC, all worked beautifully well :) Thanks again!

qfactor
Mar 23, 2014, 12:14 PM
Thanks for your post qfactor! I too had the exact same issue with SMB shares and only realised what my problem was after reading your post. As you correctly indicated, after setting the correct time on the clock of my Windows PC, all worked beautifully well :) Thanks again!

I'm glad this worked for you too! And it's such an uncomplicated solution; hope this helps everyone else who's had this issue also.