PDA

View Full Version : Problems I've faced in Lion so far.




Nghia Nguyen
Mar 1, 2011, 02:54 AM
1. Dropbox. Even though I found a walk around to get it work, but I didn't bother. I'm using iDisk for the time being.

2. Screen saver. This is strange, because I notice nobody else but me faced this problem. What happened was I chose my screen saver as "iTunes artwork" (because in Lion, that screensaver also works as a mini iTunes player -- you can try it, pretty cool) and set it at 10 minutes to be active if I'm afk. But sometimes even while I'm typing essay or coding, the screen saver just got in the way. I tried to cope with it for a few days, but today I decided to turn it off by setting the time to "Never" (there's no option to deactivate screensaver, as far as I know). Does anybody else also get this problem but get a solution? Please let me know.

3. Audio jack making weird sound. I found a solution to this: simply go to Audi MIDI Setup, then change the format to "2-ch 32-bit".

4. Font! This is really really annoying. I notice that whenever I go to any website that has *code* or *link url*, all of the texts will rendered like this (http://cl.ly/4uPk). I need help with this asap because it's super annoying. Note: it only happens on Safari. Apparently, it works fine on Chrome.

5. 1Password extension and Click to Flash for Safari don't work.

6. iOS-like reverse scrolling is apparently unable to be turned off on a 2008 MacBook. I can turn it off on my MBP 15" 2010 though.

I'll update if I come across any other problems.



Steve Ballmer
Mar 1, 2011, 03:09 AM
Any MacBook with the multi-touch trackpad can use traditional scrolling. I have the original 2008 unibody model and I have the option.

AlexMagik
Mar 1, 2011, 03:14 AM
the most big one:
i can't drag and drop. this is killing me...
it's cross all applications, simply i can drag, but when i release the mouse nothing happen, the semitransparent icon still with the mouse, click doesn't help. when i press esc, then click, then the icon goes back to the original place.

minor one:
i've to use "fast performance" on my macbook pro (first 17" unibody), else safari render pages white, and finder "icon view" also is white.


anybody knows how to fix the first one?
create a new user also doesn't fix it...

87racer
Mar 1, 2011, 03:21 AM
No screensaver issue here.

For the font problem: Did you do a clean install of Lion to a new partition or over a SL install?

Never used 1Password but for ClickToFlash: use the extension at https://extensions.apple.com/

If you do not have an option at the very top of the trackpad preference pane you may want to look into BetterTouchTool. It offers the ability to have inverse scrolling which with inverse scrolling in both mac and BTT should put you back to normal scrolling. It has some issues but the dev is very active.

the most big one:
i can't drag and drop. this is killing me...
it's cross all applications, simply i can drag, but when i release the mouse nothing happen, the semitransparent icon still with the mouse, click doesn't help. when i press esc, then click, then the icon goes back to the original place.


I read somewhere(maybe the known bugs in the documentation? i think) that "sticky mouse" was one of the known issues. Don't recall seeing a fix for it though and I haven't experienced the issue.


-----------------------------------------
New MacBook Air 13.3"
Mac OS X Lion Adventures.
Issues, Solutions, and Workarounds
http://www.bs87.com
-----------------------------------------

Nghia Nguyen
Mar 1, 2011, 03:38 AM
For the font problem: Did you do a clean install of Lion to a new partition or over a SL install




I downloaded Lion from Mac App Store, so I assume it was installed over SL. Do you know how to fix that?

msjones
Mar 1, 2011, 03:47 AM
I have been running Lion for about 12 hours now, and I have not experienced any problems at all so far. I am running it on a MacBook 5,2 with 4GB ram.

The only thing I have noticed is some lag with the new transition effects. But I know there is along way to go before the final release. Hopefully there will be some new drivers for my nvidia 9400 chip.

87racer
Mar 1, 2011, 03:56 AM
I downloaded Lion from Mac App Store, so I assume it was installed over SL. Do you know how to fix that?

Most likely your font got corrupted when you installed Lion.

From a site I just found that uses a code box they use the font called Monaco. I attached my version of Monaco. You should try replacing your version in /System/Library/Fonts/ with that one. Quit Safari completely and reopen it and see if the problem is still there. If it is, can you give me a link to an example where you see the problem?

87racer
Mar 1, 2011, 03:58 AM
forgot to add the attachment. my bad here it is.

AlexMagik
Mar 1, 2011, 04:06 AM
I read somewhere(maybe the known bugs in the documentation? i think) that "sticky mouse" was one of the known issues. Don't recall seeing a fix for it though and I haven't experienced the issue.



interesting, seems only i have this problem :)
but i noticed that after the computer goes sleep, when wake up the mouse drag'n'drop actually works again. very weird...

87racer
Mar 1, 2011, 04:15 AM
interesting, seems only i have this problem :)
but i noticed that after the computer goes sleep, when wake up the mouse drag'n'drop actually works again. very weird...

yes very interesting. could you try it with another mouse? maybe it is hardware related?

AlexMagik
Mar 1, 2011, 04:25 AM
yes very interesting. could you try it with another mouse? maybe it is hardware related?

mouse is fine, i'm using magic mouse and works fine in SL.
trackpad has the same issue (and works in SL).

after sleep / wake up, both works.
looks like it's software related. i saw quite a few people had this issues until Leopard 10.5 randomly after updates. but nobody had a solution except just reinstall. i may just do that...

87racer
Mar 1, 2011, 04:29 AM
mouse is fine, i'm using magic mouse and works fine in SL.
trackpad has the same issue (and works in SL).

after sleep / wake up, both works.
looks like it's software related. i saw quite a few people had this issues until Leopard 10.5 randomly after updates. but nobody had a solution except just reinstall. i may just do that...

Yea that is likely your best bet. I would suggest though, that you install Lion on its own partition and install all your apps to that partition instead of installing over a SL install or running your programs from a SL partition. many people have been running into bugs by trying to do this.


-----------------------------------------
New MacBook Air 13.3"
Mac OS X Lion Adventures.
Issues, Solutions, and Workarounds
http://www.bs87.com
-----------------------------------------

msjones
Mar 1, 2011, 04:35 AM
I agree. A fresh install is definitely the way to go.

If this is your only Mac, install SL and use disk utility to partition the drive for your lion install. Then on boot when you hear the chime, hold in you ALT key and you can select which partition to boot into.

Nero Wolfe
Mar 1, 2011, 05:45 AM
I had the 'sticky mouse' problem in Snow Leopard a while ago. It turned out that the solution was to disable folder actions. Don't know if that helps in Lion, but I figured I'd put it out there.

arm breaker
Mar 1, 2011, 08:18 AM
PDF support in Safari has gone weird. I can't save PDFS without doing the Print>Save as PDF option. Not a big deal but aggravating with the extra steps.

tourada
Mar 1, 2011, 08:40 AM
The best thing for everyone here to do is file a bug report. Just talking about problems will not help apple fix them. Submit a bug report so that way the problem is fixed for the next version. Assuming that you also have a developer's account, those forums will help with technical problems (since developers have access to it)

87racer
Mar 1, 2011, 12:29 PM
The best thing for everyone here to do is file a bug report. Just talking about problems will not help apple fix them. Submit a bug report so that way the problem is fixed for the next version. Assuming that you also have a developer's account, those forums will help with technical problems (since developers have access to it)

Crash reports are automatically sent to Apple so we do not need to submit them. Also, a good developer will keep an eye on many forums for issues with his/her app. Yes, the developer forums would be the most desirable but many people may not have developer's accounts.

kthnxshwn
Mar 1, 2011, 12:49 PM
A big problem I'm facing is scrolling in apps that have visible scrollbars when launched. Like iTunes, Coda, etc etc.

Nghia Nguyen
Mar 1, 2011, 03:44 PM
forgot to add the attachment. my bad here it is.

I tried but still got the same issue.

It happens when I use tumblr and try to change some CSS code: example (http://cl.ly/4wFT)

Tonewheel
Mar 1, 2011, 04:21 PM
Thinking this could be my graphics card? NVIDIA GeForce 8800 GT.

While scrolling through Safari web pages with my Magic Mouse, the page is "cut" vertically into thirds, with the center third scrolling faster than the right and left thirds. Irritating, but useable, and presumable will be fixed in the final release.

87racer
Mar 1, 2011, 04:33 PM
I tried but still got the same issue.

It happens when I use tumblr and try to change some CSS code: example (http://cl.ly/4wFT)

Ok that uses courier not monaco so try this one.

Also make sure your Appearance settings look like my attached picture.

87racer
Mar 1, 2011, 07:02 PM
Thinking this could be my graphics card? NVIDIA GeForce 8800 GT.

While scrolling through Safari web pages with my Magic Mouse, the page is "cut" vertically into thirds, with the center third scrolling faster than the right and left thirds. Irritating, but useable, and presumable will be fixed in the final release.

yea sounds like your graphics card can't keep up for some reason. other people have noted some issues with glitchy dragging of windows so this could very well be the case.

mrgstiffler
Mar 2, 2011, 07:21 PM
mouse is fine, i'm using magic mouse and works fine in SL.
trackpad has the same issue (and works in SL).

after sleep / wake up, both works.
looks like it's software related. i saw quite a few people had this issues until Leopard 10.5 randomly after updates. but nobody had a solution except just reinstall. i may just do that...

I have the same problem on my MBP. Sleep/Wake fixes it too.

HEB
Mar 2, 2011, 07:46 PM
For me, Lion has been excellent. I've experienced no bugs whatsoever, and am loving it. But definitely, definitely, definitely, I am staying with SL for the time being. I really don't want to run all of my apps on a wimpy beta platform.

ErikGrim
Mar 2, 2011, 09:04 PM
A big problem I'm facing is scrolling in apps that have visible scrollbars when launched. Like iTunes, Coda, etc etc.

It seems every app with a custom scroll is broken in slightly different ways in Lion (Twitter has no inertia anymore, Reeder has spastic scroll). Lesson: Never implement your own custom UI.

kashkha
Jul 21, 2011, 02:20 PM
Out of curiosity, have those of you with the drag & drop issue installed AirDisplay, DisplayPad, or a similar iOS screen-casting server app? There seem to be some suggestions going around that these apps might be causing it, including a tweet from the developer of one of the apps. I've emailed them and will see what they say.

87racer
Jul 21, 2011, 03:00 PM
Out of curiosity, have those of you with the drag & drop issue installed AirDisplay, DisplayPad, or a similar iOS screen-casting server app? There seem to be some suggestions going around that these apps might be causing it, including a tweet from the developer of one of the apps. I've emailed them and will see what they say.

Been using the developer preview since it was released and in dp3 i installed air display and every once in a while i would see the drag and drop issue. usually pressing escape and then clicking a couple times released it but when you tried to drag and drop again immediately after it would happen again. Was just testing out air display so i haven't reinstalled now that i have the 11A511 build and I have not had the issue.

wts
Jul 25, 2011, 01:07 PM
When i select screensaver ( by moving my mouse to a preselected hot corner ) to play a apple screensaver it will start and quit and start and quit and not stay on.


Any suggested solutions please .

atari1356
Jul 27, 2011, 10:03 PM
4. Font! This is really really annoying. I notice that whenever I go to any website that has *code* or *link url*, all of the texts will rendered like this (http://cl.ly/4uPk). I need help with this asap because it's super annoying. Note: it only happens on Safari. Apparently, it works fine on Chrome.

I'm having this same problem in Safari... noticed it while viewing code listings on http://stackoverflow.com

EDIT: like on this page (http://stackoverflow.com/questions/6009174/how-to-route-rest-request-from-a-local-service-to-a-remote-one-using-camel), for example

The site works fine in Chrome and Firefox though. I'm trying to muddle through their CSS to see if it's a specific font with the issue, but haven't been able to figure it out yet.

Taz Mangus
Jul 28, 2011, 02:46 AM
I'm having this same problem in Safari... noticed it while viewing code listings on http://stackoverflow.com

EDIT: like on this page (http://stackoverflow.com/questions/6009174/how-to-route-rest-request-from-a-local-service-to-a-remote-one-using-camel), for example

The site works fine in Chrome and Firefox though. I'm trying to muddle through their CSS to see if it's a specific font with the issue, but haven't been able to figure it out yet.

I just went to both the websites and both render fine for me without an issue.