PDA

View Full Version : I know it's a beta but this is really strange....




linkandzelda
Mar 1, 2011, 04:28 PM
Just installed 10.7 on my 2010 MBA.
The installation was slightly buggy but not bad none the less. First thing i noticed, it didn't like my wireless access point upon the initial setup. Once i got into the system i could add it without a problem, until i added my Magic Mouse...

This is absolutely unimagined and i have no idea how this works but, i can't use my Magic Mouse on the place on my desk i've been using it forever while I had Snow Leopard. Now that i have lion it jitters and stutters and becomes totally unresponsive. I have to move it to the Air about a foot away so that ti works. If i turn off wifi then the issue doesn't happen its only when both are on and in use.

surely that can't be a Lion bug? I mean.. The two can't even be affected by each other, or can they? I'm totally over the moon with this so had to post a thread to see what everyone else thought about it.

All i could think was that Bluetooth and Wifi use the same frequency and perhaps my router is randomly using a channel which is interfering with it, but why now???

I would appreciate any answers, fixes, responses or recommendations people have. And just for the information, Magic Mouse has 100% battery, and if i put my keyboard or Magic Trackpad in the same position then they are fine, no problem at all! I'm totally stumped and tempted to reinstall SL right now to test this further.

Thanks in advance,
Kris



Cougarcat
Mar 1, 2011, 04:40 PM
I'm sure it's a Lion bug. Networking in general is pretty wonky at the moment.

Steve Ballmer
Mar 1, 2011, 04:47 PM
Yeah, networking is very buggy in this build. I can't get 802.1x working at all, Wi-Fi dies every time I put my MacBook to sleep, sometimes it won't see any networks, etc.

But lots of networking things are "Known Issues" in the seed notes, so the next build will probably fix them.

linkandzelda
Mar 1, 2011, 04:51 PM
Ah I see... But bluetooth isn't networking :(

Apart from this i'm enjoying Lion so far. I might use it as my main system for a bit xD

celticpride678
Mar 1, 2011, 05:24 PM
Ah I see... But bluetooth isn't networking :(

Apart from this i'm enjoying Lion so far. I might use it as my main system for a bit xD

It's a developer preview...if you expect it to be perfect, you shouldn't have installed it.

linkandzelda
Mar 1, 2011, 05:32 PM
It's a developer preview...if you expect it to be perfect, you shouldn't have installed it.

I'm not expecting it to be perfect at all. I knew what i was in for but didn't expect this. I'm gonna attempt to fix it, but if not then i'll move on.

Cougarcat
Mar 1, 2011, 05:33 PM
Ah I see... But bluetooth isn't networking :(



Yes, it is. It's short-range wireless.

linkandzelda
Mar 1, 2011, 07:40 PM
Ah of course. PAN or something. And the fact they use the same frequency i guess makes them both "Wi-Fi".

87racer
Mar 1, 2011, 08:18 PM
not to point out the obvious but my magic mouse does that when the batteries get low, try a new set. it is highly unlikely that it has to do with wifi interfering. you could also make sure your computer isn't actively connected to another bluetooth device.

linkandzelda
Mar 1, 2011, 08:21 PM
not to point out the obvious but my magic mouse does that when the batteries get low, try a new set. it is highly unlikely that it has to do with wifi interfering. you could also make sure your computer isn't actively connected to another bluetooth device.

Battery is at 100% charged, tried new ones anyway and no effect. I even went back to 10.6 briefly to check it and it did work perfectly, went back to 10.7 and the same problem. I already have a bluetooth keyboard and trackpad connected as I use my Air always in clamshell mode, unless i'm out in which case the MM works fine. I can live with this as i've already decided to use 10.7 as my main system.

aristobrat
Mar 1, 2011, 08:24 PM
I'm having odd issues with my new 13" Air + Magic Mouse + 10.7.

During the setup (after the Welcome video), it'd totally drop the connection to the mouse, which was like 2ft from the Air. Once setup it's often jittery. Battery is 85% so that's not it.

I'm curious to see how it acts on future builds. :)