PDA

View Full Version : Lion Won't sleep




mackcat
Mar 3, 2011, 11:48 PM
Mac os 10.7 won't sleep on a 4gb 2.2GHz white macbook?


Thanks



Mac-Michael
Mar 3, 2011, 11:55 PM
Mac os 10.7 won't sleep on a 4gb 2.2GHz white macbook?


Thanks

More info?

Did you chose Full Disk Encryption? It won't sleep until it's done encrypting the whole drive. How long have you had it installed and running?

Ringo-Chan
Mar 3, 2011, 11:58 PM
Try the system preferences and see if you turned it off

mackcat
Mar 4, 2011, 07:29 AM
Full disk encryption i turned off, and I've waited an hour:apple:

baryon
Mar 4, 2011, 08:13 AM
In the jungle the quiet jungle the Lion sleeps tonight...
Sorry I just had to!

Now seriously:
Does it not sleep when you close the lid, or does it just not sleep automatically? If it's the last one, then it could be an application preventing sleep. Quit everything and see if it still does it.

mackcat
Mar 4, 2011, 08:44 AM
it does the same. both ways apple>sleep and lid shut! When I had it on a different partition it worked?:apple:

AWalkerStudios
Mar 4, 2011, 09:54 AM
You're not crazy, I've been having the same problem

v66jack
Mar 4, 2011, 09:56 AM
Lion won't sleep - have you tried a trancquiliser?

Sorry couldn't resist, I used to work for a zoo

mackcat
Mar 4, 2011, 05:21 PM
Switching off Internet sharing fixed it. It never affected it in snow leopard?:confused:

celticpride678
Mar 4, 2011, 05:27 PM
Switching off Internet sharing fixed it. It never affected it in snow leopard?:confused:

You have to keep in mind that Lion is in developer preview stage. There are still bugs and they will likely be fixed before final release.

DirtySocks85
Mar 4, 2011, 10:21 PM
I know that this doesn't really contribute, but these two things immediately came to mind.

http://www.youtube.com/watch?v=oUMwu_gXK7Q

and

http://www.youtube.com/watch?v=OlBXE5avstw

truediarist
Apr 4, 2011, 08:01 PM
I had the same issue, fixed by turning off Internet Sharing. Who knew?

Let's Sekuhara!
Apr 5, 2011, 02:01 AM
The Lion never sleeps... 'tis always on the prowl.

joblolabinette
Jul 18, 2011, 06:45 AM
Same for me, turning off internet sharing fixed the problem :D

ZachNyhus
Jul 22, 2011, 12:15 AM
But what if I don't want to turn off Internet Sharing??? I NEED my internet sharing, and I also need to put my Mac Mini to sleep once in a while. Do I really need to go to the trouble of turning the Sharing on and off manually every single time I want to sleep or wake??? That's seems like such BS... :confused::confused::confused:

schalliol
Jul 22, 2011, 06:53 PM
This post helped me out. I didn't realize that Internet Sharing would do this, and it does make sense to me why it can't sleep if it's acting as the router.

basher
Jul 22, 2011, 08:14 PM
I still have issues getting my 2011 iMac to sleep. Yesterday it slept once via a 15 minute timeout. I think in the 5 weeks I've owned it it's only slept on it's own twice.

Oh well.

porkchopboy
Jul 25, 2011, 07:15 AM
Switching off Internet sharing fixed it. It never affected it in snow leopard?:confused:

Switching off internet sharing doesn't make any difference for me. it wont sleep on battery, or power when i close lid, also when i lift lid i have to remove power cable every time now before the screen will light up, the CPU doesn't stop when i close lid. and if i choose SLEEP from the apple logo the it looks like its gone to sleep (the sleep light dims but stays on) but if i then try to close the lid the sleep light goes bright again and stays like that.

I was expecting apple to make sure Lion was spot on before release to avoid looking stupid again like with all the embarrassing initial iphone4 snags thye had.
Now im stuck with a macbook that cant sleep? Maybe I should have listened to my pal he told me to wait 3 months before upgrading to Lion :)

I also had nasty graphics glitches on desk top screen since installed Lion, but i fixed it by changing screen saver to SOLID COLOUR.

Jiloo
Jul 27, 2011, 03:52 AM
have the same issue.

i have no internet sharing.

but i had external tv connected. even if it was turned off mbp won't sleep.
plug the cable out and it sleeps again like a baby.

regards

Denisoftus
Jul 27, 2011, 04:30 AM
I noticed it does not sleep under standard user, with admin user it goes sleeping alright.

pwatson80
Jul 27, 2011, 04:47 AM
Done a little tinkering with the settings for ICS etc. No success.

What I have found is that if I use the :apple: menu sleep option rather than closing the lid, it works. Once I've woken the MacBook back up I can then close the lid and it goes to sleep after that, just like it should.

Looks like the :apple: menu option kicks it into touch.

Might work for others... Good luck, hopefully this is addressed in the future update.

Also be aware that when you do close the lid to enter sleep it seems to take longer than on Snow Leopard. I'm generally waiting around 20-30 seconds before it's snoozing.

PatrickCocoa
Jul 29, 2011, 03:42 PM
Turning off Internet Sharing worked for me.

Background: I upgraded to Lion when it came out. I usually sleep my iMac each night, which worked just fine for several years with Snow Leopard. After the upgrade to Lion, I noticed that the iMac woke up very quickly in the morning - a quick check revealed that it was never going to sleep.

I had internet sharing (system preferences, sharing) turned on as several years ago I did not have an external wi-fi - I ran the internet cable into my iMac, then broadcast via the iMac's wi-fi. A few years ago we switched routers and the new one had a built in wi-fi. I had left the iMac wi-fi broadcast on apparently.

I turned internet sharing off, selected Sleep, then my iMac went to sleep for the first time in a week.

metis
Jul 31, 2011, 02:34 PM
i've deactivated internet sharing and puff... SLEEP works again under lion :o

basher
Jul 31, 2011, 03:12 PM
I have nothing shared and my iMac still won't sleep on its' own. I have to use option+command+eject or the Apple menu sleep to sleep my system.

Oh well.

dmelgar
Jul 31, 2011, 05:18 PM
Same thing has happened to me on both a 2011 Mac Mini and 2010 Macbook Air. In both cases a reboot fixed it. Overall not a very stable operating system. Need to reboot every day or two anyway.

tobyadams87
Aug 2, 2011, 10:37 AM
Same issue here with the internet sharing - very strange.

I wonder if this is by design or whether this will be fixed in 10.7.1?

Thanks again!

QuarterSwede
Aug 3, 2011, 03:23 PM
This was driving me mad! Thanks all for the quick fix.

I also wonder if Apple is keeping Lion on while Internet Sharing is enabled (not sure why it was for me) and that it's not a bug. Got me.

mrtravel123
Aug 4, 2011, 11:20 AM
Mine slept fine when I did a SL to Lion upgrade. But, upon having my logic board replaced (after upgrading to Lion), I now have these sleep problems. When I close the lid, it doesn't sleep. When I tell it to sleep via the apple, it does sleep.

I was thinking that it could be my new logic board. But, maybe it's a Lion thing. Strange how it is acting differently with different people. Sounds like other Lion problems.

There are times I can't access my Dock either. I can always access it from my desktop. But, if I'm in full-screen mode (such as in Safari), it is random re: being able to get my Doc to appear. Argh.

lemonhk
Aug 5, 2011, 05:59 AM
didn't sharing the internet
but i plugged a ext. mon......
how can i fix this problem

ZachNyhus
Aug 6, 2011, 08:14 PM
So.... Has no one figured out a solution for the Sleep issue??? Simply "turning off Internet Sharing" isn't a solution; many of us need to keep Internet Sharing on, AND need to be able to put our computers to Sleep. Has nobody figured out how to do this???

mrtravel123
Aug 8, 2011, 11:25 AM
Ok, I just realized that mine was a different issue - likely unrelated to Lion. I had just had my logo board replaced but he Genius Bar and there was a wire inside that they didn't connect. Something to do with magnets and the lid knowing when it is closed. When they connected the wires upon my return, it now sleeps when I close the lid.

If you've had similar work done, or maybe replaced memory and bumped some wires (which I'm not sure how easy it'd be to do that), then maybe that's what is happening. For me, it was the Genius Bar that caused the issue. This probably explains why I was able to manually get it to sleep (via the Apple logo) and not via closing the lid.

basher
Aug 8, 2011, 11:29 AM
Awesome find. If I ever take my MBP in for service I'll know to test for sleep by closing the lid.

Awesome!

YMark
Aug 15, 2011, 10:32 AM
I have nothing shared and my iMac still won't sleep on its' own. I have to use option+command+eject or the Apple menu sleep to sleep my system.

Oh well.

I'm another one with this problem. I don't have internet sharing and my iMac doesn't sleep. In fact, the display doesn't go out either, unless I hot corner it (do it manually).

I'm not impressed with Lion. I have it on my iMac, my Air, and my wife's Macbook Pro. It runs well on the laptops, but I'm rebooting my iMac 2 or 3 times a week due to freezes. Not sure what the issue is, but I'm ready to go back to SL. Lion was released a bit early IMO.

I also had to switch to Chrome due to Firefox crashing all the time. But I don't blame Lion for this.

arteggio
Aug 15, 2011, 01:13 PM
Has anyone tried resetting the SMC (http://support.apple.com/kb/ht3964) and NVRAM (http://support.apple.com/kb/ht1379)?

I've always had sleep problems, even under Snow Leopard. Sometimes it was a stubborn app, other times I couldn't figure it out. I've never tried turning internet sharing, but I believe doing one of the above has helped before.

Taz Mangus
Aug 15, 2011, 03:55 PM
Try booting into safe mode (hold down spacebar while rebooting) and see if the machine goes to sleep.

apfhex
Aug 16, 2011, 11:57 AM
My Mac Pro with Lion won't sleep either, but only sometimes. I can't figure out what's causing it. I'm always using the same programs. All forms of Sharing are turned off. Wake for Ethernet access is off and allow Bluetooth devices to wake is off too. It's a clean install that I did from Lion's recovery partition.

Restarting fixes it but it starts happening again a few days later (I rarely turn it off, always sleep). Haven't tried resetting the SMC/PRAM though, that's a good tip.

exoriare
Aug 24, 2011, 06:56 AM
I thought I had this problem too, but now I realise I have a new Lion feature. Closing the lid of my MBP now does not send to sleep like it used to but into clamshell mode. So if I either disconnect the ACD or the external power supply then clamshell mode can't work and is replaced by sleep when I close the lid.

Obviously this is only true for those with portables with lids to close.;)

I'm not so happy with this new default as I never much use clamshell mode and would like to know if there is a way to reset the default to sleep. But I guess there probably isn't.

talmy
Aug 24, 2011, 09:26 AM
Two of the four systems I've upgraded to Lion won't sleep anymore (an iMac and a Macbook), one sleeps (an older iMac), and the fourth I can't tell (Macbook Air).

I've "fixed" the problem until Apple does it with a patch (it does seem to be a widespread issue) by installing PleaseSleep. Works great!

On the iMac I did a Lion reinstall, reset SMC and NVRAM, turned off all sharing and "wake on" options, turned off Bluetooth (Wifi already off), and disconnected all wired connections but a wired keyboard and mouse, shut down all apps I could including hidden ones like BetterTouchTool and Dashboard widgets and it still wouldn't sleep.

The reinstall wasn't a clean one. I wonder if people that wipe their drive and do a clean Lion install have this problem.

leftspin
Sep 25, 2011, 12:08 PM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.

talmy
Sep 25, 2011, 12:53 PM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.

Didn't help. I've got no PreventSystemSleep assertions.

shiretu
Sep 29, 2011, 05:00 PM
Didn't help. I've got no PreventSystemSleep assertions.

I had the same problem. I also had to stop blue tooth sharing :D

talmy
Sep 30, 2011, 10:05 AM
I had the same problem. I also had to stop blue tooth sharing :D

Doesn't help me. As I stated, I turned off all wireless, all sharing, all applications, and only had a wired keyboard and mouse connected and it still wouldn't sleep.

I had stated that one of the four Lion systems I have I couldn't tell if it slept or not. That was a Macbook Air. I've since determined that it also does not sleep.

I have been able to determine that Dropbox and BetterTouchTool/BetterSnapTool will in some of these systems prevent sleep, but removing them still won't allow sleep. Hopefully a solution better than PleaseSleep will present itself!

justflie
Oct 15, 2011, 01:23 PM
Same problem here. I have a Mac Pro that doesn't like sleeping automatically. No prevent sleep assertions either... Annoying and weird.

talmy
Oct 15, 2011, 05:52 PM
Now that 10.7.2 is release I can state that it solves my sleep problems. I no longer need to run PleaseSleep and all three of my non-sleeping Macs now sleep just fine.

ijha
Oct 15, 2011, 06:01 PM
Now that 10.7.2 is release I can state that it solves my sleep problems. I no longer need to run PleaseSleep and all three of my non-sleeping Macs now sleep just fine.

with internet sharing on?

Thanks,

pooryou
Oct 15, 2011, 06:09 PM
My 2009 Mac Pro never sleeps unless I manually force it to. Never been able to figure out why. I have no idea how to interpret the results of 'pmset -g assertions' but it seems promising.

I don't use internet sharing. Oh and I am on Snow Leopard.

justflie
Oct 15, 2011, 07:57 PM
Booted into single user mode and it went to sleep properly. Boy, it going to be tons of fun going process by process to find what's messing it up. :(

bully worm
Oct 15, 2011, 08:18 PM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.


Can you interpret this:


http://i.imgur.com/fvvae.png

talmy
Oct 15, 2011, 10:14 PM
Now that 10.7.2 is release I can state that it solves my sleep problems. I no longer need to run PleaseSleep and all three of my non-sleeping Macs now sleep just fine.

with internet sharing on?

Thanks,

I don't use Internet Sharing. I would expect that would keep it awake -- after all it can't share the Internet if it is sleeping.


In any case I understand Internet Sharing is a big security hole and should be left off except for when you are actually using it.

nicofly
Oct 17, 2011, 09:15 AM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.

Yes! Problem solved!!! :D TNX Leftspin :):):)

Farofa
Oct 26, 2011, 10:28 AM
My Macbook Pro 15' sleeps well with Lion, I just had to unplug the power source.

justflie
Oct 26, 2011, 12:07 PM
The problem was Drive Genius DrivePulse. DrivePulse keeps track of and looks for defrag issues, volume consistency issues, etc. For some reason, the computer wasn't happy about that and refused to sleep according to energy saver settings. I removed drivepulse and that fixed the problem! yay.

pazz
Oct 29, 2011, 07:09 PM
In windows there is a tool you can use to find out what is preventing sleep.

How can you do a similar task on mac os lion?

talmy
Oct 30, 2011, 12:37 PM
In windows there is a tool you can use to find out what is preventing sleep.

How can you do a similar task on mac os lion?

Look 3 messages above your post.

pazz
Oct 30, 2011, 01:23 PM
I have tried this, nothing is listed as preventing sleep.

talmy
Oct 30, 2011, 03:17 PM
That program only lists apps that are explicitly preventing sleep. Any app can prevent sleep by remaining active. Best approach is to set the system to sleep after a minute. Exit all apps and remove all external devices (USB devices can prevent sleep), then start/add them back in one at a time until the system refuses to sleep. In my case, the most recent problem was DropBox with "LAN sync" enabled.

pazz
Oct 30, 2011, 03:25 PM
Thanks for your help Talmy.

But I've even tried closing all apps and it still seems to be sporadic. Sometimes it'll sleep, others not. And afaik I'm not doing or running anything different.

digitalhen
Oct 30, 2011, 11:16 PM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.

Great tip.

I found my audio in permanent use:-

pid 117: [0x0000012c00000075] PreventUserIdleSystemSleep named: "com.apple.audio.'AppleHDAEngineOutput:8,0,1,1:0'.noidlesleep"

Turns out it's Spotify, whether it's playing music or not.

http://getsatisfaction.com/spotify/topics/spotify_prevents_my_mac_from_sleeping

talmy
Oct 31, 2011, 09:24 AM
Thanks for your help Talmy.

But I've even tried closing all apps and it still seems to be sporadic. Sometimes it'll sleep, others not. And afaik I'm not doing or running anything different.

Some apps have background processes you don't see in the Dock. You may need to use Activity Monitor and look for those apps and kill the processes.

pazz
Nov 2, 2011, 06:36 PM
Some apps have background processes you don't see in the Dock. You may need to use Activity Monitor and look for those apps and kill the processes.

Talmy, I've discovered its something to do with Microsoft Outlook 2011! If I remove this from startup items and shutdown and restart the machine will sleep.

Outlook has an exchange account on it so could it be that?

talmy
Nov 2, 2011, 07:33 PM
Could be syncing with the Exchange account too often for the system to get a chance to sleep.

pazz
Nov 7, 2011, 04:58 PM
How can I set Outlook to only sync every 30 mins or something?

AdeFowler
Nov 15, 2011, 05:56 AM
I've been struggling with this on my Mac Pro for the past three days. Today I unplugged my Firewire iSight camera and now she sleeps. I wish Apple would release a new 30" Cinema Display.

Slower Pace
Nov 15, 2011, 07:49 PM
Like several others, I couldn't get my Macbook to sleep with Lion. I read where turning off Internet sharing helped. I did that and Yes! Now when I close the lid it goes to sleep like it used to. A work-around I had was to unplug the charging adapter before I closed the lid. It went to sleep, then I could plug it back in and all was well till I opened it up again. This site is great for all the help we get by listening to one another. :o

danielsweden
Apr 8, 2012, 10:47 AM
To find out why your system won't sleep, type:

pmset -g assertions

In my case, I saw:

Listed by owning process:
pid 63: [0x0000012c0000003f] PreventSystemSleep named: "org.cups.cupsd"

cups is the printing system, so I went into the system prefs and deleted my printer drivers. The system then slept.

Thanks! This worked for me! But I did not have to delete ALL of my printer drivers.

The command pmset -g assertions gave the same result here. I then realized the problem started about two weeks ago, after I temporarily had my mbp connected to two different printers at another location.

Deleting the drivers for these two now unnecessary printers (one HP and one Brother) solved the problem, the command pmset -g assertions does now not show anything preventing sleep, and the computer sleeps as expected.

I still have my Canon, Adobe PDF and Prolific PS printer drivers installed. Unfortunately I did not delete the HP and Brother drivers one by one so I do not know which one of them it was that were causing the problem.

And by the way, as Spotify is mentioned above, I have Spotify also, and it is not causing any sleep problems here. Unless I play it really loud of course... :)