PDA

View Full Version : Sleep mode with external Monitor on Macbook Pro and Lion




qstyler
Mar 25, 2011, 07:26 AM
Hi!
I'm using my Macbook Pro with external monitor as extension of my desktop.
On SL system was going to a sleep mode when I closed macbook pro, but on Lion it would just put everything to external display. So I have to press power button and then “sleep mode”. Like in 90ies.
How can I make it go to sleep mode when I close my book?

Thank you!



simsaladimbamba
Mar 25, 2011, 07:32 AM
Option+Command+Eject

qstyler
Mar 25, 2011, 07:39 AM
Option+Command+Eject

I believe it won't close my macbook :)

simsaladimbamba
Mar 25, 2011, 09:45 AM
I believe it won't close my macbook :)

You could press that key combo and then close the MacBook.
Have you already contacted Apple about this?

qstyler
Mar 25, 2011, 09:52 AM
You could press that key combo and then close the MacBook.
Have you already contacted Apple about this?

Yes I can. But as a programmer I always optimize my time:
I press “Sleep mode” then wait for mac to actually fall asleep then close it.
Waiting takes time. If i'm too fast in closing it'll just do what it does.
So I'm losing like 20 seconds which is really annoying.

Lion's in developer preview. I don't think they collect bugreports from non-registered developers.

So I thought that someone knew any sort of “default write” to just change one setting for it.

simsaladimbamba
Mar 25, 2011, 09:57 AM
You could disable the smart sleep feature (where the RAM gets written to the HDD) via Terminal and save 18 seconds.

shaynes
Mar 25, 2011, 10:37 AM
Actually, this sounds more useful than SL for my use case, since I like having the lid closed when I use my external monitor.

I often am using my macbook, decide to plug it into external and then close the lid. Currently it will sleep and I have to wake it up again in order to use with the external. But with this new behavior it sounds like I save a step!

So maybe this isn't a bug, but intentional in order to please people like me?

Dr McKay
Mar 25, 2011, 10:40 AM
Actually, this sounds more useful than SL for my use case, since I like having the lid closed when I use my external monitor.

I often am using my macbook, decide to plug it into external and then close the lid. Currently it will sleep and I have to wake it up again in order to use with the external. But with this new behavior it sounds like I save a step!

So maybe this isn't a bug, but intentional in order to please people like me?

This is how Windows 7 behaves if you've set it to "Do Nothing" when you close the lid.

Sounds like a feature change to me, not a bug.

As for getting it to sleep, why not put it to sleep from the menu, only an extra 2-3 seconds.

Jiloo
Jul 27, 2011, 03:57 AM
This is how Windows 7 behaves if you've set it to "Do Nothing" when you close the lid.

Sounds like a feature change to me, not a bug.

if it's a feature, why not give us chance to change it ;)

Icy1007
Jul 27, 2011, 04:00 AM
if it's a feature, why not give us chance to change it ;)

Because Apple knows best.

0dev
Jan 15, 2013, 08:48 PM
Sorry to bump an old thread but is there a fix for this yet?

I'm getting the same issue. 2012 MBP on Lion. It used to be fine, I could just close the laptop with the external monitor connected and it'd sleep as normal, just now it's decided that when I close the laptop it wants to mirror the display to the external monitor and just sit there.

I did some searching and apparently others have fixed the issue by turning off sharing options but I don't have any on in the first place.

Is there any fix? This is a very irritating and sudden bug.

0dev
Jan 16, 2013, 07:55 PM
Never mind, problem fixed itself after a reboot.