PDA

View Full Version : Xcode 4.0 crashes when I try to "Validate" or "Submit" via Organizer




elpaproduction
Apr 5, 2011, 06:46 PM
Have you ever seen this problem?

When I click on "Validate" in Organizer, I get the following error: "Xcode encountered an internal logic error. Choose "Continue" to continue running Xcode in an inconsistent state. Choose "Crash" to halt Xcode and file a bug with Crash Reporter. Choosing "Crash" will result in the loss of all unsaved data." and Xcode crashes.

Under details it says:
"UNCAUGHT EXCEPTION (NSInvalidArgumentException): -[ITunesSoftwareApplicationDescription applicationType]: unrecognized selector sent to instance 0x20162b520
UserInfo: (null)
Hints: None
Backtrace:
0 0x00007fff81e13796 __exceptionPreprocess (in CoreFoundation)
1 0x00007fff873710f3 objc_exception_throw (in libobjc.A.dylib)
2 0x00007fff81e6d110 +[NSObject(NSObject) doesNotRecognizeSelector:] (in CoreFoundation)
3 0x00007fff81de591f ___forwarding___ (in CoreFoundation)
4 0x00007fff81de1a68 _CF_forwarding_prep_0 (in CoreFoundation)
5 0x0000000102f9f0ac __50-[AAVFetchApplicationListAssistant viewDidInstall]_block_invoke_0427 (in IDEArchivedApplicationsViewer)
6 0x00007fff81e1facc __NSArrayChunkIterate (in CoreFoundation)
7 0x00007fff81e2e7fd ____NSArrayGetIndexesPassingTest_block_invoke_1 (in CoreFoundation)
8 0x00007fff835dd283 _dispatch_apply_serial (in libSystem.B.dylib)
9 0x00007fff83594434 dispatch_sync_f (in libSystem.B.dylib)
10 0x00007fff835dd22b dispatch_apply_f (in libSystem.B.dylib)
11 0x00007fff8369358d _dispatch_apply_slow (in libSystem.B.dylib)
12 0x00007fff81df63ab __NSArrayGetIndexesPassingTest (in CoreFoundation)
13 0x0000000102f9ef27 __50-[AAVFetchApplicationListAssistant viewDidInstall]_block_invoke_0 (in IDEArchivedApplicationsViewer)
14 0x00007fff8359b2c4 _dispatch_call_block_and_release (in libSystem.B.dylib)
15 0x00007fff83579831 _dispatch_worker_thread2 (in libSystem.B.dylib)
16 0x00007fff83579168 _pthread_wqthread (in libSystem.B.dylib)
17 0x00007fff83579005 start_wqthread (in libSystem.B.dylib)
"


Am I doing something wrong?
I cleared the Cashe, restarted my Mac, and still getting the same error.
What should I do?
Thanks,



PhoneyDeveloper
Apr 5, 2011, 07:19 PM
Is there anything else in console.app that might indicate what's going wrong?

I would start by uninstalling and then re-installing Xcode.

elpaproduction
Apr 5, 2011, 07:22 PM
Is there anything else in console.app that might indicate what's going wrong?

I would start by uninstalling and then re-installing Xcode.

Thanks for your reply,

Nothing else indicates any problems, build goes well, no errors, no messages, works on simulator.

The problem only occurs when I try to "Validate" or "submit".

I'm downloading 4.0.1 now (have 4.0 now), hoping that will fix the problem.

Sykte
Apr 6, 2011, 09:30 PM
Thanks for your reply,

Nothing else indicates any problems, build goes well, no errors, no messages, works on simulator.

The problem only occurs when I try to "Validate" or "submit".

I'm downloading 4.0.1 now (have 4.0 now), hoping that will fix the problem.


Did you check your certs? It's a long shot but what version of Itunes are you running, may want to try and update that?

Compile 'em all
Jun 29, 2011, 05:06 PM
Thanks for your reply,

Nothing else indicates any problems, build goes well, no errors, no messages, works on simulator.

The problem only occurs when I try to "Validate" or "submit".

I'm downloading 4.0.1 now (have 4.0 now), hoping that will fix the problem.

Sorry to bump a rather ancient thread but did you get to resolve this problem? I am experiencing the exact same issue with XCode 4.0.2.