PDA

View Full Version : G4 MDD unable to use 2nd hard drive


Mechcozmo
Mar 1, 2005, 10:40 PM
My friend recently got a hand me down Mac. It turned out to be a dual 1.42 G4.
Yes, he is a lucky bastard.
Anyway.

The original 120GB hard drive is fine, but he wants to install a 2nd hard drive. It is a 40 GB Quantum Fireball, 5200 rpm.

It DOES show up in System Profiler.
It DOES NOT show up in Disk Utility.

It is connected to the second ATA-66 bus. The original hard drive is connected to the 1st ATA-66 bus. The SuperDrive and a CD-RW we installed is on the ATA-33 bus.

The drive is I think set to Cable Select, but may be a Master.

Main thing that I can't believe is why it would show up in System Profiler but not Disk Utility.

He says it is because it was formatted as NTFS in its previous life. I say there is something else wrong.

It is his first Mac and he is kinda forced into using it (PC's motherboard broke). The easy of use has already awed him ("The disk images... they mount a disk and then the software didn't come with an installer, how do I install software?"). But this is something that is bugging me because it doesn't make sense.

Any advice?

MacsRgr8
Mar 2, 2005, 05:46 PM
If I'm not sure, I always make the drive master.

It doesn't matter which filesytem is on the drive, it should appear in DiskUtil. An NTFS (or FAT32) formatted drive should even be accessable for the Finder.

I would make sure the drive is set to master. Then, connect it to the 2nd ATA-66 bus making sure it is attached to the "end of the cable" (in the MDD the upper slot in the drive holder, connected to the last IDE cable connector, seen from the motherboard).

I can tell you that there is no problem connecting ALL the possible connections to all the ATA busses.
I have a MDD 1,25 GHz G4 (FW 800), with 4 internal hard drives, a Combo Drive, SuperDrive and Radeon 9800 Pro (yeah.. eats up the power leftovers :D ). All work well.

Must admit this particular Mac does make some noise.... :rolleyes: