PDA

View Full Version : "failed with exit code 1" error




nickculbertson
Apr 13, 2011, 07:14 AM
Hello,
I got this error last night and I'm still scratching my head about it.


Build Ukulele of project Ukulele with configuration Debug

Ld build/Ukulele.build/Debug-iphoneos/Ukulele.build/Objects-normal/armv6/Ukulele normal armv6
cd /Users/nickculbertson/Documents/GuitarApp
setenv IPHONEOS_DEPLOYMENT_TARGET 4.2
setenv PATH "/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2 -arch armv6 -isysroot /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.2.sdk -L/Users/nickculbertson/Documents/GuitarApp/build/Debug-iphoneos -F/Users/nickculbertson/Documents/GuitarApp/build/Debug-iphoneos -filelist /Users/nickculbertson/Documents/GuitarApp/build/Ukulele.build/Debug-iphoneos/Ukulele.build/Objects-normal/armv6/Ukulele.LinkFileList -dead_strip -miphoneos-version-min=4.2 -framework Foundation -framework UIKit -framework CoreGraphics -framework QuartzCore -framework AudioToolbox -framework AVFoundation -framework MediaPlayer -framework MessageUI -o /Users/nickculbertson/Documents/GuitarApp/build/Ukulele.build/Debug-iphoneos/Ukulele.build/Objects-normal/armv6/Ukulele

ld: ldr 12-bit displacement out of range (4096 max +/-4096) in _AudioServicesCreateSystemSoundID$stub in _AudioServicesCreateSystemSoundID$stub from /Users/nickculbertson/Documents/GuitarApp/build/Ukulele.build/Debug-iphoneos/Ukulele.build/Objects-normal/armv6/Ukulele
collect2: ld returned 1 exit status
Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2 failed with exit code 1


The project runs fine on both iPad and iPhone builds in the simulator and the iPad build works on the device. When I run the iPhone build on the device I get the error. Any thoughts?

Thanks,
Nick